在线检测未来函数

通达信三十系统指标公式

来源:Internet,编辑:股旁网,2012-12-13

VOLUME:VOL,VOLSTICK;
MAVOL30:MA(VOLUME,30),COLORRED,LINETHICK3;
E30:EMA(C,30),COLORMAGENTA;
庄30:EMA(WINNER(C)*70,30)*1000,COLORMAGENTA,LINETHICK3;
散30:EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,30)*1000,COLORGREEN,LINETHICK3;
铭30:MA(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),30)*1000;
VAR3:=LLV(HIGH,240);VAR4:=100*(CLOSE-VAR3)/VAR3;VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;VAR7:=0;VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;VARA:=BARSCOUNT(CLOSE);VARB:=VAR8<20 AND VAR9<23 AND VARA>35;VARC:VARB AND COUNT(VARB,1)=1;VARD:=EMA(CLOSE,21)-EMA(CLOSE,8);
VARE:=EMA(VARD,5);VARF:TROUGHBARS(3,6,1)<4 AND CROSS(VARD,VARE);
VAR10:IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);VAR1A:=EMA(VAR19,100);VAR1B:=2*(VAR19-VAR1A);VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));VAR1E:=EMA(VAR1D*0.97,3);VAR1F:=(HIGH+LOW+CLOSE)/3;VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV(VAR1F,14));VAR21:=MA(CLOSE,5);VAR22:=MA(CLOSE,13);VAR23:=MA(CLOSE,20);VAR24:=MA(CLOSE,34);VAR25:=MA(CLOSE,72);VAR26:=MA(CLOSE,125);VAR27:=MA(CLOSE,250);VAR28:=MA(CLOSE,250)<MA(CLOSE,125) AND MA(CLOSE,250)<MA(CLOSE,5);VAR29:=MA(CLOSE,5)>MA(CLOSE,250) AND MA(CLOSE,5)<MA(CLOSE,125);VAR2A:=VAR28 AND VAR29;VAR2B:=CROSS(VAR1E,LOW);VAR2C:=(VAR11+VAR13+VAR15+VAR17);VAR2D:=(VAR12+VAR14+VAR16+VAR18);VAR2E:=IF(YEAR<2018 AND VAR1B>0.1,VAR1C,0);VAR2F:=VAR10;VAR30:=VAR2F AND VARF AND VARC AND VAR2B AND VAR4<0 AND VAR5=0 AND VAR6=0 AND VAR20<(-110);大方强势买点: VAR2F>0 , , ;STICKLINE(大方强势买点>0,0,4,1,0), , ;DRAWTEXT(VAR20<-110 AND 大方强势买点>0,2,'强势买点'), , ;DRAWICON(大方强势买点>0,4.5,1);DRAWTEXT(VAR2F AND VARF AND VARC,2.8,'30%下单莫错过!'), , ;DRAWTEXT(VAR17,1.3,'变盘上涨'),COLORYELLOW , ;

通达信三十系统指标公式

 

相关文章