在线检测未来函数

通达信激光瞄准器主图指标公式

来源:Internet,编辑:股旁网,2012-12-13

P5:=30;
牛熊界:MA(CLOSE,P5),LINETHICK2,COLORWHITE;
KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100));
趋势线:=EMA(((KS / 10) + EMA(CLOSE,10)),3);
AA:= - 100 * (趋势线 - CLOSE) / 趋势线;
AC:=(EMA(AA,5) );
AG:=SUM((VOL / FINANCE(7)),1);
SSL:=EMA(CLOSE,3);
MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);
{MM:=(IF(((DATATYPE > 5) AND (DATATYPE < 9)),MA(MMV,1),IF((DATATYPE = 5),MA(MMV,4),IF((DATATYPE = 4),MA(MMV,8),IF((DATATYPE = 3),MA(MMV,16),IF((DATATYPE = 2),MA(MMV,32),0))))) );}
MM:=(MA(C,3)+MA(C,5)+MA(C,10)+MA(C,13)+MA(C,20))/5;
SA:=(MM * 0.985);
SS:=(MA(CLOSE,5));
DD:=(MA(CLOSE,13));
GG:=(MA(CLOSE,21));
短趋势:IF(((SSL > MM)),SSL,SA),LINETHICK1,COLORWHITE;
空方:IF(((SSL > MM) ),MM,SA),LINETHICK1,COLORFFFFFF;
多方:IF(((SSL > MM)),MM,SA),LINETHICK2,COLORFF00FF;
DRAWTEXT(多方-短趋势=0 ,多方*1.005 , '◆'),COLORBLUE,LINETHICK3;
VAR2Y:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR3Y:=(((CLOSE - REF(OPEN,29)) / REF(OPEN,29)) * 100);
VAR4Y:=REF(CLOSE,1);
VAR5Y:=((SMA(MAX((CLOSE - VAR4Y),0),6,1) / SMA(ABS((CLOSE - VAR4Y)),6,1)) * 100);
VAR6Y:=((SMA(MAX((CLOSE - VAR4Y),0),12,1) / SMA(ABS((CLOSE - VAR4Y)),12,1)) * 100);
VAR7Y:=((SMA(MAX((CLOSE - VAR4Y),0),24,1) / SMA(ABS((CLOSE - VAR4Y)),24,1)) * 100);
VAR8Y:=(((CLOSE - LLV(LOW,45)) / (HHV(HIGH,45) - LLV(LOW,45))) * 100);
VAR9Y:=SMA(VAR8Y,3,1);
VARAY:=SMA(VAR9Y,3,1);
VARBY:=((3 * VAR9Y) - (2 * VARAY));
VARCY:=(CROSS(VAR5Y,10) AND (VAR3Y < (0 - (28 * 20))));
VARDY:=((100 - CROSS(76,VAR5Y)) AND (VAR3Y > (5 * 20)));
DRAWICON(((CROSS(76,VAR5Y) AND (VAR3Y > 5)) ),(HIGH * 1.0099),5),COLORFFFFFF;
VAREY:=((((CROSS(VAR9Y,VARAY) AND (VARAY < 10)) AND (VAR3Y < (0 - 30))) AND (VAR2Y > 3)) * 30);
VARFY:= - ((((VARAY < 11) AND (VAR5Y < 15)) AND (VAR3Y < (0 - 26))) * 10);
DRAWICON((CROSS(VARFY,(0 - 9))),(LOW * 0.998),4);
能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) * 4)));
VAR3C:=EMA(能量线,1);
VAR4C:=REF(能量线,1);
STICKLINE(((VAR3C > VAR4C)),VAR3C,VAR4C,7.5,0),COLOR00FFFF;
X:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);
Y:=EMA(CLOSE,10);
LL:=REF(CLOSE,2);
MM2:=((SMA(MAX((CLOSE - LL),0),6,1) / SMA(ABS((CLOSE - LL)),6,1)) * 100);
DB:=IF(((MM2 < REF(MM2,1)) AND (MM2 > 79)),MM2,0);
DRAWICON(CROSS(Y,X),(LOW * 0.985),1),LINETHICK3,COLORRED;
DRAWICON(CROSS(X,Y),(HIGH * 1.02),2),LINETHICK2,COLOR00FF00;
DRAWTEXT(DB,(HIGH * 1.02),'↓顶'),LINETHICK2,COLOR00FF00;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
DD2:=EMA(((0.667 * REF(AK1,1)) + (0.333 * AK1)),2);
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((((CLOSE - VAR3) / (VAR4 - VAR3)) * 100),3);
VAR6:=((AK + VAR5) / 2);
VAR7:=EMA(((0.667 * REF(VAR5,1)) + (0.333 * AK1)),2);
VAR8:=EMA(VAR6,5);
BB:=EMA(((0.667 * REF(VAR8,1)) + (0.333 * VAR8)),2);
AB:=CROSS(AK1,AK);
BB1:=(CROSS(AK1,BB) AND (BB < 30));
CD:=(BB1 * 0.6);
DRAWTEXT((CD = 0.6),(LOW * 0.99),'↑底2'),LINETHICK1,COLOR33CC99;
DRAWTEXT((AB = 1),(LOW * 0.99),'↑底1'),LINETHICK1,COLORWHITE;
C1:=(CLOSE+LOW+HIGH)/3;
C2:=EMA(C1,6);
C3:=EMA(C2,5);
C4:=CROSS(C2,C3);
DRAWTEXT(C4,LOW/1.01,'★'),LINETHICK3,COLORRED;
C5:=CROSS(C3,C2);
DRAWTEXT(C5,HIGH*1.03,'★'),LINETHICK3,COLORBLUE;

通达信激光瞄准器主图指标公式

 

相关文章