在线检测未来函数

通达信江恩法则5.0主图指标公式

来源:Internet,编辑:股旁网,2012-12-14

N:=17;
GDFZ0:=C;
GDFZ1:=H;
GDFZ2:=L;
TYA:=((((((((((GDFZ2 + GDFZ1) + GDFZ0) + REF(GDFZ0,1)) + REF(GDFZ2,1)) + REF(GDFZ1,1)) + REF(GDFZ0,2)) + REF(GDFZ2,2)) + REF(GDFZ1,2)) / 9));
HDA:=(((((HHV(TYA,(17 * 2)) + REF(HHV(TYA,(17 * 2)),1)) + REF(HHV(TYA,(17 * 2)),2)) + REF(HHV(TYA,(17 * 2)),3)) + REF(HHV(TYA,(17 * 2)),4)) / 5);
LDA:=(((((LLV(TYA,(17 * 2)) + REF(LLV(TYA,(17 * 2)),1)) + REF(LLV(TYA,(17 * 2)),2)) + REF(LLV(TYA,(17 * 2)),3)) + REF(LLV(TYA,(17 * 2)),4)) / 5);
A1:=(REF(HDA,1) = (HHV(TYA,((2 * N) + 0))));
B1:=(FILTER(A1,N));
HD:=(FILTER(B1,N));
A2:=(REF(LDA,1) = (LLV(TYA,((2 * N) + 0))));
B2:=(FILTER(A2,N) );
LD:=(FILTER(B2,N));
A:=(REF(HDA,BARSLAST(HD)));
B:=(REF(LDA,BARSLAST(LD)));
T1:=((BARSLAST(HD) < BARSLAST(LD)) AND (NOT(HD)));
T2:=((BARSLAST(HD) > BARSLAST(LD)) AND (NOT(LD)));
BF:=IF(T1,A,A);
HH:=MA(BF,1);
BG:=IF(T2,B,B);
LL:=MA(BG,1);
HH1:=(BARSLAST((GDFZ0 > (REF(HH,1) * 1.003))));
LL1:=(BARSLAST((GDFZ0 < (REF(LL,1) * 0.997))));
IF((HH1 < LL1),LL,DRAWNULL),,COLOR00FFFF;
IF((HH1 > LL1),HH,DRAWNULL),LINETHICK2,COLORFFFFFF;
DRAWICON(CROSS(HH1,LL1),HH,2);
DRAWICON(CROSS(LL1,HH1),LL,1);
STICKLINE((HH1 < LL1),OPEN,CLOSE,3,0),COLORRED;
STICKLINE((HH1 < LL1),HIGH,LOW,0,0),COLORRED;
STICKLINE((HH1 > LL1),OPEN,CLOSE,3,0),COLORFF00FF;
STICKLINE((HH1 > LL1),HIGH,LOW,0,0),COLORFF00FF;

通达信江恩法则5.0主图指标公式

 

相关文章