在线检测未来函数

同花顺顶底买卖主图指标公式

来源:Internet,编辑:股旁网,2012-12-16

Y1: IF(DATE>=1080630,EMA(EMA(EMA(EMA(CLOSE,3),3),3),3),0),LINETHICK1,COLOR0000FF;
y2: IF(DATE>=1080630,EMA(REF(Y1,1),3),0),LINETHICK1,COLOR00FFFF;
w3: EMA(EMA(EMA(EMA(EMA(CLOSE,65),3),3),3),3),LINETHICK1,COLORFF0000;
AA:= MA(WINNER(CLOSE*0.95)*100,3);
VAR83:= 1/WINNER(CLOSE);
VAR84:= (CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR85:= 100-ABS(VAR84);
VAR86:= 3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR87:= 3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR88:= 100-VAR87;
VAR89:= 100-VAR86;
VAR90:= MA(WINNER(CLOSE*0.95)*100,3);
VAR91:= IF(VAR83>5,IF(VAR83<100,VAR83,VAR85-10),0);
VAR92:= MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR93:= 100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR94:= 100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR95:= VAR93<REF(VAR94,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VARA:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VARB:= SMA(VARA,3,1);
VARC:= SMA(VARB,3,1);
探索:= EMA(3*VARB-2*VARC,3);
主力:= (-1)*(EMA(VAR89,1)-50)+50;
Z1:= MA(主力,9);
VARD:= (-1)*(EMA(VAR89,1)-50)+50;
VARE:= (-1)*(EMA(VAR89,12)-50)+50;
LCC:= REF(CLOSE,1);
RSI1:= SMA(MAX(CLOSE-LCC,0),6,1)/SMA(ABS(CLOSE-LCC),6,1)*100;
天涯:= IF(RSI1>93 OR AA>90 AND RSI1>80,80,100);
苦海:= EMA(100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)),6);
ZS:= MA(探索,3);
ZM:= MA(MA(探索,3),3);
A11:= 3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1);
黑马线:= EMA(A11,5);
A12:= (黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A4:= (CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
趋势线3:= MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2);
A5:= (HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;
N:= 3;
VAR1:= REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:= SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:= EMA(VAR2,10);
VAR4:= LLV(LOW,33);
VAR5:= EMA(IF(LOW<=VAR4,VAR3,0),5);
VAR6:= REF(CLOSE,1);
VAR7:= SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
VAR8:= LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;
VAR9:= CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
VAR10:= VAR8 AND VAR9;
VAR11:= (2*CLOSE+HIGH+LOW)/4;
VAR12:= LLV(LOW,13);
VAR13:= HHV(HIGH,13);
VAR14:= LLV(LOW,1)=LLV(LOW,35) AND DATE<=1080701 AND CLOSE>=OPEN*1.04;
VAR15:= CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
VAR16:= EMA((VAR11-VAR12)/(VAR13-VAR12)*100,13);
VAR17:= ((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
VAR18:= 1/WINNER(CLOSE);
VAR19:= MA(CLOSE,13);
VAR20:= 100-ABS((CLOSE-VAR19)/VAR19*100);
VAR21:= LLV(LOW,75);
VAR22:= HHV(HIGH,75);
VAR23:= (VAR22-VAR21)/100;
VAR24:= SMA((CLOSE-VAR21)/VAR23,20,1);
VAR25:= SMA((OPEN-VAR21)/VAR23,20,1);
VAR26:= 3*VAR24-2*SMA(VAR24,15,1);
VAR27:= MA(HHV(HIGH,485),17);
VAR28:= MA(HHV(HIGH,222),17);
VAR29:= MA(HHV(HIGH,96),17);
VAR30:= MA(LLV(LOW,485),17);
VAR31:= MA(LLV(LOW,222),17);
VAR32:= MA(LLV(LOW,96),17);
VAR33:= MA((VAR30*0.96+VAR31*0.96+VAR32*0.96+VAR27*0.558+VAR28*0.558+VAR29*0.558)/6,17);
VAR34:= MA((VAR30*1.25+VAR31*1.23+VAR32*1.2+VAR27*0.55+VAR28*0.55+VAR29*0.65)/6,17);
VAR35:= MA((VAR30*1.3+VAR31*1.3+VAR32*1.3+VAR27*0.68+VAR28*0.68+VAR29*0.68)/6,17);
VAR36:= LLV(LOW,30);
VAR37:= MA((VAR33*3+VAR34*2+VAR35)/6*1.738,17);
VAR38:= IF(DATE>=1080630,VAR37,VAR37*DAY);
VAR39:= LOW;
VAR40:= REF(LOW,1);
VAR41:= SMA(ABS(VAR39-VAR40),3,1)/SMA(MAX(VAR39-VAR40,0),N,1)*100;
VAR42:= MA(IF(CLOSE*1.35<=VAR38,VAR41*10,VAR41/10),N);
VAR43:= HHV(VAR42,30);
VAR44:= 1080630;
VAR45:= 3*VAR25-2*SMA(VAR25,15,1);
VAR46:= 100-VAR45;
VAR47:= IF(900101<DATE AND DATE<99991232,1,0);
VAR49:= REF(LOW,1)*0.9;
VAR50:= LOW*0.9;
VAR51:= (VAR50*VOL+VAR49*(CAPITAL-VOL))/CAPITAL;
VAR52:= EMA(VAR51,30);
VAR53:= CLOSE-REF(CLOSE,1);
VAR54:= MAX(VAR53,0);
VAR55:= ABS(VAR53);
VAR56:= SMA(VAR54,7,1)/SMA(VAR55,7,1)*100;
VAR57:= SMA(VAR54,13,1)/SMA(VAR55,13,1)*100;
VAR58:= BARSCOUNT(CLOSE);
VAR59:= SMA(MAX(VAR53,0),6,1)/SMA(ABS(VAR53),6,1)*100;
VAR60:= (-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR61:= (CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR62:= SMA((SMA(VAR61,4,1)-50)*2,3,1);
VAR63:= (INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR64:= SMA(VAR63,4,1);
VAR65:= SMA(VAR64,3,1);
VAR66:= (HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR67:= VAR59<=25 AND VAR60<(-95) AND DATE<=1080701 AND VAR66>20 AND VAR62<(-30) AND VAR65<30 AND VAR52-CLOSE>=(-0.25) AND VAR56<22 AND VAR57<28 AND VAR58>50;
VAR68:= (HIGH+LOW+CLOSE)/3;
VAR69:= (VAR68-MA(VAR68,14))/(0.015*AVEDEV(VAR68,14));
VAR70:= (VAR68-MA(VAR68,70))/(0.015*AVEDEV(VAR68,70));
VAR71:= IF(VAR69>=150 AND VAR69<200 AND VAR70>=150 AND VAR70<200,10,0);
VAR72:= IF(VAR69<=(-150) AND VAR69>(-200) AND VAR70<=(-150) AND VAR70>(-200),-10,VAR71);
VAR73:= (CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR74:= REVERSE(VAR73);
VAR75:= SMA(VAR73,3,1);
绝佳买点:= IF(DATE<=VAR44,MA(IF(LOW<=VAR36,(VAR42+VAR43*2)/2,0),N),100000000);
跑:= FILTER(REF(黑马线,1)>90 AND A12<0 AND DATE<=1080631,7);
买线:= EMA(CLOSE,2);
卖线:= EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
AA:= 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1);
BB:=2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
位置:=(AA-BB);
抄底:= CROSS(位置,10) AND DATE>=1080631;
A1:= VOL=HHV(VOL,120);
A2:= CLOSE/OPEN>1.05;
TJ:= A1 AND A2;
龙:= VAR10;
买4:= VAR14;
AA1:= AMOUNT/VOL AND DATE>=1080701;
BB1:= LOW<AA1*0.9;
CC1:= (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
DD1:= LOW<MA(CLOSE,5)*0.921;
EE1:= VOL<MA(VOL,5)*1.5;
FF1:= BB1 AND CC1 AND DD1 AND EE1;
买3:= FILTER(FF1,3) AND DATE>=1080630;
二十天最低跌幅:= HHV(CLOSE,20)/LLV(CLOSE,20);
RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:= SMA(RSV,3,1);
D:= SMA(K,3,1);
J:= 3*K-2*D;
X:= LLV(J,2)=LLV(J,8);
买1:= CROSS(J,REF(J+0.01,1)) AND X AND J<20 AND 二十天最低跌幅>=1.3 AND DATE<=1080630;
长期底部:= LLV(HIGH,30);
上:= SMA(LOW,5,2)*0.96;
短期底部:= LLV(HIGH,30)*0.93;
LC:= REF(CLOSE,1);
RSI:= SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
大顶:= FILTER(VAR17>20 AND FILTER(VAR17<REF(VAR17,1),5) AND DATE<=1080701,5);
VAR76:= (OPEN+LOW+HIGH+CLOSE)/4;
MAN:= SMA(HIGH,21,2)*1.05;
短底2:= EMA(VAR76,5);
支撑:= HHV(短底2,60);
VAR77:= (HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR78:= SMA(VAR77,5,1);
VAR79:= SMA(VAR78,8,1);
VAR80:= CROSS(VAR78,VAR79) AND VAR79<5;
VAR81:= CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR80;
VAR82:= IF(CLOSE>1000,VAR80,VAR81);
黑马起步:= VAR82;
逃:= FILTER(HIGH>支撑 AND CLOSE<支撑 AND CLOSE/OPEN>0-1.06 AND CLOSE<OPEN,5) AND DATE<=1080701;
逃命:= 黑马起步>0 AND DATE>=1080531;
选逃:= FILTER(逃命 OR 逃 OR CROSS(84,RSI) OR 大顶,3) AND DATE>=1080701;
上线:= SMA(CLOSE,6.5,1);
下线:= SMA(CLOSE,13.5,1);
WW:= DATE>=1080531;
散户:= SMA(VAR75,3,1)*VAR47*WW;
新庄:= SMA(散户,3,1)*VAR47*WW;
高抛:= CROSS(新庄,散户) AND 新庄>75 AND DATE>=1080701;
买入= CROSS(买线,卖线) AND DATE>=1080701;
卖出:= CROSS(卖线,买线) AND DATE>=1080701;
大黑马:= CROSS(趋势线3,0) AND 黑马线<40 AND DATE>=1080701;
大买:= FILTER(绝佳买点>30000,5) AND DATE>=1080701;
选底:= FILTER(LOW<=上 AND HIGH>=短期底部 AND CLOSE>=长期底部 AND CLOSE/OPEN>1.03,3) AND DATE<=1080701;
稳赚10买:= FILTER(买3 OR 选底,3) AND COUNT(买1+买4+龙,3)>0 AND DATE>=1080701;
资金进场:= VAR95 AND COUNT(VAR95,30)=1 AND DATE<=1080701;
STICKLINE(买线>=卖线 AND DATE>=1080701,LOW,HIGH,1,0),COLOR0000FF;
STICKLINE(买线>=卖线 AND DATE>=1080701,CLOSE,OPEN,4.5,0),COLOR0000AA;
STICKLINE(买线>=卖线 AND DATE>=1080701,CLOSE,OPEN,4,0),COLOR0000CC;
STICKLINE(买线>=卖线 AND DATE>=1080701,CLOSE,OPEN,3,0),COLOR0000CC;
STICKLINE(买线>=卖线 AND DATE>=1080701,CLOSE,OPEN,2,0),COLOR0000EE;
STICKLINE(买线<卖线 AND DATE>=1080701,CLOSE,OPEN,4.5,0),COLORAAAA00;
STICKLINE(买线<卖线 AND DATE>=1080701,CLOSE,OPEN,4,0),COLORBBBB00;
STICKLINE(买线<卖线 AND DATE>=1080701,CLOSE,OPEN,3,0),COLORCCCC00;
STICKLINE(买线<卖线 AND DATE>=1080701,CLOSE,OPEN,2,0),COLOREEEE00;
STICKLINE(买线<卖线 AND DATE>=1080701,LOW,HIGH,1,0),COLORFFFF00;
选买:= FILTER(买3 OR 选底,3) AND COUNT(买1+买4+龙,3)>0 AND DATE>=1080701;
STICKLINE(选买 AND DATE>=1080701,CLOSE,HHV(HIGH,90)*0.94,0.3,0),COLORFF0000;
DRAWTEXT(选买 AND DATE>=1080701,HHV(HIGH,90)*1,'稳赚'),COLORFF0000;
DRAWTEXT(选买 AND DATE>=1080701,HHV(HIGH,90)*0.97,'10%买'),COLORFF0000;
DRAWTEXT(选逃,HIGH*1.04,'逃'),COLOR00FFFF;
DRAWTEXT(买入,LOW*0.996,'买'),COLOR0000FF;
DRAWTEXT(卖出,HIGH*1,'卖'),COLOR00FFFF;
DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,HIGH*1.095,'大资金'),COLOR008000;
DRAWTEXT(VAR95 AND COUNT(VAR95,30)=1,HIGH*1.06,'进场'),COLOR008000;
DRAWTEXT(跑,HIGH*1.02,'跑'),COLOR00FFFF;
DRAWTEXT(大黑马,LOW*0.98,'大黑马'),COLORFFFFFF;
DRAWTEXT(CROSS(新庄,散户) AND 新庄>75,HIGH*1.04,'抛'),COLOR00FFFF;
DRAWTEXT(大买,LOW*0.96,'大买'),COLOR0000FF;
DRAWTEXT(IF(选底,100,0),LOW*0.995,'底'),COLOR399C71;
VAR330:= DATE>1080621 AND (DAY=1 OR DAY=16);
位置:= (CLOSE+REF(CLOSE,105))/2;

同花顺顶底买卖主图指标公式

 

相关文章