在线检测未来函数

通达信MACD卖出指标公式

来源:Internet,编辑:股旁网,2012-12-16

N:=2;M:=3;
VAR11:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VAR11),40,2);
VAR12:=REF(C,1);
VAR13:=SMA(MAX(C-VAR12,0),6,1)/SMA(ABS(C-VAR12),6,1)*100;
DRAWTEXT(CROSS(84,VAR13),50,'S'),COLORGREEN ;
VAR2:=1;
VAR3:=REF(HIGH,1)*1.1;
VAR4:=HIGH*1.1;
VAR5:=(VAR4*VOL+VAR3*(CAPITAL-VOL))/CAPITAL;
VAR6:=REF(LOW,1)*0.9;
VAR7:=LOW*0.9;
VAR8:=(VAR7*VOL+VAR6*(CAPITAL-VOL))/CAPITAL;
VAR9:=EMA(VAR8,30);
VARA:=EMA(VAR5,30);
VARB:=VARA-2;
VARC:=IF(CLOSE<=VAR9,VARB,VARA);
VARD:=MA(CLOSE,80)-MA(CLOSE,10)/17;
买点: STICKLINE(VARC-VARB=0 AND VAR2 AND CROSS((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,MA((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,M)),30,0,2,0),COLORRED;
写字: DRAWTEXT(FILTER(VARC-VARB=0 AND CROSS((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,MA((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,M)),4),45,'B'),COLORRED;
VARE:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
卖出线:=SMA(SMA(VARE,3,1),3,1);
买入线:=3*SMA(VARE,3,1)-2*卖出线;
DRAWICON(CROSS(90,买入线),25,2);
{以下设置"买卖点"的买点}
VAR4A:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR5A:=SMA(VAR4A,13,8);
VAR8A:=EMA(C,5);
VAR9A:=MA((LLV(C,9))*1.1,14);
VAR10A:=2*VAR9A-VAR8A-C*0.1;
VAR11A:=IF(((VAR8A-VAR10A)*5>0),(POW((VAR8A-VAR10A)*5,2))/10,(-1*(POW((VAR8A-VAR10A)*
(5),2)))/(10));
VAR12A:=IF((VAR11A>0),VAR11A-0,12);
VAR13A:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;
趋势:=CEILING(SMA(VAR5A,13,8)),LINETHICK2,COLOR0000FF;
STICKLINE(FILTER(CROSS(趋势,VAR12A)AND 趋势>REF(C,1) OR 趋势>REF(趋势,1)AND 趋势<35
AND C>REF(C,1),5),0,20,1,0),COLORMAGENTA;
DRAWTEXT(FILTER(CROSS(趋势,VAR12A)AND 趋势>REF(C,1) OR 趋势>REF(趋势,1)AND 趋势<35
AND C>REF(C,1),5),35,'B'),COLORRED;
{以下设置"追涨买入"的买点}
空:=EMA(C,5);
均衡:=EMA(空,5);
中轨:=HHV(MA(H,13),13);
追涨买入:IF(FILTER(均衡>REF(均衡,1)AND 中轨<REF(中轨,1)AND C>REF(C,1),11),45,0),COLORWHITE;
DRAWTEXT(FILTER(均衡>REF(均衡,1)AND 中轨<REF(中轨,1)AND C>REF(C,1),11),60,'追涨'),COLORWHITE;
{以下设置"筹码突破点"的突破点}
主筹估算:=EMA(WINNER(C)*70,3);
散筹估算:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,3);
筹码突破见高卖:CROSS(主筹估算,散筹估算),COLORGREEN;
STICKLINE(CROSS(主筹估算,散筹估算),0,50,0.5,0),COLORGREEN;
DRAWTEXT(CROSS(主筹估算,散筹估算),70,'S'),COLORGREEN;
DRAWTEXT(CROSS(主筹估算,散筹估算),65,' /T+0'),COLORRED;

通达信MACD卖出指标公式

 

相关文章