在线检测未来函数

通达信最牛波段底指标公式

来源:Internet,编辑:股旁网,2012-12-19

N:=10;M:=150;
{黄金分割线}
顶1:=REFDATE(HHV(H,M),DATE);
底1:=REFDATE(LLV(L,M),DATE);
H5:=顶1-(顶1-底1)*0.98;
%80.9:REFDATE(H5,DATE),COLOR666666,LINETHICK2,COLORYELLOW;
底部:REFDATE(底1,DATE),COLOR666666,LINETHICK4;
DRAWTEXT(ISLASTBAR,%80.9,' 80.9%'),COLORMAGENTA,LINETHICK2;
DRAWTEXT(ISLASTBAR,底部,' 底部'),COLORRED,LINETHICK4;
VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2:=REF(VAR1,1);
VAR3:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;
HY3:=IF(COUNT(VAR3<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND
CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(HY3,LOW*0.99,'→◆●注意买入'),COLORLIRED;
EMA3:EMA(C,3),COLORWHITE,LINETHICK2,NODRAW;
EMA13:EMA(C,13),COLORYELLOW,NODRAW;
EMA21:EMA(C,21),COLORFF00FF,NODRAW;
EMA55:EMA(C,55),COLORGREEN,NODRAW;
AR1:=EMA21>EMA13 AND EMA13>EMA3;
AR2:=BARSLAST((C-EMA3)/EMA3*100<-6);
AR3:=EMA3>=REF(EMA3,2);
AR4:=COUNT(CROSS(C,EMA3),AR2)=1;
AR5:=AR1 AND AR2 AND AR3 AND AR4;
AR6:=AR5 AND FILTER(AR5,10);
DRAWTEXT(AR6,L-0.09,'红启动'),COLORYELLOW;
{STICKLINE(AR6,H,L,0.5,1),COLORYELLOW;}
{STICKLINE(AR6,O,C,6,1),LINETHICK2,COLORYELLOW;}
BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
BR2:=ABS((EMA3-EMA13)+(EMA13-EMA21))/C<0.2;
BR3:=C>EMA21 AND (REF(C,1)<REF(EMA21,1) OR REF(C,2)<REF(EMA21,2) OR REF(C,3)<REF(EMA21,3) OR REF(C,4)<REF(EMA21,4) OR REF
(C,5)<REF(EMA21,5));
{波段顶底}
DRAWTEXT(CROSS(REF(ZIG(3,19),1),ZIG(3,19)),HIGH*1.01,'波段顶'),COLORYELLOW;
DRAWTEXT(CROSS(ZIG(3,19),REF(ZIG(3,19),1)),LOW*0.99,'【波段底】'),COLORWHITE;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.97),'老鼠仓'),COLOR4080FF;
NK:=74,NODRAW;
MK:=3,NODRAW;
PC:(C+REF(C,1)+O)/3,NODRAW;
高:=REF(HHV(H,N),M),NODRAW;
低:=REF(LLV(L,N),M),NODRAW;
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
低点:REFDATE(低,DATE),COLORWHITE;
DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE;

通达信最牛波段底指标公式

 

相关文章