在线检测未来函数

通达信金手指标公式

来源:Internet,编辑:股旁网,2012-12-17

N1:=5;N2:=8;N3:=13;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORRED,LINETHICK2;
RSI2:=SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),N3,1)/SMA(ABS(CLOSE-LC),N3,1)*100;
DRAWICON(CROSS(RSI1,20),20,23);
WLT11:=CROSS(RSI1,RSI2);
WLT22:=COUNT(WLT11,20)=2;
DRAWICON(FILTER(WLT22 AND RSI1<50,5),RSI2,23);
{DRAWICON(CROSS(RSI1,RSI2) AND RSI1<50,RSI2,23);}
SAL:=FILTER(CROSS(80,RSI1) AND RSI1<REF(RSI1,1),8);
DRAWICON(SAL,80,15);
{DRAWICON(CROSS(80,RSI1) AND RSI1<REF(RSI1,1),80,15);}
DRAWBAND(RSI1,RGB(255,50,50),RSI2,RGB(0,0,220));
STICKLINE(CROSS(RSI1,20) AND (CROSS(RSI1,RSI2) AND RSI1<50),20,0,4,0 ),COLOR000099;
STICKLINE(CROSS(RSI1,20) AND (CROSS(RSI1,RSI2) AND RSI1<50),20,0,3,0 ),COLOR0000BB;
STICKLINE(CROSS(RSI1,20) AND (CROSS(RSI1,RSI2) AND RSI1<50),20,0,1.5,0 ),COLOR0000DD;
STICKLINE(CROSS(RSI1,20) AND (CROSS(RSI1,RSI2) AND RSI1<50),20,0,0.3,0 ),COLOR0000FF;
VAR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)/28.57;
VAR4:=EMA(VAR3,5);
操盘:=3*VAR3-2*VAR4;
D1:=CROSS(操盘,VAR3) AND VAR3<2.1 AND C>O;
STICKLINE(D1,20,0,4,0),COLOR008888;
STICKLINE(D1,20,0,3,0),COLOR00AAAA;
STICKLINE(D1,20,0,2,0),COLOR00CCCC;
STICKLINE(D1,20,0,1,0),COLOR00EEEE;
STICKLINE(D1,20,0,0.3,0),COLOR00FFFF;
DRAWTEXT(D1,41,'全'),COLORFFFFFF;
DRAWTEXT(D1,35,'仓'),COLORFFFFFF;
{DMI:0上金叉,主升>20黄彩带专抓主升段,在调整及熊市行情中会走出背离趋势}
N:=13;M:=5;
TRR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/TR;
MDI:=DMM*100/TR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=EXPMEMA(ADX,M);
{DRAWBAND(ADX,RGB(255,255,0),ADXR,RGB(0,255,0));}
主升:PDI,COLOR0000FF,LINETHICK2;
主跌:=MDI,COLORFFFFFF,LINETHICK0;
天:80,COLORFF0000,POINTDOT,LINETHICK2;
地:20,COLORFF00FF,POINTDOT,LINETHICK4;
TJJ:=主升>20 AND ADX>ADXR;
TJ11:=主升>20 AND ADX<ADXR;
TJ22:=主升<=20 AND ADX>ADXR;
TJ33:=主升<=20 AND ADX<ADXR;
STICKLINE(TJJ,主升,20,0.1,0),COLORRED;
STICKLINE(TJ11,主升,20,0.1,0),COLORDDDD00;
STICKLINE(TJ22,主升,20,0.1,0),COLORDD00DD;
STICKLINE(TJ33,主升,20,0.1,0),COLOR00DD00;
STICKLINE(CROSS(ADX,主跌) AND 主跌<20 AND ADX>ADXR,20,10,4,0),COLOR990099;
STICKLINE(CROSS(ADX,主跌) AND 主跌<20 AND ADX>ADXR,20,10,2,0),COLORBB00BB;
STICKLINE(CROSS(ADX,主跌) AND 主跌<20 AND ADX>ADXR,20,10,1,0),COLORDD00DD;
STICKLINE(CROSS(ADX,主跌) AND 主跌<20 AND ADX>ADXR,20,10,0.5,0),COLORDD00FF;
DRAWICON(CROSS(ADX,ADXR) AND 主跌<20,20,23);
D2:=CROSS(ADX,主跌) AND 主跌<20 AND ADX>ADXR;
D33:=COUNT(D1 OR D2,3)>=2;
D66:=D1 AND D2;
DRAWICON(FILTER(D33,5),0,23);
DRAWICON(FILTER(D66,13),0,23);

通达信金手指标公式

 

相关文章