在线检测未来函数

通达信落带为安主图指标公式

来源:Internet,编辑:股旁网,2012-12-17

RSV:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
TJ:=D<10;
TJ1:=D>90;
上边线:IF(BARSLAST(TJ),REF(HIGH,BARSLAST(TJ)),DRAWNULL),COLORWHITE;
下边线:IF(BARSLAST(TJ),REF(LOW,BARSLAST(TJ)),DRAWNULL),COLORMAGENTA;
安全带:STICKLINE(D,上边线*0.996,下边线*1.005,8,0),COLORBROWN;
STICKLINE(C>O,O,C,3,1),COLORRED;
STICKLINE(C>O,H,C,0,0),COLORRED;
STICKLINE(C>O,L,O,0,0),COLORRED;
STICKLINE(C<O,O,C,3,0),COLORCYAN;
STICKLINE(C<O,H,L,0,1),COLORCYAN;
STICKLINE(TJ,O,C,2,0),COLORFF00FF;
STICKLINE(TJ1,O,C,2,0),COLORGREEN;
{涨停板立体K线}
A:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=9.8/100;
STICKLINE(A AND CLOSE=OPEN AND HIGH=LOW,REF(CLOSE,1),H,0,0),COLORGREEN,LINETHICK1;
B:=(REF(CLOSE,1)-CLOSE)/CLOSE>=9.8/100;
STICKLINE(B AND CLOSE=OPEN AND HIGH=LOW,REF(CLOSE,1),H,0,0),COLORGREEN,LINETHICK1;
STICKLINE(B,H,L,0,0),COLORGREEN,LINETHICK2;
STICKLINE(B,O,C,3.5,0),COLOR008800;
STICKLINE(B,O,C,2,0),COLOR00AA00;
STICKLINE(B,O,C,1,0),COLOR00CC00;
STICKLINE(B,O,C,0.2,0),COLOR00FF00;
STICKLINE(A,H,L,0,0),COLORYELLOW,LINETHICK2;
STICKLINE(A,O,C,3.5,0),COLOR008888;
STICKLINE(A,O,C,2,0),COLOR00AAAA;
STICKLINE(A,O,C,1,0),COLOR00CCCC;
STICKLINE(A,O,C,0.2,0),COLOR00FFFF;
{地域板块、所属行业、所属概念,主图显示}
DRAWTEXT_FIX(ISLASTBAR ,0.10,0.01,1,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.18,0.01,1,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.36,0.01,1,GNBLOCK),COLORWHITE;

通达信落带为安主图指标公式

 

相关文章