在线检测未来函数

通达信短线看涨指标公式

来源:Internet,编辑:股旁网,2012-12-17

T0:=IF(TIME>093000 AND TIME<094500 ,1,0);
T1:=IF(TIME>093100 AND TIME<145500 ,1,0);
T2:=IF(TIME>100000 AND TIME<145500 ,1,0);
T3:=IF(TIME>140000 AND TIME<145500 ,1,0);
T4:=IF(TIME>142500 AND TIME<145500 ,1,0);
涨幅:=DYNAINFO(14)*100;
CCT:=DYNAINFO(8);
PPP:= FILTER(CCT=0,350) ;
DRAWTEXT(PPP,45,'★今日该股票未开盘,不能分析★'),COLORFF00FF;
VAR80:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,3,0);
VAR81:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR83:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR85:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR87:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
NN1:=VAR80;
NN2:=(VAR81+VAR83+VAR85+VAR87);
VAR82:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR84:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR86:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR88:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
MM1:=(VAR82+VAR84+VAR86+VAR88);
MM2:= IF(MM1>0,-500,0);
MM:= IF(C>1000,MM2*100,MM2),COLORRED,LINETHICK3;
CT:SUM(MM,0) AND T1=1;{统计}
五指山:EMA((CLOSE-LLV(CLOSE,55))/(HHV(CLOSE,55)-LLV(LOW,55))*100,5),LINETHICK1,COLORFF00FF;
M1:= (7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1),2,1)),COLORWHITE;
万泉河: EMA(MA(M1,5),3),LINETHICK1,COLORFFFF00;
WH:=五指山;
WL:=万泉河;
CA:=IF(T1=1 AND WH>80 AND CT=1,1,0);
P4:= FILTER(CA=1,350);
DDC:=' ★提醒:短线看跌,紫线高点出局!本信号若消失则可能转升。';
DRAWTEXT(P4,45,DDC),COLORGREEN;
VARM1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VARM2:=SMA(VARM1,3,1);
VARM3:=SMA(VARM2,3,1);
VARM4:=SMA(VARM3,3,1);
A:=EMA(WINNER(CLOSE),10);
B:=EMA(WINNER(CLOSE),34);
AAD:=MA(CLOSE,32);
BAD:=MA(CLOSE,12);
DDD:=CROSS(B,A);
AAC:=MA(C,1);
BBB:=MA(AAD,2);
VAR51:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;
BB:=SMA(VAR51,7,1);
VAR67:=(LOW+HIGH+CLOSE)/3;
VAR68:=(VAR67-MA(VAR67,14))/(0.015*AVEDEV(VAR67,14));
WR30:=100*(HHV(HIGH,79)-CLOSE)/(HHV(HIGH,79)-LLV(LOW,79));
VAR21:=(2*CLOSE+HIGH+LOW+OPEN)/5;
VAR22:=LLV(LOW,34);
VAR23:=HHV(HIGH,34);
SK1:=EMA((VAR21-VAR22)/(VAR23-VAR22)*100,13);
WR31:=IF(WR30=0 OR SK1>=90 OR VAR68>-250,100,WR30);
舟:IF(NN1>0 OR NN2>0,35,DRAWNULL)*2,STICK,COLORMAGENTA,LINETHICK3;
岸:(T1=1 AND CT=0 AND SK1=100 OR T1=1 AND CT=0 AND SK1>0 AND WR30>98 AND SK1<=13)*60,STICK,COLORMAGENTA,LINETHICK1;
花:EMA(IF(WL<15 AND T3=1 AND L<= LLV(L,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),30,1),0),3)*25,STICK,COLORYELLOW,LINETHICK3;
W1:=CROSS(M1,WL);
N1:=WH<35 AND WH > MA(REF(WH,3),3) AND CT=0 AND T2=1 AND 涨幅<8;
技:IF(W1=1 AND N1=1,75,0),STICK,COLORRED,LINETHICK3;
P2:= FILTER(技,16) ;
DRAWTEXT(P2,25,'←短底'),COLORYELLOW,LINETHICK1;
VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3));
看涨:VARC=1;
CH:SUM(看涨,0) AND T1=1;{统计}
P1:= FILTER(看涨,16) ;
DRAWTEXT(P1,30,'←短线看涨'),COLORYELLOW,LINETHICK2;
VAR1Z:=REF(CLOSE,1);
VAR2Z:=SMA(MAX(CLOSE-VAR1Z,0),7,1)/SMA(ABS(CLOSE-VAR1Z),7,1)*100;
VAR3Z:=SMA(MAX(CLOSE-VAR1Z,0),13,1)/SMA(ABS(CLOSE-VAR1Z),13,1)*100;
VAR4Z:=SMA(MAX(VAR1Z-CLOSE,0),7,1)/SMA(ABS(CLOSE-VAR1Z),7,1)*100;
VAR5Z:=SMA(MAX(VAR1Z-CLOSE,0),13,1)/SMA(ABS(CLOSE-VAR1Z),13,1)*100;
VAR6Z:=BARSCOUNT(CLOSE);
波:(T3=1 AND VAR2Z<25 AND VAR3Z<30 AND VAR6Z>35)*3,STICK, COLORSTICK,LINETHICK2;
VARF:=100-3*SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
VAR9A:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
VAR2A:=VARF<REF(VAR9A,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(CT=0 AND VAR2A AND COUNT(VAR2A,50)=1,75,'←大资金'),LINETHICK1,COLORYELLOW;
大资金:(CT=0 AND VAR2A AND COUNT(VAR2A,50)=1)*85,STICK,COLORYELLOW,LINETHICK1;
VAR31:=MA(VOL,5)>MA(VOL,60);
介入: IF(A<0.15 AND ABS(A-B)<0.05 AND CROSS(A,B) AND VAR31,1,0)*80,STICK,COLORRED,,LINETHICK2;
P3:= FILTER(介入,16) ;
DDB:='←进场注意';
DRAWTEXT(P3,IF(介入>0 AND 涨幅<8,60,70),DDB),COLORYELLOW;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
SD:=(C>60 AND C<100,500,300);
SF:=IF(C<40 AND C<=60,800,SD);
SG:=IF(C>10 AND C<=25,1000,IF(C>25 AND C<40,1000,SF));
SH:=IF(C<5,5000,IF(C>=5 AND C<=10,3000,SG));
SJ:=IF(C>=6000,5,SH);
SK:=IF(C>1000 AND C<6000,25,SJ);
MACD:(DIF-DEA)*SK,COLORSTICK;
NC2:=WL>35 AND WL<65 AND WL > MA(REF(WL,5),5) AND CT=0 AND T2=1 AND 涨幅<8;
P5:=FILTER(NC2,32) ;
DRAWTEXT(P5 ,WL*1.01,'←加仓'),COLOR00FFFF,LINETHICK2;
VARM6:=CROSS(VARM3,VARM4) AND VARM3<30 AND T1=1 AND CCT >0 ;
VARM7:=CROSS(VARM4,VARM3) AND VARM3>80 AND T1=1 AND CCT>0 AND CH=0;
STICKLINE(FILTER(VARM6=1,10)=1,0,70,10,0),LINETHICK1,COLORRED;
DRAWTEXT(FILTER(VARM6=1,10)=1,60,'←追'),LINETHICK1,COLORYELLOW;{买}
DRAWTEXT(FILTER(VARM7=1,5)=1,80,'↓逃顶'),LINETHICK1,COLORYELLOW; {卖}
MA5:=MA(CLOSE,5);
MA65:=MA(CLOSE,65);
MA21:=MA(CLOSE,21);
DD1:=COUNT(MA21>MA65,10)=10;
GX:=MAX(MA5,MAX(MA21,MA65));
DX:=MIN(MA5,MIN(MA21,MA65));
DD2:=ABS(GX/DX-1)*100<=15;
DD3:=COUNT(MACD<0,10)=10;
DD4:=IF(DD1 AND DD2 AND DD3,5,0);
DD5:=CCT>0 AND 0+IF(CROSS(0.1,DD4) AND CROSS(MACD,0),8,0) ;
DDE:='←买不亏';
STICKLINE(FILTER(DD5=1,50)=1,0,30,10,0),LINETHICK1,COLORYELLOW;
DRAWTEXT(FILTER(DD5=1,50)=1,10,DDE),LINETHICK1,COLORYELLOW;
警戒:90,COLOR5AFF9E;
轴:0;

通达信短线看涨指标公式

 

相关文章