在线检测未来函数

通达信优化相思豆主图指标公式

来源:Internet,编辑:股旁网,2012-12-18

M1:EMA(CLOSE,13),COLORBLUE;
M2:EMA(M1,3),COLORBLUE;
M3:EMA(M2,3),COLORBLUE;
M4:EMA(M3,3),COLORBLUE;
M5:=EMA(M4,3),COLORBLUE;
{支撑}
HLC:=REF(MA((HIGH+LOW+CLOSE)/3,10),1);
HV:=EMA(HHV(HIGH,10),3);
LV:=EMA(LLV(LOW,10),3);
支撑:EMA(HLC*2-HV,3),COLORE99A2C;
VC:=IF(CLOSE>=M1,10,-10)+IF(CLOSE>=M2,10,-10)+IF(CLOSE>=M3,10,-10)+
IF(M1>=M2,10,-10)+ IF(M2>=M3,10,-10);
SN:=IF(M5>REF(M5,1), 1, 0)*IF(M4>REF(M4,1), 1, 0); A:=VC-(1-SN)*10;
QRG:=IF(A<-50,-50,A),COLORAADDCC;
M1S:IF(M1>REF(M1,1),M1,DRAWNULL),COLORFF00FF ;
M2S:IF(M2>REF(M2,1),M2,DRAWNULL),COLORFF00FF;
M3S:IF(M3>REF(M3,1),M3,DRAWNULL),COLORFF00FF ;
M4S:IF(M4>REF(M4,1),M4,DRAWNULL),COLORFF00FF ;
M5S:IF(M5>REF(M5,1),M5,DRAWNULL),COLORFF00FF ;
STICKLINE(C<=O ,O,C,2,1), COLORFFCCCC;
破浪:IF( CROSS(QRG,-10) ,L,DRAWNULL),CIRCLEDOT,COLORYELLOW,LINETHICK2;
空仓:IF( QRG=-50 AND REF(QRG,1)>=-30,H,DRAWNULL),CIRCLEDOT,COLORGREEN,LINETHICK2;
斩回买:IF( QRG>=-10 AND QRG<50 AND REF(QRG,1)=50 ,L,DRAWNULL),CIRCLEDOT,COLORFF00FF,LINETHICK2;

通达信优化相思豆主图指标公式

 

相关文章