在线检测未来函数

通达信KDJ背离画线指标公式

来源:Internet,编辑:股旁网,2012-12-18

N:=5;M1:=3;M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1),COLORYELLOW,LINETHICK1;
D:SMA(K,M2,1),COLORCYAN,LINETHICK1;
J:3*K-2*D,COLORMAGENTA,LINETHICK1;
高安全区:0,COLORRED;
安全区:20,COLORCYAN;
风险区:100,COLORGREEN;
U1:=BARSLAST(REF(CROSS(K,D),1));
U2:=REF(C,U1+1)>C AND REF(K,U1+1)<K AND CROSS(K,D)AND D<50;
背离:=IF(U2>0,1,0);
DRAWLINE(U1=0,D,底背离,REF(D,U1),0),COLORRED,LINETHICK2;
DRAWLINE(底背离,D,底背离,REF(D,U1),0),COLORRED,LINETHICK2;
DRAWTEXT(底背离,REF(D,U1)*1.00,' 底背离'),COLORYELLOW;
RR:=MAX(C,O);
Q1:=HHV(RR,5);
Q2:=D<REF(D,1) AND REF(D,1)>REF(D,2);
A2:=BARSLAST(REF(Q2,1));
顶背离:= REF(Q1,A2+1)<Q1 AND K<REF(K,A2+1) AND Q2;
DRAWLINE(A2=0 ,D,顶背离,REF(D,A2),0),COLORWHITE,LINETHICK2;
DRAWLINE(顶背离,D,顶背离,REF(D,A2),0),COLORWHITE,LINETHICK2;
DRAWTEXT(顶背离,REF(D,A2)*1.02,' 顶背离'),COLORGREEN;

通达信KDJ背离画线指标公式

 

相关文章