在线检测未来函数

通达信新双均线主图指标公式

来源:Internet,编辑:股旁网,2012-12-20

MA5:MA(CLOSE,5);
IF(MA5>REF(MA5,1),MA5,DRAWNULL)LINETHICK5,COLORRED;
IF(MA5<REF(MA5,1),MA5,DRAWNULL)LINETHICK5,COLORGRAY;
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
持股:=VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
离场:=IF(持股,JRL,DRAWNULL);
明离场价:=离场,COLORFF99FF,NODRAW;
今离场价:=REF(离场,1)COLOR0000FF,NODRAW;
观望:=VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
进:=IF(观望,JRH,DRAWNULL);
明进场价:=进,COLOR33AACC,NODRAW;
今进场价:=REF(明进场价,1),COLORFF0000,NODRAW;
短买:=VAR19,COLOR33AACC,NODRAW;
品红离场:=VAR1A,COLORFF99FF,NODRAW;
急速超跌:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;
STICKLINE(ISLASTBAR AND (持股 OR REF(持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (观望 OR REF(观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00;
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
STICKLINE(持股,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(持股,CLOSE,O,2,0),COLOR000088;
STICKLINE(持股,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(持股,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(持股,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(观望,CLOSE,O,2.8,0),COLOR555500;
STICKLINE(观望,CLOSE,O,2,0),COLOR888800;
STICKLINE(观望,CLOSE,O,1.5,0),COLORAAAA00;
STICKLINE(观望,CLOSE,O,1,0),COLORCCCC00;
STICKLINE(观望,CLOSE,O,0.5,0),COLOREEEE00;
CO:=(C-O);
STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;
STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;
STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;
STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;
STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;
STICKLINE(短买,O,O+CO/3,2.8,0),COLOR335555;
STICKLINE(短买,O,O+CO/3,2,0),COLOR338888;
STICKLINE(短买,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(短买,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(短买,O,O+CO/3,0,0),COLOR33EEEE;
STICKLINE(品红离场,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(品红离场,O,O+CO/3,2,0),COLOR880088;
STICKLINE(品红离场,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(品红离场,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(品红离场,O,O+CO/3,0.5,0),COLOREE00EE;
VC:=(2*CLOSE+HIGH+LOW)/4;
K1:=SLOPE(WMA(VC,3),5)*4+VC,COLOR00FFFF;
D1:=WMA(K1,3),COLOR00FF00;
K2:=EMA(K1,3);
D2:=EMA(D1,3);
M1:(K2+D2)/2;
IF(M1>REF(M1,1),M1,DRAWNULL),COLORRED;
IF(M1<REF(M1,1),M1,DRAWNULL),COLORBLUE;
K3:=SLOPE(WMA(VC,55),5)*4+VC,COLOR00FFFF;
D3:=WMA(K3,13),COLOR00FF00;
K4:=EMA(K3,13);
D4:=EMA(D3,13);
M2:(K4+D4)/2;
IF(M2>REF(M2,1),M2,DRAWNULL),COLORRED;
IF(M2<REF(M2,1),M2,DRAWNULL),COLORBLUE;
DRAWTEXT(CURRBARSCOUNT=1,M2*1.0,'1');
DRAWTEXT(CURRBARSCOUNT=5,M2*1.0,'5');
DRAWTEXT(CURRBARSCOUNT=8,M2*1.0,'8');
DRAWTEXT(CURRBARSCOUNT=13,M2*1.0,'13');
DRAWTEXT(CURRBARSCOUNT=21,M2*1.0,'21');
DRAWTEXT(CURRBARSCOUNT=34,M2*1.0,'34');
DRAWTEXT(CURRBARSCOUNT=55,M2*1.0,'55');
DRAWTEXT(CURRBARSCOUNT=60,M2*1.0,'60');
DRAWTEXT(CURRBARSCOUNT=75,M2*1.0,'75');
DRAWTEXT(CURRBARSCOUNT=89,M2*1.0,'89');

通达信新双均线主图指标公式

 

相关文章