在线检测未来函数

同花顺短线操盘主图指标公式

来源:Internet,编辑:股旁网,2012-12-21

var1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
Var2:=REF(Var1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var3:=REF(Var2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var4:=REF(Var3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var5:=REF(Var4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var6:=REF(Var5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var7:=REF(Var6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var8:=REF(Var7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var9:=REF(Var8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VarA:=REF(Var9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VarB:=REF(VarA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VarC:=REF(VarB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VarD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VarE:=REF(VarD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VarF:=REF(VarE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var10:=REF(VarF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var11:=REF(Var10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var12:=REF(Var11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var13:=REF(Var12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var14:=REF(Var13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var15:=REF(Var14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var16:=REF(Var15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var17:=REF(Var16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var18:=REF(Var17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var19:=REF(VarD OR VarE OR VarF OR Var10 OR Var11 OR Var12 OR Var13 OR
Var14 OR Var15 OR Var16 OR Var17 OR Var18,1) AND Var1;
DRAWTEXT(Var19,L,'B'),colorwhite;
Var1A:=REF(Var1 OR Var2 OR Var3 OR Var4 OR Var5 OR Var6 OR Var7 OR
Var8 OR Var9 OR VarA OR VarB OR VarC,1) AND VarD;
DRAWTEXT(Var1A,H*1.02,'S'),coloryellow;
ma3:MA(C,3),colorfff000;
ma6:MA(C,6),colorff99ff;
ma9:MA(C,9),color00ff00;
qs1:=IF(C>MA(C,4),1,0);
qs2:=IF(C<MA(C,4),-1,0);
qs3:=IF(MA(C,5)>REF(MA(C,5),1),1,0);
qs4:=IF(MA(C,5)<REF(MA(C,5),1),-1,0);
qs:=qs1+qs2+qs3+qs4;
STICKLINE((qs=-2 AND C<O),H,L,0,0),Color00FF00;
STICKLINE((qs=-2 AND C<O),OPEN,CLOSE,10,0),Color007900;
STICKLINE((qs=-2 AND C<O),OPEN,CLOSE,8,1),Color00A200;
STICKLINE((qs=-2 AND C<O),OPEN,CLOSE,4,0),Color00D600;
STICKLINE((qs=-2 AND C<O),OPEN,CLOSE,2,0),Color00FF00;

STICKLINE((qs=-2 AND C>O),H,L,0,0),Color53A9FF;
STICKLINE((qs=-2 AND C>O),O,C,10,0),Color003E7B;
STICKLINE((qs=-2 AND C>O),O,C,8,1),Color0053A6;
STICKLINE((qs=-2 AND C>O),O,C,4,0),Color006AD5;
STICKLINE((qs=-2 AND C>O),O,C,2,0),Color2492FF;

STICKLINE((qs=0 AND C<O),H,L,0,0),ColorFFFFFF;
STICKLINE((qs=0 AND C<O),O,C,10,0),ColorBBBBBB;
STICKLINE((qs=0 AND C<O),O,C,8,1),ColorCACACA;
STICKLINE((qs=0 AND C<O),O,C,4,0),ColorF6F6F6;
STICKLINE((qs=0 AND C<O),O,C,2,0),ColorFFFFFF;

STICKLINE((qs=0 AND C>O),H,L,0,0),Color00FFFF;
STICKLINE((qs=0 AND C>O),O,C,10,0),Color008888;
STICKLINE((qs=0 AND C>O),O,C,8,1),Color00BFBF;
STICKLINE((qs=0 AND C>O),O,C,4,0),Color00DBDB;
STICKLINE((qs=0 AND C>O),O,C,2,0),Color00F0F0;

STICKLINE((qs=2 AND C<O),H,L,0,0),ColorFF00FF;
STICKLINE((qs=2 AND C<O),O,C,10,0),ColorBB00BB;
STICKLINE((qs=2 AND C<O),O,C,8,1),colorFF5BFF;
STICKLINE((qs=2 AND C<O),O,C,4,0),colorF900F9;
STICKLINE((qs=2 AND C<O),O,C,2,0),ColorFF66FF;

STICKLINE((qs=2 AND C>O),H,L,0,0),Color0000FF;
STICKLINE((qs=2 AND C>O),O,C,10,0),Color00007B;
STICKLINE((qs=2 AND C>O),O,C,8,1),Color000097;
STICKLINE((qs=2 AND C>O),O,C,4,0),Color0000C4;
STICKLINE((qs=2 AND C>O),O,C,2,0),Color0000EC;
AC:=AMOUNT/(VOL);
YY:=MA(AC,13);
LLL:=(C-YY)/YY*100;
MIDC := MA(CLOSE,21);
UPPERC:= MIDC + 2*STD(C,21);
LOWERC:= MIDC - 2*STD(C,21);
BBA:=(C-LOWERC)/(UPPERC-LOWERC);
BBC:=FORCAST(BBA,3);
LIFENGCYC:=(REF(LLL,1)<-15 AND REF(BBA,1)<0 AND LLL>REF(LLL,1));
STICKLINE(LIFENGCYC>0,C,O,2,0),COLOR10ABFF;
STICKLINE(LIFENGCYC>0,C,O,1.5,0),COLOR10D0FF;
STICKLINE(LIFENGCYC>0,C,O,1,0),COLOR10FFFF;
DRAWTEXT(LIFENGCYC>0,LOW*0.99,'☆'),colorffffff;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'▼'),ColorFFFFFF;

同花顺短线操盘主图指标公式

 

相关文章