在线检测未来函数

通达信变速均线指标公式

来源:Internet,编辑:股旁网,2012-12-23

公式中,T为时间周期,一般取值为20个交易日;N为短周期参数,固定取值为2个交易日;M为长周期参数,固定取值为30个交易日。

T:=20;N:=2;M:=30;
DIRECTION:=CLOSE-REF(CLOSE,T);
VOLATILITY:=SUM(ABS(CLOSE-REF(CLOSE,1)),T);
ER:=SUM(ABS(DIRECTION/VOLATILITY),1);
FastC:=2/(N+1);
SlowC:=2/(M+1);
Smooth:=ER*(FastC-SlowC)+slowC;
SE:=Smooth*Smooth;
YY:=REF(Close,1)+SE*(Close-Ref(Close,1));
AA:=IF(SUM(1,0)=T+1,YY,0);
BB:=BARSLAST(AA>0);
CC:=REF(Close,BB);
AMA:REF(CC,1)+SE*(Close-REF(CC,1));

通达信变速均线主图指标公式

 

相关文章