在线检测未来函数

通达信抄底ABC指标公式

来源:Internet,编辑:股旁网,2012-12-23

VAR2:=IF(EMA(C,10)/EMA(EMA(C,30),16)<0.85 AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND V/CAPITAL*100<5,50,0);
VAR3:=(-100)*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))+100;
VAR4:=(-100)*(HHV(H,50)-C)/(HHV(H,50)-LLV(L,50))+100;
VAR5:=(-100)*(HHV(H,70)-C)/(HHV(H,70)-LLV(L,70))+100;
VAR6:=((C-MA(C,34))/MA(C,34)*100+10)*5;
VAR7:=((C-MA(C,50))/MA(C,50)*100+10)*5;
VAR8:=((C-MA(C,70))/MA(C,70)*100+10)*5;
VAR9:=(VAR3+VAR4+VAR5+VAR6+VAR7+VAR8)/6;
VARA:=EMA(VAR9,3);
VARB:=ABS(VAR6-VAR8);
VARC:=(VAR9+VARB)/2;
VARD:=(-1)*(EMA(100*(1-WINNER(C)),1)-50)+50;
VARE:=VARD+VARC;
VARF:IF(VAR2>0 AND VARE<0,200,0);
VAR10:IF(VARC<0 AND C=LLV(C,5) AND C/REF(C,1)>0.905 AND
C/REF(C,1)<1.05 AND V/CAPITAL*100<5,-50,0);
VAR11:IF(VARE<0 AND VAR10=-50,100,0);
VAR12:=MA(C,3);
VAR13:=REF(C,2)*0.865;
VAR14:=REF(C,13)*0.772;
VAR15:=MIN(VAR13,VAR14);
VAR16:=100*V/CAPITAL;
VAR17:=MA(C,30);
VAR18:IF((C-VAR15)/C<0.03 AND SUM(VAR16,5)/5<1.8,1,0);
VAR19:IF(VAR18>0 AND (VAR10<0 OR VAR2>0),100,0);
VAR1A:=VAR19;
VAR1B:=IF(VARF>0 AND VAR11>0 AND SUM(V/CAPITAL*100,5)/5<1 OR VAR18>0 AND
REF(C,1)/REF(C,2)>0.902 OR (VARF>0 AND VAR11>0 AND
SUM(V/CAPITAL*100,5)/5<1 OR VAR18>0) AND (VAR10<0 OR VAR2>0) AND
VAR19<10,50,0);
VAR1C:=(VARF>0 AND VAR11>0 AND SUM(V/CAPITAL*100,5)/5<1 OR VAR18>0) AND
(VAR10<0 OR VAR2>0);
VAR1D:=VARF>0 AND VAR11>0 AND SUM(V/CAPITAL*100,5)/5<1 OR VAR18>0 AND REF(C,1)/REF(C,2)>0.902;
VAR1E:=VAR1C OR VAR1D;
G:=MA(C,80)-MA(C,30);

通达信抄底ABC指标公式

 

相关文章