在线检测未来函数

通达信欢乐KJ指标公式

来源:Internet,编辑:股旁网,2012-12-24

N:=90;M:=3;
10,COLORRED,LINETHICK3,POINTDOT;
20,COLOR00FFFF,LINETHICK3,POINTDOT;
40,COLORA943FF,LINETHICK3,POINTDOT;
50,COLORRED,LINETHICK2;
60,COLORRED,LINETHICK3,POINTDOT;
80,COLOR00FFFF,LINETHICK3,POINTDOT;
90,COLORA943FF,LINETHICK3,POINTDOT;
100,COLOR00FF00,LINETHICK1;
{共振}
RV:=(CLOSE-LLV(LOW,33))/(HHV(HIGH,33)-LLV(LOW,33))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
VAR44:=SMA(RV,3,1);
VAR55:=SMA(VAR44,3,1);
KK:=EMA(SMA(RG,3,1),2);
JJ:=SMA(KK,3,1);
共振点:=(CROSS(VAR44,VAR55) AND CROSS(KK,JJ));
STICKLINE(共振点>0,0,70,1.2,0),COLOR008888;
STICKLINE(共振点>0,0,70,0.8,0),COLOR00AAAA;
STICKLINE(共振点>0,0,70,0.4,0),COLOR00CCCC;
STICKLINE(共振点>0,0,70,0,0),COLOR00FFFF;
DRAWTEXT(共振点>0,75,'升'),COLOR00FFFF;
{今买明卖}
MA111:=MA(CLOSE,20);
MA112:=MA(CLOSE,40);
MA113:=MA(CLOSE,60);
A11:=OPEN<MA111 OR OPEN<MA112 OR OPEN<MA113;
A12:=C>MAX(MA111,MAX(MA112,MA113));
A13:=V/MA(V,30)>1.2;
A14:=C/REF(C,1)>1.049;
BT:=IF(A11 AND A12 AND A13 AND A14,50,0);
STICKLINE(BT,0,40,1.2,0),COLOR000088;
STICKLINE(BT,0,40,0.8,0),COLOR0000BB;
STICKLINE(BT,0,40,0.4,0),COLOR0000DD;
STICKLINE(BT,0,40,0,0),COLOR0000FF;
DRAWTEXT(BT>0.9,40,'买'),COLOR0000FF,LINETHICK1;
{波段底部}
低:=REF(LLV(L,N),M);
低点:=REFDATE(低,DATE);
XG:=低点=L AND ((C-L)>(O-C) OR (O-L)>(C-O));
STICKLINE(XG,0,60,1.2,0),COLOR888888;
STICKLINE(XG,0,60,0.8,0),COLORBBBBBB;
STICKLINE(XG,0,60,0.4,0),COLORDDDDDD;
STICKLINE(XG,0,60,0,0),COLORFFFFFF;
DRAWTEXT(XG,60,'底部'),COLORFFFFFF,LINETHICK1;
{机会难得}
VAR17:=REF(CLOSE,1);
VAR18:=SMA(MAX(CLOSE-VAR17,0),7,1)/SMA(ABS(CLOSE-VAR17),7,1)*100;
VAR19:=SMA(MAX(CLOSE-VAR17,0),13,1)/SMA(ABS(CLOSE-VAR17),13,1)*100;
VAR1A:=BARSLAST(VAR19<33)<=3 AND CROSS(VAR18,VAR19);
VAR1B:=(CLOSE-MA(CLOSE,33))/MA(CLOSE,20)*100<-12.5;
VAR1C:=LLV(LOW,5);
VAR1D:=HHV(HIGH,10);
VAR1E:=EMA((CLOSE-VAR1C)/(VAR1D-VAR1C)*100,4);
VAR1F:=EMA(0.667*REF(VAR1E,1)+0.333*VAR1E,2);
机会难得:=0-(-1)*VAR1A AND VAR1B AND CROSS(VAR1E,VAR1F) AND VAR1E<=25,COLORMAGENTA,LINETHICK1;
STICKLINE(机会难得,0,35,1.2,0),COLOR880088;
STICKLINE(机会难得,0,35,0.8,0),COLORAA00AA;
STICKLINE(机会难得,0,35,0.4,0),COLORCC00CC;
STICKLINE(机会难得,0,35,0,0),COLORFF00FF;
DRAWTEXT(机会难得,35,'机会'),COLORFF00FF,LINETHICK1;
{KDJ}
RSV:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K:SMA(RSV,3,1),COLORWHITE,LINETHICK2;
D:=SMA(K,3,1),COLOR00FFFF,LINETHICK2;
{J线没未来}
J:3*K-2*D,COLOR00FFFF,LINETHICK2;
IF(J<REF(J,1),J,DRAWNULL),COLORGREEN,LINETHICK2;
IF(J>REF(J,1),J,DRAWNULL),COLORRED,LINETHICK2;
{KDJ红绿相交}
DRAWICON(CROSS(J,D) AND CROSS(J,K),0,25);
DRAWICON(CROSS(D,J) AND CROSS(K,J),100,27);
{抢钱了}
MA20:=MA(C,20);
MA30:=MA(C,30);
QSXS:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
ZF:=(C/REF(C,1)-1)*100;
N1:=BARSLAST(CROSS(C,MA(C,5)));
N2:=BARSLAST(CROSS(MA(C,5),C));
HM:=IF(N1<N2,N1+1,0)*QSXS;
Z2:=HM=1 AND ZF>=0 AND C>O AND QSXS;
KX1:=ZF<=-3 AND C<O;
XDSJ:=BARSLAST(KX1);
KX2:=ZF>=3 AND C>O;
JBY:=KX2 AND XDSJ<=2 AND C>=REF(O*0.99,XDSJ) AND ZF>ABS(REF(ZF,XDSJ)*0.99);
Z3:=IF(FILTER(JBY,1) AND QSXS,5,0);
抢钱了:=Z2 AND Z3;
IF(抢钱了,70,0),LINETHICK1,COLORYELLOW;
{买}
A5:=C-REF(C,1);
A6:=100*EMA(EMA(A5,6),6)/EMA(EMA(ABS(A5),6),6);
RMA1:=EMA(CLOSE,7);
NMA1:=EMA(CLOSE,19);
UP1:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA1,RMA1))+1),LLV(L,BARSLAST(CROSS(NMA1,RMA1))+1),H
=HHV(H,BARSLAST(CROSS(RMA1,NMA1))+1),HHV(H,BARSLAST(CROSS(RMA1,NMA1))+1),0);
DOWN1:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA1,NMA1))+1),HHV(H,BARSLAST(CROSS(RMA1,NMA1))+1),L
=LLV(L,BARSLAST(CROSS(NMA1,RMA1))+1),LLV(L,BARSLAST(CROSS(NMA1,RMA1))+1),0);
买入:=(LLV(A6,2)=LLV(A6,7) AND COUNT(A6<0,2) AND CROSS(A6,MA(A6,2))) AND
REF(DOWN1,1)<REF(DOWN1,2) AND UP1>REF(DOWN1,1);
IF(买入,0,35),COLORCYAN,LINETHICK2;
{坐标线位置,最多7个,用分号分隔
0.00;20.00;50.00;60.00;80.00;100.00}

通达信欢乐KJ指标公式

 

相关文章