在线检测未来函数

飞狐止损止赢主图指标公式

来源:Internet,编辑:股旁网,2012-12-25

DRAWGBK(CLOSE,COLORRGB(200,200,50),COLORRGB(100,50,50),1);
VAR1:=(((((3 * CLOSE) + LOW) + OPEN) + HIGH) / 6);
B0:=(((((((((((((((((((((20 * VAR1) + (19 * REF(VAR1,1))) + (18 * REF(VAR1,2))) + (17 * REF(VAR1,3))) + (16 * REF(VAR1,4))) + (15 * REF(VAR1,5))) + (14 * REF(VAR1,6))) + (13 * REF(VAR1,7))) + (12 * REF(VAR1,8))) + (11 * REF(VAR1,9))) + (10 * REF(VAR1,10))) + (9 * REF(VAR1,11))) + (8 * REF(VAR1,12))) + (7 * REF(VAR1,13))) + (6 * REF(VAR1,14))) + (5 * REF(VAR1,15))) + (4 * REF(VAR1,16))) + (3 * REF(VAR1,17))) + (2 * REF(VAR1,18))) + REF(VAR1,20)) / 210);
D01:=MA(B0,21);
D02:=MA(B0,34);
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
GA:=(((((((100 - (2 * REF(K,1))) + (2 * K)) + ((4 * REF(D,1)) / 3)) / 3) * (HHV(HIGH,9) - LLV(LOW,9))) + (100 * LLV(LOW,9))) / 100);
GB:=(((((((0 - (2 * REF(K,1))) + (2 * K)) + ((4 * REF(D,1)) / 3)) / 3) * (HHV(HIGH,9) - LLV(LOW,9))) + (100 * LLV(LOW,9))) / 100);
A1:=IF(CROSS(D,K),LOW,0);
A2:=IF(CROSS(50,D),1,0);
B11:REF(GA,BARSLAST(A2)),LINETHICK5,colorFF;
B22:IF((D01 < D02),REF(GB,BARSLAST(A1)),REF(GA,BARSLAST(A1))),LINETHICK5,colorFFFF;
FILLRGN(((B11 >= B22) AND ((((B11 - B22) / B22) * 100) < 2)),B11,B22),colorFFFFFF;
FILLRGN(((B11 < B22) AND (((ABS((B11 - B22)) / B22) * 100) < 2)),B11,B22),colorFFFFFF;
STICKLINE((((B11 < B22) AND (CLOSE > B11)) AND (B11 < (B22 * 0.962))),B22,(B22 * 0.962),0,0),colorFF00;
B33:IF((((B11 < B22) AND (CLOSE > B11)) AND (B11 < (B22 * 0.962))),(B22 * 0.962),REF(GA,BARSLAST(A2))),LINETHICK5,colorFF00FF;
STICKLINE((CLOSE >= OPEN),CLOSE,HIGH,0,0),color10FFFF;
STICKLINE((CLOSE >= OPEN),OPEN,LOW,0,0),color10FFFF;
STICKLINE((CLOSE < OPEN),OPEN,HIGH,0,0),colorFFFF10;
STICKLINE((CLOSE < OPEN),CLOSE,LOW,0,0),colorFFFF10;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),colorFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),color1029FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),color1040FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),color1083FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4,0),color10ABFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),color10D0FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2,0),color10FFFF;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,8,0),colorFF147C;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,7,0),colorFF5B74;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,6,0),colorFF747C;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,5,0),colorFF887C;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,4,0),colorFFAC10;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,3,0),colorFFD110;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,2,0),colorFFFF10;
DRAWBKBMP(CLOSE,'cpw'),ALIGN4;
RSI1:=((SMA(MAX((INDEXC - REF(INDEXC,1)),0),6,1) / SMA(ABS((INDEXC - REF(INDEXC,1))),6,1)) * 100);
DA1:=(((((3 * INDEXC) + INDEXL) + INDEXO) + INDEXH) / 6);
DB:=(((((((((((((((((((((20 * DA1) + (19 * REF(DA1,1))) + (18 * REF(DA1,2))) + (17 * REF(DA1,3))) + (16 * REF(DA1,4))) + (15 * REF(DA1,5))) + (14 * REF(DA1,6))) + (13 * REF(DA1,7))) + (12 * REF(DA1,8))) + (11 * REF(DA1,9))) + (10 * REF(DA1,10))) + (9 * REF(DA1,11))) + (8 * REF(DA1,12))) + (7 * REF(DA1,13))) + (6 * REF(DA1,14))) + (5 * REF(DA1,15))) + (4 * REF(DA1,16))) + (3 * REF(DA1,17))) + (2 * REF(DA1,18))) + REF(DA1,20)) / 210);
B1:=MA(DB,3);
B2:=MA(DB,5);
B3:=MA(DB,21);
B4:=MA(DB,34);
S:=IF((DATE > 960101),1,0);
VAR47:=(LLV(INDEXC,24) * 1.056);
VAR48:=((COUNT((MA(INDEXC,5) > REF(MA(INDEXC,5),1)),17) / 17) * 100);
DRAWTEXT((((((((CROSS(INDEXC,VAR47) AND (LLV(INDEXC,24) = LLV(INDEXC,60))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1)) AND (B3 < B4)) OR (((CROSS(INDEXC,VAR47) AND (LLV(INDEXC,24) = LLV(INDEXC,60))) AND (INDEXC < MIN(B1,MIN(B2,MIN(B3,B4))))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR (((CROSS(INDEXC,VAR47) AND (INDEXC > (REF(INDEXC,1) * 1.056))) AND (INDEXC < MIN(B1,MIN(B2,MIN(B3,B4))))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR ((((CROSS(INDEXC,VAR47) AND (INDEXC > MAX(B1,MAX(B2,MAX(B3,B4))))) AND (MAX(B1,B2) < MAX(B3,B4))) AND (B3 < B4)) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR ((((CROSS(INDEXC,VAR47) AND (INDEXC > MAX(B1,MAX(B2,MAX(B3,B4))))) AND (MAX(B1,B2) < MIN(B3,B4))) AND (B3 > B4)) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))),(LOW * 0.98),'大盘见底啦!');
DRAWTEXT((((((CROSS(B4,INDEXC) AND (B3 < B4)) AND (INDEXC > MIN(B1,MIN(B2,MIN(B3,B4))))) AND (B1 < B4)) AND (COUNT(CROSS(B4,B3),BARSLAST((((((((CROSS(INDEXC,VAR47) AND (LLV(INDEXC,24) = LLV(INDEXC,60))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1)) AND (B3 < B4)) OR (((CROSS(INDEXC,VAR47) AND (LLV(INDEXC,24) = LLV(INDEXC,60))) AND (INDEXC < MIN(B1,MIN(B2,MIN(B3,B4))))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR (((CROSS(INDEXC,VAR47) AND (INDEXC > (REF(INDEXC,1) * 1.056))) AND (INDEXC < MIN(B1,MIN(B2,MIN(B3,B4))))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR ((((CROSS(INDEXC,VAR47) AND (INDEXC > MAX(B1,MAX(B2,MAX(B3,B4))))) AND (MAX(B1,B2) < MAX(B3,B4))) AND (B3 < B4)) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR ((((CROSS(INDEXC,VAR47) AND (INDEXC > MAX(B1,MAX(B2,MAX(B3,B4))))) AND (MAX(B1,B2) < MIN(B3,B4))) AND (B3 > B4)) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))))) = 1)) AND (COUNT((CROSS(B4,INDEXC) AND (B3 < B4)),BARSLAST((((((((CROSS(INDEXC,VAR47) AND (LLV(INDEXC,24) = LLV(INDEXC,60))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1)) AND (B3 < B4)) OR (((CROSS(INDEXC,VAR47) AND (LLV(INDEXC,24) = LLV(INDEXC,60))) AND (INDEXC < MIN(B1,MIN(B2,MIN(B3,B4))))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR (((CROSS(INDEXC,VAR47) AND (INDEXC > (REF(INDEXC,1) * 1.056))) AND (INDEXC < MIN(B1,MIN(B2,MIN(B3,B4))))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR ((((CROSS(INDEXC,VAR47) AND (INDEXC > MAX(B1,MAX(B2,MAX(B3,B4))))) AND (MAX(B1,B2) < MAX(B3,B4))) AND (B3 < B4)) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR ((((CROSS(INDEXC,VAR47) AND (INDEXC > MAX(B1,MAX(B2,MAX(B3,B4))))) AND (MAX(B1,B2) < MIN(B3,B4))) AND (B3 > B4)) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))))) = 1)),(HIGH * 1.02),'准备清仓逃顶!'),colorFFFF;
DRAWTEXT(((CROSS(RSI1,80) AND (B2 > B3)) AND (COUNT((INDEXC < B4),BARSLAST((((((((CROSS(INDEXC,VAR47) AND (LLV(INDEXC,24) = LLV(INDEXC,60))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1)) AND (B3 < B4)) OR (((CROSS(INDEXC,VAR47) AND (LLV(INDEXC,24) = LLV(INDEXC,60))) AND (INDEXC < MIN(B1,MIN(B2,MIN(B3,B4))))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR (((CROSS(INDEXC,VAR47) AND (INDEXC > (REF(INDEXC,1) * 1.056))) AND (INDEXC < MIN(B1,MIN(B2,MIN(B3,B4))))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR ((((CROSS(INDEXC,VAR47) AND (INDEXC > MAX(B1,MAX(B2,MAX(B3,B4))))) AND (MAX(B1,B2) < MAX(B3,B4))) AND (B3 < B4)) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR ((((CROSS(INDEXC,VAR47) AND (INDEXC > MAX(B1,MAX(B2,MAX(B3,B4))))) AND (MAX(B1,B2) < MIN(B3,B4))) AND (B3 > B4)) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))))) >= 5)),(HIGH * 1.02),'准备清仓逃顶!'),colorFFFF;
DRAWTEXT((CROSS(RSI1,80) AND (COUNT((INDEXC > INDEXO),8) = 8)),(HIGH * 1.02),'准备清仓逃顶!'),colorFFFF;
DRAWTEXT((CROSS(VAR48,75) AND (COUNT(CROSS(75,VAR48),BARSLAST((((((((CROSS(INDEXC,VAR47) AND (LLV(INDEXC,24) = LLV(INDEXC,60))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1)) AND (B3 < B4)) OR (((CROSS(INDEXC,VAR47) AND (LLV(INDEXC,24) = LLV(INDEXC,60))) AND (INDEXC < MIN(B1,MIN(B2,MIN(B3,B4))))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR (((CROSS(INDEXC,VAR47) AND (INDEXC > (REF(INDEXC,1) * 1.056))) AND (INDEXC < MIN(B1,MIN(B2,MIN(B3,B4))))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR ((((CROSS(INDEXC,VAR47) AND (INDEXC > MAX(B1,MAX(B2,MAX(B3,B4))))) AND (MAX(B1,B2) < MAX(B3,B4))) AND (B3 < B4)) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR ((((CROSS(INDEXC,VAR47) AND (INDEXC > MAX(B1,MAX(B2,MAX(B3,B4))))) AND (MAX(B1,B2) < MIN(B3,B4))) AND (B3 > B4)) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))))) = 1)),(HIGH * 1.02),'准备清仓逃顶!'),colorFFFF;
DRAWTEXT((CROSS(99,VAR48) AND (COUNT((VAR48 = 100),BARSLAST((((((((CROSS(INDEXC,VAR47) AND (LLV(INDEXC,24) = LLV(INDEXC,60))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1)) AND (B3 < B4)) OR (((CROSS(INDEXC,VAR47) AND (LLV(INDEXC,24) = LLV(INDEXC,60))) AND (INDEXC < MIN(B1,MIN(B2,MIN(B3,B4))))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR (((CROSS(INDEXC,VAR47) AND (INDEXC > (REF(INDEXC,1) * 1.056))) AND (INDEXC < MIN(B1,MIN(B2,MIN(B3,B4))))) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR ((((CROSS(INDEXC,VAR47) AND (INDEXC > MAX(B1,MAX(B2,MAX(B3,B4))))) AND (MAX(B1,B2) < MAX(B3,B4))) AND (B3 < B4)) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))) OR ((((CROSS(INDEXC,VAR47) AND (INDEXC > MAX(B1,MAX(B2,MAX(B3,B4))))) AND (MAX(B1,B2) < MIN(B3,B4))) AND (B3 > B4)) AND (COUNT(CROSS(INDEXC,VAR47),13) <= 1))))) > 21)),(HIGH * 1.02),'准备清仓逃顶!'),colorFFFF;

飞狐止损止赢主图指标公式
 

相关文章