在线检测未来函数

通达信未来波段主图指标公式

来源:Internet,编辑:股旁网,2012-12-25

谷:=TROUGHBARS(2,5,2);
峰:=PEAKBARS(2,5,2);
DRAWTEXT(CROSS(谷,峰),H*1.008,'高')COLORGREEN;
DRAWTEXT(CROSS(峰,谷),L*0.995,'低')COLORRED;
DRAWNUMBER(CROSS(谷,峰),H*1.015,HHV(H,5))COLORYELLOW;
DRAWNUMBER(CROSS(峰,谷),L*0.985,LLV(L,5))COLORGREEN;
DRAWTEXT(REF(CROSS(谷,峰),1),REF(H,1)*1.008,'出')COLORGREEN;
DRAWTEXT(REF(CROSS(峰,谷),1),REF(L,1)*0.995,'进')COLORRED;
SCGDTS:=BARSLAST(CROSS(谷,峰));
SCDDTS:=BARSLAST(CROSS(峰,谷));
SCGDGZ:=HHV(H,SCGDTS+1);
SCDDDZ:=LLV(L,SCDDTS+1);
ZDD:=(SCGDGZ-L)/L*100;
ZDZ:=(H-SCDDDZ)/SCDDDZ*100;
最大涨幅:=IF(谷<峰,ZDZ,0)NODRAW;
最大跌幅:=IF(谷>峰,ZDD,0)NODRAW;
DRAWNUMBER(谷<峰 AND ISLASTBAR,H*1.04,最大涨幅)COLORRED;
DRAWNUMBER(谷>峰 AND ISLASTBAR,H*1.04,最大跌幅)COLORGREEN;
DRAWLINE(CROSS(谷,峰),H,CROSS(峰,谷),L,0)COLORGREEN;
DRAWLINE(CROSS(峰,谷),L,CROSS(谷,峰),H,0)COLORRED;

通达信未来波段主图指标公式
 

 

相关文章