在线检测未来函数

通达信变轨CCI+KDJ指标公式

来源:Internet,编辑:股旁网,2012-12-26

TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14))/2;
CCI14:=CCI+50,COLORFFFF00,LINETHICK2;
CCI84:=(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84)),COLORFF00FF;
DRAWBAND(CCI84,RGB(220,0,130),100,RGB(0,0,0));
DRAWBAND(CCI14,RGB(220,220,0),100,RGB(0,0,0));
STICKLINE(1,90,90,2,0),COLOR00FFFF;
STICKLINE(1,80,80,2,0),COLOR00FF00;
STICKLINE(1,50,50,1,0),COLORAA0000;
STICKLINE(1,20,20,2,0),COLORFF00FF;
STICKLINE(1,10,10,2,0),COLOR0000FF;
STICKLINE(1,100,101,6,0),COLOR00FF00;
STICKLINE(1,0,-1,6,0),COLOR0000FF;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
{DRAWBAND(J,RGB(250,170,0),D,RGB(0,0,220));}
DRAWBAND(J,RGB(250,0,0),K,RGB(0,220,0));
JJ:J,COLOR00FFFF,LINETHICK1;
{DD:D,COLOR0000FF,LINETHICK1;}
KK:K,COLORFF0000;
DRAWICON(CROSS(JJ,10),10,13);
DRAWICON(CROSS(90,JJ),90,14);
DRAWICON(CROSS(CCI14,0),0,34);
DRAWICON(CROSS(100,CCI14),100,35);
STICKLINE(J<0,0,J,0.5,0),COLOR00FFFF;
STICKLINE(J>100,100,J,0.5,0),COLORWHITE;
TT:=(CURRBARSCOUNT=5-4);
DRAWNUMBER(TT AND J,J,J),COLOR00FFFF;
DRAWTEXT(ISLASTBAR,J*1.03,' ★J值★'),COLOR00FFFF;
顶底CCI:CCI14,COLORFFFF00,LINETHICK1;
CCI买卖:CCI84,COLORFF00FF,LINETHICK1;
DRAWTEXT_FIX(1,0.1,0.01,0,'★顶部标识★【绿色箭头-CCI逃顶】【蓝色球-KDJ逃顶】★【黄色山峰-顶底CCI14标识】【粉色山峰-买卖CCI84标识】'),COLORFFFF00;
DRAWTEXT_FIX(1,0.1,0.90,0,'★底部标识★【桔红箭头--CCI买入】【红球--KDJ买入】'),COLOR00FFFF;

通达信变轨CCI+KDJ指标公式

 

相关文章