在线检测未来函数

通达信纯画圆弧主图指标公式

来源:Internet,编辑:股旁网,2012-12-29

低天:=28;
高天:=10;
CURR:=CURRBARSCOUNT;
高低:=DRAWLINE(CURR=高天,H,CURR=低天,L,0);
低高:=DRAWLINE(CURR=低天,L,CURR=高天,H,0);
高低线:=IF(高天>低天,高低,低高);
DRAWBAND(高低线,RGB(225,226,199),高低线,RGB(225,226,199));
IF(CURR=高天,H,IF(CURR=低天,L,IF(CURR=ROUND((低天+高天)/2),高低线,DRAWNULL))),COLORAA00AA,CROSSDOT,LINETHICK3;
SH:=CONST(REF(H,BARSLAST(CURR=高天)));
SL:=CONST(REF(L,BARSLAST(CURR=低天)));
高低距:=SH-SL;
天距:=ABS(低天-高天);
PR:=ABS(低天-高天)/2+IF(高天>低天,低天,高天);
RN:=(SH+SL)/2;
Y弧:=(SH*SL);
BX:=2*(SH*SL)/天距;
BY:=(SH*SL)/高低距;
XW:=IF(CURR<PR,PR-CURR,CURR-PR)*BX;
SY:=IF(XW<Y弧,SQRT(Y弧*Y弧-XW*XW),0)/BY;
Y震谱1:IF(高天<低天,RN+SY,RN-SY),COLOR00FFFF;
Y震谱2:IF(高天<低天,RN-SY,RN+SY),COLOR00FFFF;

通达信纯画圆弧主图指标公式

 

相关文章