在线检测未来函数

通达信抄底红灯指标公式

来源:Internet,编辑:股旁网,2012-12-28

N:=9;M1:=3;M2:=3;M3:=5;
RSV:= (CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
FASTK:=SMA(RSV,M1,1);
K:SMA(FASTK,M2,1),COLORFF00FF;
D:SMA(K,M3,1),COLORFFFFFF;
A1:=LLV(LOW,999999);
A2:=HHV(HIGH,999999);
A3:=100/(A2-A1);
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF(VAR9>100,VAR9-100,0);
VAR11:=HHV(HIGH,34);
VAR12:=EMA((VAR6-VAR8)/(VAR11-VAR8)*100,13);
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,2);
VAR14:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF
(INDEXC,1))/INDEXC,8,1)*100-25;
VAR15:=MA(VAR14,3);
VAR16:=REF(VAR15,1);
STICKLINE(VAR12-VAR13>0,VAR12,VAR13,2,0),COLORRED;
STICKLINE(VAR12-VAR13<0,VAR12,VAR13,2,0),COLORGREEN;
生命线:=EMA(VAR13,5);
STICKLINE(CROSS(VAR13,VAR12) AND VAR12>60,80,100,3,0),COLOR00FF00;
绿灯亮卖:0,COLOR00FF00;
STICKLINE(CROSS(VAR12,VAR13) AND VAR12>VAR13 AND VAR12<18,20,0,3,0),COLORRED;
红灯亮买:0,COLORRED;
VAR21:=INDEXC;
VAR22:=MA(VAR21,6);
VAR23:=MA(VAR21,24);
VAR24:=MA(VAR21,32);
VAR25:=MA(VAR21,62);
VAR26:=MA(VAR21,105);
VAR27:=VAR25<REF(VAR25,1) AND VAR26<REF(VAR26,1) AND VAR25<VAR26*0.98;
VAR28:=VAR24>VAR22*1.11 AND VAR23>VAR22*1.095;
VAR29:=VAR22>VAR21*0.95;
抄底A:= VAR27 AND VAR28 AND VAR29 AND CLOSE/COST(8)<=0.8 AND CLOSE<OPEN;
STICKLINE(抄底A,40,60,1,1),COLORFF00FF;
抄底1:0,COLORFF00FF;
VAR2A:=CLOSE/MA(CLOSE,40)*100<78;
VAR2B:=CLOSE/MA(CLOSE,60)*100<74;
VAR2C:=HIGH>LOW*1.051;
VAR2D:=VAR2C AND COUNT(VAR2C,5)>1;
VAR2E:=VAR2D AND (VAR2A OR VAR2B);
VAR2F:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR30:=(CLOSE-VAR2F)/VAR2F*100+30-(REF(HIGH,13)/CLOSE-1.35)*100;
VAR31:=(CLOSE-REF(CLOSE,5))/CLOSE*100<-9;
VAR32:=WINNER(CLOSE);
VAR33:=EMA((INDEXC-MA(INDEXC,10))/INDEXC*100,14)<-4.9;
VAR34:=(MA(VOL,5)-VOL)/CAPITAL*100<0.8;
VAR35:=(VOL-MA(VOL,21))/VOL*100;
抄底B:= VAR33 AND VAR31 AND VAR32<0.12 AND VAR34 AND VAR35>18;
STICKLINE(抄底B,40,60,2,1),COLORYELLOW;
抄底2:0,COLORYELLOW;
VAR36:=(REF(CLOSE,1)+REF(CLOSE,2)+REF(CLOSE,3)+REF(CLOSE,4)+REF(CLOSE,5))/5;
VAR37:=(REF(CLOSE,2)+REF(CLOSE,3)+REF(CLOSE,4)+REF(CLOSE,5)+REF(CLOSE,6))/5;
VAR38:=(REF(CLOSE,3)+REF(CLOSE,4)+REF(CLOSE,5)+REF(CLOSE,6)+REF(CLOSE,7))/5;
VAR39:=(REF(CLOSE,4)+REF(CLOSE,5)+REF(CLOSE,6)+REF(CLOSE,7)+REF(CLOSE,8))/5;
VAR3A:=(REF(CLOSE,5)+REF(CLOSE,6)+REF(CLOSE,7)+REF(CLOSE,8)+REF(CLOSE,9))/5;
BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
抄底C:=(VAR36/CLOSE>1.112 OR VAR37/CLOSE>1.123 OR VAR38/CLOSE>1.135 OR VAR39/CLOSE>1.145 OR VAR3A/CLOSE>1.156) AND BIAS3<=-20 AND COST(25)/CLOSE>=1.5 AND CLOSE<OPEN;
STICKLINE(抄底C,40,60,3,1),COLOR0099FF;
{抄底3:0,COLOR0099FF;}
VAR3B:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
抄底D:= FILTER(IF(CROSS(VAR3B,-28),1,0),8);
STICKLINE(CROSS(VAR3B,-28),40,60,8,1),COLORFFFFFF;
{抄底4:0,COLORFFFFFF;}
VAR3C:=DMA(EMA(CLOSE,13),SUM(VOL,5)/2/CAPITAL);
VAR3D:=(CLOSE-VAR3C)/VAR3C*100;
抄底E:= REF(VAR3D,1)<-35 AND VAR3D>REF(VAR3D,1) AND REF(VAR3D,1)<REF(VAR3D,2) AND VAR3D-REF(VAR3D,1)>2.5;
STICKLINE(抄底E,40,60,8,1),COLORFFCC66;
{抄底5:0,COLORFFCC66;}
VAR3E:=100*WINNER(REF(CLOSE,1)*1.1)-100*WINNER(REF(CLOSE,1)*0.9);
抄底F:= CLOSE>OPEN*1.06 AND VAR3E<10;
STICKLINE(抄底F,40,60,3,1),COLORBLUE;
{抄底6:0,COLORBLUE;};

通达信抄底红灯指标公式

 

相关文章