在线检测未来函数

通达信主力进退线指标公式

来源:Internet,编辑:股旁网,2012-12-28

VAR1:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
VAR2:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR3:=SMA(VAR2,13,8);
VAR4:=SMA(VAR1,21,8);
X:=CEILING(SMA(VAR3,13,8));
底:IF((X-VAR4<(-65)),1,6),COLOR00FF00;
顶:IF((X-VAR4>85),95,100),COLORF0F000;
RSV:= (CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
FASTK:=SMA(RSV,7,1);
K:SMA(FASTK,7,1);
D:SMA(K,9,1),COLORFFFFFF;
STICKLINE(K>D,K,D,2,0),COLORRED;
STICKLINE(K<D,K,D,2,0),COLORWHITE;
强弱分界线: 50,POINTDOT, COLORF00FF0;
VAR1X:=IF(MONTH<12,1,1);
VAR3X:=(2*CLOSE+HIGH+LOW)/4;
VAR4X:=LLV(LOW,34);
VAR5X:=HHV(HIGH,34);
主力进退线:EMA((VAR3X-VAR4X)/(VAR5X-VAR4X)*100,13)*VAR1X,LINETHICK2,COLORRED;
DRAWTEXT(CROSS(K,D) OR CROSS(主力进退线,K),K-10,'B'),COLORYELLOW;
DRAWTEXT(CROSS(D,主力进退线),K+10,'S'),COLORYELLOW;
IF(主力进退线<REF(主力进退线,1),主力进退线,DRAWNULL),LINETHICK2;
NL:=VOL*(O+C+H+L)/4;
能量趋势:=SUM(NL,4)/SUM(VOL,4),COLORFFFFFF;
A:=LLV(DMA(CLOSE,VOL/CAPITAL),120);
股票大趋势:=100*(CLOSE-A)/A,COLORRED,LINETHICK2;
DRAWICON(FILTER(股票大趋势>REF(股票大趋势,1) AND 股票大趋势>REF(股票大趋势,3) AND 能量趋势>REF(能量趋势,2) ,10),30,1);

通达信主力进退线指标公式

 

相关文章