在线检测未来函数

通达信均线距离角度选股指标公式

来源:Internet,编辑:股旁网,2013-01-05

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,30);
MA4:=MA(CLOSE,60);
X1:=IF(MA1>MA2,ABS(MA1-MA2),-ABS(MA1-MA2));
X2:=IF(MA1>MA3,ABS(MA1-MA3),-ABS(MA1-MA3));
X3:=IF(MA3>MA4,ABS(MA3-MA4),-ABS(MA3-MA4));
X4:=IF(MA2>MA3,ABS(MA2-MA3),-ABS(MA2-MA3));
XJL:= X2>REF(X2,1)AND X3>REF(X3,1) AND (X1>REF(X1,1) OR X4>REF(X4,1)) ;
JD1:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;
JD2:=ATAN((MA2/REF(MA2,1)-1)*100)*180/3.1416;
JD3:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416;
JD4:=ATAN((MA4/REF(MA4,1)-1)*100)*180/3.1416;
XJD1:=CROSS(JD1,JD2);
XJD2:=CROSS(JD1,JD3);
XJD3:=CROSS(JD1,JD4);
XJD4:=CROSS(JD2,JD3);
XJD5:=CROSS(JD2,JD4);
XJDS:=JD2>REF(JD2,1) AND JD4>REF(JD4,1) AND JD3>REF(JD3,1) AND JD1>REF(JD1,1) ;
XJDC:=(COUNT(XJD2,3) AND COUNT(XJD3,3)) OR (REF(JD2,1)<REF(JD2,2) AND REF(JD1,1)<REF(JD1,2) AND REF(JD3,1)<REF(JD3,2) AND REF(JD2,2)>REF(JD2,3) AND REF(JD3,2)>REF(JD3,3) AND REF(JD1,2)>REF(JD1,3));
DD:=EMA((C*3+H+L+O)/6,5);
YL:=DD>=REF(DD,1) AND C>DD;
JDJL:FILTER(YL AND XJDS AND XJDC AND XJL AND MA2>=REF(MA2,1) AND C>MA1 AND C>MA3 AND L<MA1,7);

通达信均线距离角度选股指标公式

 

相关文章