在线检测未来函数

通达信五里操盘选股指标公式

来源:Internet,编辑:股旁网,2013-01-06

DIF:=(EMA(C,12)-EMA(C,26));
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
MJBT:=EXIST((CROSS(DIF,DEA) AND DIF>0) OR CROSS(DIF,0),5) ;
MVOL5:=MA(V,5);
MVOL10:=MA(V,10);
MVOL20:=MA(V,20);
量托:=MVOL5>=MVOL20 AND CROSS(MVOL10,MVOL20) AND REF(MVOL10,1)<REF(MVOL20,1);
VJBT:=EXIST(CROSS(MVOL5,MVOL10) OR 量托,5);
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA60:=MA(C,60);
MA120:=MA(C,120);
T1:=BARSLAST(REF(LONGCROSS(MA60,MA120,55),1));
JJC:=CROSS(MA5,MA10) AND T1<30;
SJBT:=FILTER(MJBT AND JJC AND VJBT,5);
RSV:=(((C-LLV(L,60))/(HHV(H,60)-LLV(L,60)))*100);
K:=SMA(RSV,10,1),COLOR0000FF,LINETHICK1;
D:=SMA(SMA(RSV,10,1),3,1),COLORFFFFFF,LINETHICK1;
J:=SMA(K,10,1),COLOR00FF00,LINETHICK1;
DBU:=(((C/COST(13))<=0.78)*17);
BT01:=LONGCROSS(K,16.18,5) AND D<19.1;
BT02:=LONGCROSS(K,D,8) AND D<16.18;
FTBT:=FILTER(COUNT(BT01 OR BT02,3)=2,3);
BT03:=FILTER(CROSS(K,D) AND EXIST(DBU=17,3),3);
XG01:=SJBT OR FTBT OR BT03;
LC:=REF(C,1);
RSI5:=SMA(MAX(C-LC,0),5,1)/SMA(ABS(C-LC),5,1)*1000;
DC:=RSI5-LLV(RSI5,10);
AV:=(MA(DC,3)*5+DC*15)/20;
DXRSI:=IF(AV>13,MA(AV,3),AV)/6;
MADXRSI:=MA(DXRSI,5),COLORBBBBBB;
DXBT:=CROSS(DXRSI,1) AND DXRSI<30;
ABS34:=MA(-100*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34)),20);
BS13:=-100*(HHV(H,13)-C)/(HHV(H,13)-LLV(L,13));
EBS5:=EMA(-100*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34)),5);
VBS13:=BS13+100;
VABS34:=ABS34+100;
VEBS5:=EBS5+100;
底区:=(VABS34<12 AND VEBS5<8 AND (VBS13<7.2 OR REF(VBS13,1)<5) AND (VEBS5>REF(VEBS5,1)
OR VBS13>REF(VBS13,1))) OR (VABS34<8 AND VEBS5<7 AND VBS13<15 AND VBS13>REF(VBS13,1))
OR (VABS34<10 AND VEBS5<7 AND VBS13<1);
低金:=(VABS34<15 AND REF(VABS34,1)<15 AND VEBS5<18 AND VBS13>REF(VBS13,1) AND
CROSS(VBS13,VABS34) AND VBS13>VEBS5 AND (REF(VBS13,1)<5 OR REF(VBS13,2)<5 ) AND
(VEBS5>=VABS34 OR REF( VBS13,1)<1 ));
FZBT:=DXBT AND 低金;
FZXG:=低金 OR FZBT;
VARF11:=(C-MA(C,55))/MA(C,55)*100<-30 AND (C-MA(C,89))/MA(C,89)*100<-27
AND COUNT((C-MA(C,55))/MA(C,55)*100<-30 AND (C-MA(C,89))/MA(C,89)*100<-27,2)=1
AND (O-REF(C,1))/REF(C,1)>-0.07 AND COUNT(C=O,6)=0,COLORCCCCCC;
VARF21:=(C-DMA(EMA(C,8),SUM(V,9)/2.8/CAPITAL))/DMA(EMA(C,8),SUM(V,9)/2.8/CAPITAL)*100,COLOR00AAAA;
VARF31:=REF(VARF21,1)<-46 AND VARF21>REF(VARF21,1) AND REF(VARF21,1)<REF(VARF21,2) AND VARF21-REF(VARF21,1)>2.2;{-42,1.8}
JDBT1:=(VARF11 OR VARF31)*10,COLOR0000FF,LINETHICK2;
JDBT2:=LONGCROSS(VARF21,-23,3);
JDXG:=JDBT1 OR JDBT2;
XG02:=FILTER(FZXG OR JDXG,5);
XG:=XG01 OR XG02;
{基本面部分}
LTP:=FINANCE(7)<300000000 AND FINANCE(1)<500000000; {流通盘股小于3亿股,总盘小于5亿}
MGSY:=FINANCE(33)>0.02 AND BARSCOUNT(C)>30;
SYL:=C/FINANCE(33)<200 AND C/FINANCE(33)>5; {市盈率低于200}
JZC:=FINANCE(34)>2;{ 每股净资产}
{通达信去掉*、S、ST}
S2:=IF(NAMELIKE('S'),0,1);
S3:=IF(NAMELIKE('*'),0,1);
GJFW:=DYNAINFO(7)>3 AND DYNAINFO(7)<40;{3元-40元价格的股}
XGJ:=LTP AND MGSY AND SYL AND JZC AND S2 AND S3 AND GJFW;
W18:EXIST(XG AND XGJ,3);

通达信五里操盘选股指标公式

 

相关文章