在线检测未来函数

通达信五里操盘指标公式

来源:Internet,编辑:股旁网,2013-01-06

DIF:=(EMA(C,12)-EMA(C,26));
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
MJBT:=EXIST((CROSS(DIF,DEA) AND DIF>0) OR CROSS(DIF,0),5) ;
MVOL5:=MA(V,5);
MVOL10:=MA(V,10);
MVOL20:=MA(V,20);
量托:=MVOL5>=MVOL20 AND CROSS(MVOL10,MVOL20) AND REF(MVOL10,1)<REF(MVOL20,1);
VJBT:=EXIST(CROSS(MVOL5,MVOL10) OR 量托,5);
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA60:=MA(C,60);
MA120:=MA(C,120);
T1:=BARSLAST(REF(LONGCROSS(MA60,MA120,55),1));
JJC:=CROSS(MA5,MA10) AND T1<30;
SJBT:FILTER(MJBT AND JJC AND VJBT,5);
DRAWBAND(0,RGB(0,0,0),SJBT*18,RGB(218,218,18));
DRAWTEXT(SJBT,16,'牛三金'),COLOR0078FF;
RSV:=(((C-LLV(L,60))/(HHV(H,60)-LLV(L,60)))*100);
K:SMA(RSV,10,1),COLOR0000FF,LINETHICK1;
D:SMA(SMA(RSV,10,1),3,1),COLORFFFFFF,LINETHICK1;
J:SMA(K,10,1),COLOR00FF00,LINETHICK1;
DBU:=(((C/COST(13))<=0.78)*17);
STICKLINE(DBU,0,6,3,0),COLOR0067DF;
BT01:=LONGCROSS(K,16.18,5) AND D<19.1;
BT02:=LONGCROSS(K,D,8) AND D<16.18;
FTBT:=FILTER(COUNT(BT01 OR BT02,3)=2,3);
DRAWBAND(0,RGB(0,0,0),FTBT*15,RGB(218,18,218));
DRAWTEXT(FTBT,16,'★反弹'),COLORFF00FF;
BT03:=FILTER(CROSS(K,D) AND EXIST(DBU=17,3),3);
DRAWBAND(0,RGB(0,0,0),BT03*18,RGB(218,18,18));
DRAWTEXT(BT03,16,'★金底'),COLOR0000FF;
ST01:=LONGCROSS(K,80,5) AND D>76;
ST02:=LONGCROSS(D,K,5) AND D>70;
ST:=ST01 OR ST02;
DRAWBAND(100,RGB(18,18,218),100-ST*17,RGB(18,18,18));
DRAWTEXT(ST,80,'★顶'),COLOR00FF00;
底线:20,COLORFF00FF,LINETHICK1,DOTLINE;
分水线:50,COLORFFFFFF,LINETHICK1,DOTLINE;
顶线:80,COLOR00FF00,LINETHICK1,DOTLINE;
{RSI}
LC:=REF(C,1);
RSI5:=SMA(MAX(C-LC,0),5,1)/SMA(ABS(C-LC),5,1)*1000;
DC:=RSI5-LLV(RSI5,10);
AV:=(MA(DC,3)*5+DC*15)/20;
DXRSI:=IF(AV>13,MA(AV,3),AV)/6;
MADXRSI:=MA(DXRSI,5),COLORBBBBBB;
DXBT:=CROSS(DXRSI,1) AND DXRSI<30;
{BIAS}
ABS34:=MA(-100*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34)),20);
BS13:=-100*(HHV(H,13)-C)/(HHV(H,13)-LLV(L,13));
EBS5:=EMA(-100*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34)),5);
VBS13:=BS13+100;
VABS34:=ABS34+100;
VEBS5:=EBS5+100;
底区:=(VABS34<12 AND VEBS5<8 AND (VBS13<7.2 OR REF(VBS13,1)<5) AND (VEBS5>REF(VEBS5,1)
OR VBS13>REF(VBS13,1))) OR (VABS34<8 AND VEBS5<7 AND VBS13<15 AND VBS13>REF(VBS13,1))
OR (VABS34<10 AND VEBS5<7 AND VBS13<1);
低金:=(VABS34<15 AND REF(VABS34,1)<15 AND VEBS5<18 AND VBS13>REF(VBS13,1) AND
CROSS(VBS13,VABS34) AND VBS13>VEBS5 AND (REF(VBS13,1)<5 OR REF(VBS13,2)<5 ) AND
(VEBS5>=VABS34 OR REF( VBS13,1)<1 ));
FZBT:=DXBT AND 低金;
FZXG:=低金 OR FZBT;
VARF11:=(C-MA(C,55))/MA(C,55)*100<-30 AND (C-MA(C,89))/MA(C,89)*100<-27
AND COUNT((C-MA(C,55))/MA(C,55)*100<-30 AND (C-MA(C,89))/MA(C,89)*100<-27,2)=1
AND (O-REF(C,1))/REF(C,1)>-0.07 AND COUNT(C=O,6)=0,COLORCCCCCC;
VARF21:=(C-DMA(EMA(C,8),SUM(V,9)/2.8/CAPITAL))/DMA(EMA(C,8),SUM(V,9)/2.8/CAPITAL)*100,COLOR00AAAA;
VARF31:=REF(VARF21,1)<-46 AND VARF21>REF(VARF21,1) AND REF(VARF21,1)<REF(VARF21,2) AND VARF21-REF(VARF21,1)>2.2;{-42,1.8}
JDBT1:=(VARF11 OR VARF31)*10,COLOR0000FF,LINETHICK2;
JDBT2:=LONGCROSS(VARF21,-23,3);
JDXG:=JDBT1 OR JDBT2;
W118:=FILTER(FZXG OR JDXG,5);
DRAWBAND(0,RGB(0,0,0),W118*17,RGB(218,218,218));
DRAWTEXT(W118,18,'★谷底'),COLORFFFFFF;
DRAWTEXT_FIX(1,0.0,0.003,0,'★原理1: 根据60KDJ判断买点!!! 【橙块底部关注区】+【金底】+【反弹】
+【谷底】为抄底信号; 【牛三金】为牵牛信号!!!'),COLORBBBBBB;
DRAWTEXT_FIX(1,0.0,0.083,0,'★原理2: 根据K线-MACD-量VOL三金叉判断买点!!! 当C>MA60时的三金叉为五里牛三金,是可靠的买入信号!!!'),COLOR0078FF;

通达信五里操盘主图指标公式

 

相关文章