在线检测未来函数

通达信DDX趋势背离指标公式

来源:Internet,编辑:股旁网,2013-01-09

N1:=14;N:=8;
AAQ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量:=IF(CLOSE>OPEN,AAQ*(HIGH-LOW),IF(CLOSE<OPEN,AAQ*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),LINETHICK0,COLORRED;
卖量:=IF(CLOSE>OPEN,0-AAQ*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AAQ*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORCYAN;
进出量:=买量+卖量,COLOR00FFFF;
N日内净流入:SUM(进出量,5),LINETHICK2,COLORFF55BB;
流入:=IF(N日内净流入>REF(N日内净流入,1),N日内净流入,DRAWNULL),COLORYELLOW,LINETHICK2;
RSI1:=N日内净流入;
AA:=REF(RSI1,N)=HHV(RSI1,2*N+1);
BB:=BACKSET(AA,N+1);
CC:=FILTER(BB,N) AND RSI1=HHV(RSI1,N+1);
A1:=BARSLAST(REF(CC,1));
背离:=REF(CLOSE,A1+1)<CLOSE AND REF(RSI1,A1+1)>RSI1 AND CC;
STICKLINE(FILTER(顶背离>0,5),100,RSI1,1,0),COLORRED;
DRAWLINE(CC,RSI1,FILTER(顶背离>0,5),RSI1,0),COLORRED;
AA2:=REF(RSI1,N)=LLV(RSI1,2*N+1);
BB2:=BACKSET(AA2,N+1);
CC2:=FILTER(BB2,N) AND RSI1=LLV(RSI1,N+1);
A2:=BARSLAST(REF(CC2,1));
底背离:=REF(CLOSE,A2+1)>CLOSE AND REF(RSI1,A2+1)<RSI1 AND CC2;
STICKLINE(FILTER(底背离>0,5),0,RSI1,1,0),COLORCYAN;
DRAWLINE(CC2,RSI1,FILTER(底背离>0,5),RSI1,0),COLORCYAN;
0,LINETHICK2,COLORGREEN ;

通达信DDX趋势背离指标公式

 

相关文章