在线检测未来函数

通达信见涨就买见跌就卖指标公式

来源:Internet,编辑:股旁网,2013-01-07

多头线:(SUM((((2)*(CLOSE-CLOSE*0.2)+(OPEN-OPEN*0.2)+(HIGH-HIGH*0.2)+(LOW-LOW*0.2))/(5))*(VOL),8))/(SUM(VOL,8)),COLOR0099FF;
空头线:LLV(多头线,8),COLORGREEN;
C-C*0.2,COLORWHITE;
VAR1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2:=CROSS(VAR1,0.9);
VAR3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4:=CROSS(VAR3,0.9);
压力: REF(HIGH,BARSLAST(VAR2)), POINTDOT,COLOREA91B5;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2)),REF(HIGH,BARSLAST(VAR2)),5,0),COLOREA91B5;
支撑: REF(LOW,BARSLAST(VAR4)), POINTDOT,COLOR3791B5;
STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4)),REF(LOW,BARSLAST(VAR4)),5,0),COLOR3791B5;
DRAWTEXT(VAR2,HIGH*1.01,'跌'),COLOR00E40E;
VAR5:=IF(VAR2,HIGH,IF(VAR4,LOW,0));
VAR6:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);
VAR7:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);
VAR8:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1)
AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);
VAR9:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);
VARA:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);
VARB:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1)
AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);
DRAWTEXT(CROSS(VAR9,0.9),LOW*0.99,'涨'),COLOR0000FF;
现价:CLOSE,POINTDOT,COLORRED;

通达信见涨就买见跌就卖指标公式

 

相关文章