在线检测未来函数

通达信征战股市指标公式

来源:Internet,编辑:股旁网,2013-01-11

有买卖提示,可波段操作,红色持仓,蓝色减仓,有未来函数,仅供参考,高手可慎用.

VAR3:=REF(CLOSE,2);
VAR4:=((SMA(MAX(CLOSE-VAR3,0),7,1))/(SMA(ABS(CLOSE-VAR3),7,1)))*(100);
DRAWTEXT((VAR4<REF(VAR4,1)) AND (VAR4>79),135,'高位'),COLOR00F200;
VAR5:=((CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80)))*(200);
VARA:=SMA(VAR5,3,1);
VARB:=SMA(VARA,3,1);
VARC:=(3)*(VARA)-(2)*(VARB);
VARD:=LLV(LOW,5);
VARE:=HHV(HIGH,5);
VARF:=(EMA(((CLOSE-VARD)/(VARE-VARD))*(100),4))*(2);
VAR6:=EMA((0.66699999)*(REF(VARF,1))+(0.333)*(VARF),2);
VAR7:=(3)*(VARF)-(2)*(VAR6);
VAR8:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VAR9:=POW(MA(LOW,5),2)+MA(LOW,5);
VAR10:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VAR11:=((VAR8-LLV(VAR9,64))/(HHV(VAR10,64)-LLV(VAR9,64)))*(150)+65-10;
VAR12:=(SMA(VAR11,3,1))*(1.5)-100;
VAR13:=SMA(VAR12,3,1);
VAR14:=(3)*(VAR12)-(2)*(VAR13);
VAR15:=(HIGH+LOW+(CLOSE)*(2))/(4);
VAR1A:=EMA(VAR15,13);
VAR1B:=STD(VAR15,13);
VAR1C:=((VAR15-VAR1A)*(100))/(VAR1B);
VAR1D:=EMA(VAR1C,5);
VAR1E:=EMA(VAR1D,13);
VAR1F:=EMA(VAR1D,13)+200-100;
VAR16:=EMA(VAR1F,10);
VAR17:=(3)*(VAR1F)-(2)*(VAR16);
VAR18:=VARA+VARF+VAR12+VAR1F;
VAR19:=VARB+VAR6+VAR13+VAR16;
VAR20:=VARC+VAR7+VAR14+VAR17;
VAR21:=(HIGH+LOW+CLOSE)/(3);
VAR22:=((AMOUNT)/(VOL))/(100);
VAR23:=((SUM(AMOUNT,5))/(SUM(VOL,5)))/(100);
VAR24:=(VAR21-MA(VAR21,34))/((0.015)*(AVEDEV(VAR21,34)));
VAR25:=DMA(((AMOUNT)/(VOL))/(100),(VOL)/(CAPITAL));
VAR2A:=(HIGH+LOW+CLOSE+VAR21)/(4);
VAR2B:=EMA(VAR2A,24);
VAR2C:=STD(VAR2A,24);
VAR2D:=((VAR2A-VAR2B)/(VAR2C))*(100);
VAR2E:=(VAR21-MA(VAR21,24))/((0.015)*(AVEDEV(VAR21,24)));
VAR2F:=EMA(VAR2D,5);
VAR26:=((VAR2F+VAR2E+VAR24)/(3)+165)/(4);
VAR27:=(EMA(EMA(EMA(VAR26,15),10),5)-25)*(2)+VAR25;
VAR28:=((VAR18+VAR19+(VAR20)*(30))/(32))/(5)-15;
VAR29:=EMA(VAR28,13);
VAR30:=EMA(CLOSE,8);
VAR31:=EMA(VAR30,20);
VAR3A:=CROSS(VAR30,VAR31);
VAR3B:=(VAR30<EMA(CLOSE,120));
VAR3C:=(3)*(SMA(((CLOSE-LLV(LOW,65))/(HHV(HIGH,65)-LLV(LOW,65)))*(100),5,1))-(2)*(SMA(SMA(((CLOSE-LLV(LOW,65))/(HHV(HIGH,65)-LLV(LOW,65)))*(100),5,1),3,1));
VAR3D:=EMA(VAR3C,3);
VAR3E:=EMA((VAR27+VAR29)/(2),2);
STICKLINE((VAR3E-REF(VAR3E,1)>0),VAR3E,0,3,0),COLOR0000EC;
STICKLINE((VAR3E-REF(VAR3E,1)>0),VAR3E,0,2,0),COLOR0000E9;
STICKLINE((VAR3E-REF(VAR3E,1)<0),VAR3E,0,3,0),COLOR00E100;
STICKLINE((VAR3E-REF(VAR3E,1)<0),VAR3E,0,2,0),COLOR00F200;
STICKLINE((VAR3E-REF(VAR3E,1)<0),VAR3E,0,1,0),COLORFFFF00;
底:DRAWTEXT(FILTER(CROSS(VAR3D,10),34),(-2),'底'),COLORYELLOW;
DRAWICON(底,5,1);
VAR3F:=((CLOSE-MA(CLOSE,6))/(MA(CLOSE,6)))*(100);
VAR32:=((CLOSE-MA(CLOSE,12))/(MA(CLOSE,12)))*(100);
VAR33:=((CLOSE-MA(CLOSE,24))/(MA(CLOSE,24)))*(100);
VAR34:=(VAR3F+(2)*(VAR32)+(3)*(VAR33))/(6);
DRAWICON(VAR3A AND VAR3B,10,5);
DRAWTEXT(VAR3A AND VAR3B,10,'可加仓'),COLORYELLOW;

通达信征战股市指标公式

 

相关文章