在线检测未来函数

飞狐AO动量指标公式

来源:Internet,编辑:股旁网,2013-01-13

VAR1:=(HIGH+LOW)/2;
AO:MA(VAR1,5)-MA(VAR1,34),LINETHICK0;
STICKLINE(AO>=REF(AO,1),0,AO,2.2,1),COLORRED;
STICKLINE(AO<REF(AO,1),0,AO,2.2,1),COLORGREEN;
AO5:MA(AO,5),COLORFF6600;
S1:=CROSS(0,AO);
DRAWTEXT(S1,AO,'S'),COLORWHITE;
DRAWICON(S1,AO,2);
S2:=AO<0 AND REF(AO,1)>REF(AO,2) AND AO<REF(AO,1);
DRAWTEXT(S2,AO,'S'),COLORWHITE;
DRAWICON(S2,AO,2);
SCOUNT:=BARSLAST(AO<0);
SD:=HHV(AO,SCOUNT);
SCOUNTD:=HHVBARS(AO,SCOUNT);
S3:=AO>0 AND REF(AO,1)>REF(AO,2) AND AO<REF(AO,1);
S31:=COUNT(S3,SCOUNTD);
DRAWTEXT(S31>=2 AND S3,AO,'S'),COLORWHITE;
DRAWICON(S31>=2 AND S3,AO,2);
B1:=CROSS(AO,0);
DRAWTEXT(B1,AO,'B'),COLORWHITE;
DRAWICON(B1,AO,1);
B2:=AO>0 AND REF(AO,1)<REF(AO,2) AND AO>REF(AO,1) ;
DRAWTEXT(B2,AO,'B'),COLORWHITE;
DRAWICON(B2,AO,1);
BCOUNT:=BARSLAST(AO>0);
BD:=LLV(AO,BCOUNT);
BCOUNTD:=LLVBARS(AO,BCOUNT);
B3:=AO<0 AND REF(AO,1)<REF(AO,2) AND AO>REF(AO,1);
B31:=COUNT(B3,BCOUNTD);
DRAWTEXT(B31>=2 AND B3,AO,'B'),COLORWHITE;
DRAWICON(B31>=2 AND B3,AO,1);

飞狐AO动量指标公式

 

相关文章