在线检测未来函数

通达信飞剑主图指标公式

来源:Internet,编辑:股旁网,2013-01-13

MA3:=MA(C,3);MA5:MA(C,5);MA10:MA(C,10);MA20:MA(C,20);MA60:MA(C,60);
M3:=MA3>REF(MA3,1) AND REF(MA3,1)<=REF(MA3,2);
M5:=MA5>REF(MA5,1) AND REF(MA5,1)<=REF(MA5,2);
M5DOWN:=MA5<REF(MA5,1) AND REF(MA5,1)>=REF(MA5,2);
M510:=ABS(MA5-MA10);
M520:=ABS(MA5-MA20);
{买入条件}
MA5TG:=LLV(MA5,7)>LLV(MA5,20);
M510SX:=HHV(M510,3)<HHV(M510,13);
M520SX:=HHV(M520,3)<HHV(M520,13);
STICKLINE(M510SX AND M520SX AND M5,O,C,3,0),COLORMAGENTA;
T1:=BARSLAST(C/REF(C,1)<=0.97);
DYFZ:=M3 AND C>=(REF(C,T1)+REF(O,T1))/2*0.98 AND COUNT(C<REF(C,1),7)>=2;
STICKLINE(DYFZ,O,C,3,0),COLORYELLOW;
CSX:=C>MA5 AND C>MA10 AND C>MA20 AND L<MA20;
PL:=ABS(MA5-MA10)/MA5*100<2 AND ABS(MA5-MA20)/MA5*100<5;
DRAWTEXT(CSX AND PL,LOW,'买'),COLORRED;
大底:=M520SX AND CROSS(C,MA60) AND MA60>REF(MA60,1)*0.98 AND
MA60<REF(MA60,1)*1.02 AND COUNT(MA60<REF(MA60,1),20)>13
AND ABS(MA20-MA60)/MA20*100<5;
DRAWTEXT(大底,LOW,'大底'),COLORMAGENTA;
{卖出条件}
TOWFL:=C<REF(C,1) AND REF(C,1)>REF(C,2);
STICKLINE(TOWFL AND M5DOWN,O,C,3,0),COLORGREEN;

通达信飞剑主图指标公式

 

相关文章