在线检测未来函数

通达信牛股浮出指标公式

来源:Internet,编辑:股旁网,2013-01-14

RSVCC:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
STICKLINE( RSVCC>0,100,50,10,0),COLOR660044;
STICKLINE( RSVCC>0,50,0,10,0),COLOR003300;
N:=9;M1:=3;M2:=3;P:=9;
快线:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,,COLORRED,LINETHICK2;
慢线:=SMA(快线,M1,1)COLORCYAN;
空:=SMA(慢线,M2,1),COLOR00FF00;
牛股浮出:IF(BARSLAST(CROSS(慢线,空))<P AND BARSLAST(CROSS(空,慢线))<P AND CROSS(慢线,空) AND 慢线<20,90,0),COLOR0099FF;
STICKLINE(牛股浮出,0,60,9,0),COLORGREEN;
STICKLINE(牛股浮出,0,70,7,0),COLORFF0033;
STICKLINE(牛股浮出,0,80,6,0),COLORFF0066;
STICKLINE(牛股浮出,0,90,5,0),COLORFF0099;
STICKLINE(牛股浮出,0,100,3,0),COLORFF00CC;
STICKLINE(牛股浮出,0,105,1.5,0),COLOR0099FF;
STICKLINE(牛股浮出,0,105,0.6,0),COLORRED;
AA:=LLV(LOW,13);
BB:=HHV(HIGH,13);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
股海神偷:DD,COLORRED,LINETHICK2;
股海:=(((DD-LLV(DD,21))/(HHV(DD,13)-LLV(DD,21)))*(4))*(25);
真海神偷:IF(CROSS(股海,90) AND (股海神偷<40),70,0),COLORMAGENTA;
{DRAWICON(CROSS(股海,90),45,5);}
跟踪:10,COLORFF00FF;
神偷隐现:IF(股海神偷<55,20,1)COLORCYAN,LINETHICK2;
REF(股海神偷,1)>=1 AND (REF(股海神偷,2));
REF(REF(股海神偷,1),2)AND (股海神偷<跟踪),COLOR00FFFF;
IF((COUNT((股海神偷>REF(股海神偷,1)),1)=1) AND (REF(股海神偷,1)<REF(REF(股海神偷,1),1)) AND (股海神偷<跟踪),50,0),COLORF00FF0;
风险:80,COLORFF00FF;
狼狗:87.5,COLOR00FF00;
VAR6:=(2*C+H+L)/4;
VAR8:=LLV(LOW,30);
VARA:=HHV(HIGH,30);
B:=EMA((VAR6-VAR8)/(VARA-VAR8)*100,8);
B1:=EMA(B,5);
STICKLINE(B>0 AND B-B1>=0,79,80,8,0),COLOR00FF00;
STICKLINE(B>0 AND B-B1<0,79,80,8,0),COLORRED;
STICKLINE(B>0 AND B-B1>=0,49,50,8,0),COLORCYAN;
STICKLINE(B>0 AND B-B1<0,49,50,8,0),COLORRED;
STICKLINE(B>0 AND B-B1>=0,19,20,8,0),COLOR00FF00;
STICKLINE(B>0 AND B-B1<0,19,20,8,0),COLORRED;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VARB:=HHV(HIGH,34);
VARC:=EMA((VAR6-VAR8)/(VARB-VAR8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VARF:=MA(VARE,3);
VAR10:=REF(VARF,1);
红柱出现为买入: STICKLINE(CROSS(VARC,VARD) AND VARC>VARD AND VARC<18,20,0,30,0), COLORRED;
STICKLINE(B-B1>0,B,B1,8,0),COLORRED;
STICKLINE(B-B1<0,B,B1,8,0),COLORCYAN;

通达信牛股浮出指标公式

 

相关文章