在线检测未来函数

飞狐中线波段指标公式

来源:Internet,编辑:股旁网,2013-01-16

VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF(VAR9>100,VAR9-100,0);
VAR11:=HHV(HIGH,34);
VAR12:=EMA((VAR6-VAR8)/(VAR11-VAR8)*100,13);
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,2);
VAR14:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VAR15:=MA(Var14,3);
VAR16:=REF(VAR15,1);
STICKLINE(VAR12-VAR13>0,VAR12,VAR13,8,0),COLORRED;
STICKLINE(VAR12-VAR13<0,VAR12,VAR13,8,0),COLOR00FF0F;
生命线:EMA(VAR13,5) COLORYELLOW;
绿灯亮卖:STICKLINE(cross(VAR13,VAR12) and VAR12>60,80,100,8,0),COLORGREEN;
红灯亮买:STICKLINE(cross(VAR12,VAR13) and VAR12>VAR13 and VAR12<18,20,0,8,0),COLORRED;
短卖:STICKLINE((CROSS(VAR16,VAR15)),30,50,2,0);
短买:STICKLINE((CROSS(VAR15,VAR16)),70,50,2,0);

飞狐中线波段指标公式

 

相关文章