在线检测未来函数

同花顺花仙子四色指标公式

来源:Internet,编辑:股旁网,2013-01-16

指标的使用很简单,蓝色代表趋势线。其他不同颜色表示股价所处的相对位置。 使用时配合其他分析手段效果更佳。

N1:=17;N2:=34;
STICKLINE(C>0,40,60,10,0),COLOR999999;
RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
短K:SMA(RSV,3,1),COLORF580F5,LINETHICK0;
短D:SMA(短K,3,1),COLORCCDD33,LINETHICK0;
RSV1:=(CLOSE-LLV(LOW,N2))/(HHV(HIGH,N2)-LLV(LOW,N2))*100;
中K:SMA(RSV1,5,1),colorred,LINETHICK0;
中D:SMA(中K,10,1),COLOR00FFFF,LINETHICK0;
短:=3*短K-2*短D,colorred,LINETHICK4;
中:=3*中K-2*中D,colorred,LINETHICK4;
趋势线:(短+中)/2,COLORFF9900,LINETHICK2;
底线:10,colorwhite;
顶线:90,COLOR33FF33;
BB:=IF(BARSLAST(CROSS(短K,RSV))>=3 AND CROSS(RSV,短K) AND 短K<30,20,0);
STICKLINE(BB,0,50,2.8,1),COLOR0000BB;
STICKLINE(BB,0,50,1.4,1),COLOR0000DD;
STICKLINE(BB,0,50,0.7,1),COLOR0000FF;
AA:=IF(BARSLAST(CROSS(RSV,短K))>=4 AND CROSS(短K,RSV) AND RSV>50,20,0);
STICKLINE(AA,80,100,2.8,1),COLORD8D8D8;
STICKLINE(AA,80,100,1.4,1),COLORE8E8E8;
STICKLINE(AA,80,100,0.7,1),COLORFFFFFF;
STICKLINE(短K>短D,短K,短D,2.8,1),COLOR820082;
STICKLINE(短K>短D,短K,短D,1.4,1),COLORB700B7;
STICKLINE(短K>短D,短K,短D,0.7,1),COLORF700F7;
STICKLINE(短K>短D,短K,短D,0.1,1),COLORFF37FF;
STICKLINE(短K<=短D,短K,短D,2.8,1),COLORBFBF00;
STICKLINE(短K<=短D,短K,短D,1.4,1),COLORE8E800;
STICKLINE(短K<=短D,短K,短D,0.7,1),COLORFFFF15;
STICKLINE(短K<=短D,短K,短D,0.1,1),COLORFFFF46;
STICKLINE(中K>中D,中K,中D,2.8,0),COLOR000099;
STICKLINE(中K>中D,中K,中D,1.4,0),COLOR0000DD;
STICKLINE(中K>中D,中K,中D,0.7,0),COLOR0000CC;
STICKLINE(中K>中D,中K,中D,0.1,0),COLOR0000FF;
STICKLINE(中K<=中D,中K,中D,2.8,0),COLOR009FFF;
STICKLINE(中K<=中D,中K,中D,1.4,0),COLOR00B5FF;
STICKLINE(中K<=中D,中K,中D,0.7,0),COLOR00E4FF;
STICKLINE(中K<=中D,中K,中D,0.1,0),COLOR00FFFF;

同花顺花仙子四色指标公式

 

相关文章