在线检测未来函数

通达信黑马强牛指标公式

来源:Internet,编辑:股旁网,2013-01-19

VAR3:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),13)/4;
VAR4:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),44)/4;
VAR5:=EMA(CLOSE,1)-EMA(CLOSE,1297);
VAR6:=EMA(VAR5,715);
VAR7:=2*(VAR5-VAR6);
VAR8:=POW(VAR7,3)*0.1+POW(VAR7,2);
VARA:=EMA(CLOSE,2)-EMA(CLOSE,34);
VARB:=EMA(VARA,33);
VARC:=2*(VARA-VARB);
VARD:=POW(VARC,3)*0.1+POW(VARC,3);
VARF:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR10:=EMA(VARF,30);
VAR11:=2*(VARF-VAR10)*10;
VAR12:=POW(VAR11,3)*0.1+POW(VAR11,2);
VAR13:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR14:=EMA(VAR13*0.97,3);
VAR15:=(HIGH+LOW+CLOSE)/3;
VAR16:=(VAR15-MA(VAR15,14))/(0.015*AVEDEV(VAR15,14));
VAR17:=IF(VAR11>0.015,VAR12,0)*100;
VAR18:=(CLOSE-LLV(CLOSE,95))/(HHV(CLOSE,95)-LLV(CLOSE,95))*100;
VAR19:=VOL/240>MA(VOL,6)/240 AND CLOSE>OPEN*1.003;
VAR1A:=VAR19 AND CLOSE<MA(CLOSE,10)*1.05 AND CLOSE<MA(CLOSE,10)*1.3;
VAR1B:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),0-VOL,0)),0)/1000;
VAR1C:=MA(VAR1B,13);
VAR1D:=VAR1B-VAR1C;
VAR1E:=EMA(VAR1D,3);
VAR1F:=CROSS(VAR1D,VAR1E);
强马: IF(FILTER(CROSS(EMA(CLOSE,6),EMA(CLOSE,11)) AND VAR3<10 AND VARD>0 AND VAR17>0 AND VAR18<30 AND VAR1F,90)=1,20,0),STICK , COLORRED;
强牛: IF(FILTER(CROSS(EMA(CLOSE,3),EMA(CLOSE,13)) AND VAR17>0 AND VAR4<5 AND VAR8>0 AND VAR18<30 AND VAR1A,5)=1,20,0),STICK , COLOR6699CC;
强龙: IF(FILTER(强马 AND 强牛 AND VAR1A,5)=1,20,0),STICK , COLORYELLOW;
{www.gupang.com 股旁网_通达信指标公式}
红马线: (CLOSE-MA(CLOSE,42))/MA(CLOSE,42)*100, COLORSTICK;
见底: IF(HHV(CLOSE,20)/CLOSE>1.15 AND HIGH/LOW>1.05 AND CROSS(-28,红马线)*1/2,20,0),STICK , COLORFF0000;
强势必行: IF(FILTER(红马线>0 AND 强马 AND 红马线>0 AND 强牛 OR 红马线>0 AND 强龙,5)=1,30,0),LINETHICK2 , COLORYELLOW;
当日强势预警: (强马 OR 强牛) AND DYNAINFO(14)>=0.02 AND DYNAINFO(17)>=0.5, COLORFF6600;
DRAWTEXT(强马>0,5,'马') ;
DRAWTEXT(强牛>0,13,'牛'), COLOR6699CC;
DRAWTEXT(强龙>0,18,'龙'), COLORYELLOW;
DRAWTEXT(见底>0,-7,'见底'), COLORMAGENTA;

通达信黑马强牛指标公式

 

相关文章