在线检测未来函数

通达信水手导航版主图指标公式

来源:Internet,编辑:股旁网,2013-01-17

N1:=5;
B6:=MA(C,240);
B5:=MA(C,120);
B4:=MA(C,60);
B3:=MA(C,20);
B2:=MA(C,10);
B1:=MA(C,5);
M5:=MA(CLOSE,5),LINETHICK1;
M10:=MA(CLOSE,10);
支撑压力线:=MA(CLOSE,20);
生命线:MA(CLOSE,60),COLORRED;
牛熊分界线:MA(CLOSE,120),COLOR009900;
年线:MA(CLOSE,240),COLORFF9900;
短期压力线:MA(C,10);
短期压力线1:HHV(短期压力线,2);
短期压力线2:短期压力线-(短期压力线1-短期压力线),COLORYELLOW;
DRAWICON(CROSS(ZIG(3,14),REF(ZIG(3,14),1)),LOW*0.98,1),COLORRED;
DRAWICON(CROSS(REF(ZIG(3,13),1),ZIG(3,13)),HIGH*1.01,2), COLORGREEN;
DIF:=EMA(CLOSE,50)-EMA(CLOSE,55);
DEA:=EMA(DIF,30);
趋势柱:=(DIF-DEA)*2, VOLSTICK ;
水手柱:=趋势柱-REF(趋势柱,1);
STICKLINE(水手柱>0.001,CLOSE,OPEN,1.5,1),COLORRED;
STICKLINE(水手柱<0.001,CLOSE,OPEN,1.5,0),COLORCYAN;
水手1:=MA(C,10);
水手2:=HHV(水手1,2);
水手短向:=水手1-(水手2-水手1);
DIF11:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA11:=EMA(DIF11,9);
趋势:=(DIF11-DEA11)*2;
水手背离线:=MA(趋势,N1),LINETHICK3;
A111:=EMA(C,12);
A211:=EMA(C,26);
方向1:=(A111+A211)/2;
方向2:=A111-A211;
导航线1:=方向1+方向2;
水手导航线:导航线1+水手背离线,COLORYELLOW,LINETHICK3;
DIF1:=EMA(CLOSE,40)-EMA(CLOSE,50);
DEA1:=EMA(DIF1,30);
趋势1:=(DIF1-DEA1)*2;
水手强弱线:=MA(趋势1,N1);
IF(水手强弱线>REF(水手强弱线,1),水手导航线,DRAWNULL),COLORRED,LINETHICK3;
IF(水手强弱线<REF(水手强弱线,1),水手导航线,DRAWNULL),COLORGREEN,LINETHICK3;

通达信水手导航版主图指标公式

 

相关文章