在线检测未来函数

通达信最优版RSI指标公式

来源:Internet,编辑:股旁网,2013-01-18

N:=14;N1:=3;N2:=34;K:=3;
LC:=REF(C,1);
RSII:=SMA(MAX(C-LC,0),14,1)/SMA(ABS(C-LC),14,1)*100,COLORRED,LINETHICK2;
压力:HHV(MA(RSII,3),13),COLORGREEN;
支撑:LLV(MA(RSII,3),13),COLORYELLOW;
VAR2:MA(RSII,8),COLOR888888;
VAR3:REF(VAR2,3),COLOR888888;
DRAWBAND(VAR2,RGB(0,124,24),RSII,RGB(255,0,0));
STICKLINE(VAR2>=VAR3,VAR3,VAR2,2,0),COLOR00FFFF;{DRAWNULL}
STICKLINE(VAR3>VAR2,VAR2,VAR3,2,0),COLORFFBB00};
RSI:RSII,COLORFFFFFF,LINETHICK2;
VAR4:IF(RSI<VAR2,RSI,VAR2),COLORRED,LINETHICK1;
AA:=REF(RSI,N1)=HHV(RSI,2*N1+1);
BB:=BACKSET(AA,N1+1);
CC:=FILTER(BB,N1) AND RSI=HHV(RSI,N1+1);
A1:=BARSLAST(REF(CC,1));
背离:=REF(CLOSE,A1+1)<CLOSE AND REF(RSI,A1+1)>RSI AND CC;
DRAWTEXT(顶背离,压力+1.5,'DBL'),COLORMAGENTA;
DRAWLINE(CC,RSI,FILTER(顶背离>0,5),RSI,0),COLORWHITE;
AA2:=REF(RSI,N1)=LLV(RSI,2*N1+1);
BB2:=BACKSET(AA2,N1+1);
CC2:=FILTER(BB2,N1) AND RSI=LLV(RSI,N1+1);
A2:=BARSLAST(REF(CC2,1));
{www.gupang.com 股旁网-通达信公式}
底背离:=REF(C,A2+1)>CLOSE AND REF(RSI,A2+1)<RSI AND CC2;
DRAWTEXT(底背离,支撑-1.5,'DBL'),COLORMAGENTA;
DRAWLINE(CC2,RSI,FILTER(底背离>0,5),RSI,0),COLORWHITE;

通达信最优版RSI指标公式

 

相关文章