在线检测未来函数

通达信血枫主力指标公式

来源:Internet,编辑:股旁网,2013-01-18

VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
{持币区域:VAR1,COLORFEDCBA;
持股区域:IF(VAR1>0,VAR1,0),COLORRED;}
短顶:STICKLINE(VAR1>9 AND FILTER(VAR1<REF(VAR1,1),5),VAR1+2,0,3,0),COLORGREEN;
大顶:STICKLINE(VAR1>20 AND FILTER(VAR1<REF(VAR1,1),5),VAR1+5,0,7,0),COLOR00FF00;
VAR2:=HHV(VAR1>20,10);
危险: STICKLINE(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR1+10,0,4,0);
注意止损:STICKLINE(VAR2 AND FILTER(VAR1< REF(VAR1,1),6)
AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VAR1+6,0,3,0);
短底:=STICKLINE(VAR1<-9 AND VAR1> REF(VAR1,1),VAR1-2,0,3,0),COLORRED;
大底:STICKLINE(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),VAR1-5,0,7,0),COLORYELLOW;
买入准备:VAR1<-9 AND VAR1>REF(VAR1,1),COLORWHITE;
DRAWTEXT(VAR1>9 AND FILTER(VAR1<REF(VAR1,1),5),VAR1+2,'短顶'),COLOR00FF00;
DRAWTEXT(VAR1>20 AND FILTER(VAR1<REF(VAR1,1),5),VAR1+5,'大顶'),COLORFFFF00;
DRAWTEXT(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR1+10,'危险'),COLOR00FFFF;
DRAWTEXT(VAR2 AND FILTER(VAR1< REF(VAR1,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VAR1+6,'注意止损'),COLORFF00FF;
DRAWTEXT(FILTER(VAR1<-9 AND VAR1>REF(VAR1,1),18),VAR1-2,'短底'),,COLOR0000FF;
DRAWTEXT(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),VAR1-5,'大底'),;
DRAWTEXT(FILTER(VAR1<-9 AND VAR1>REF(VAR1,1),18),1,'买入准备');
VAR3:=LLV(HIGH,240);
VAR4:=((100 * (CLOSE - VAR3)) / VAR3);
VAR5:=REF(LLV(CLOSE,480),1);
VAR6:=REF(HHV(CLOSE,480),1);
VAR7:=((100 * (CLOSE - VAR5)) / (VAR6 - VAR5));
VAR8:=(((CLOSE - LLV(CLOSE,981)) / (HHV(CLOSE,981) - LLV(CLOSE,981))) * 100);
VAR9:=(((CLOSE - LLV(CLOSE,393)) / (HHV(CLOSE,393) - LLV(CLOSE,393))) * 100);
VARA:=(((CLOSE - LLV(LOW,981)) / (HHV(HIGH,981) - LLV(LOW,981))) * 100);
VARB:=(((CLOSE - LLV(LOW,393)) / (HHV(HIGH,393) - LLV(LOW,393))) * 100);
VARC:=(EMA(((100 * (CLOSE - LLV(LOW,100))) / (HHV(HIGH,100) - LLV(LOW,100))),5) / 4);
VARD:=IF((DATE < 1031231),IF((VARC > 23.16),VARC,0),0);
VARE:=(VARC < 1);
VARF:=VARD;
VAR10:=((VAR4 < 0) AND (VAR7 < 0));
VAR11:=1;
VAR12:=((((HIGH + LOW) + (CLOSE * 2)) / 4) * VAR11);
VAR13:=EMA(VAR12,21); VAR14:=STD(VAR12,21);
VAR15:=((((((VAR12 - VAR13) / VAR14) * 100) + 200) / 4) * VAR11);
VAR16:=(((EMA(VAR15,89) - 25) * 1.56) * VAR11);
VAR17:=((EMA(VAR16,5) * 1.22) * VAR11);
VAR18:=(EMA(VAR17,3) * VAR11);
VAR19:=((3 * VAR17) - ((2 * VAR18) * VAR11));
VAR1A:=IF(((CROSS(VAR19,VAR17) AND CROSS(VAR19,VAR18)) AND CROSS(VAR17,VAR18)),1,0);
VAR1B:=IF(((CROSS(VAR17,VAR19) AND CROSS(VAR18,VAR19)) AND CROSS(VAR18,VAR17)),1,0);
买点:IF((FILTER(((((VAR8 = 0) AND VARE) AND VAR10) AND VAR1A),5) = 1),10,0),COLORRED;
卖点:IF((FILTER((((VAR8 = 100) AND VARF) AND VAR1B),5) = 1),10,0),COLORGREEN;
VAR1C:=(EMA(((100 * (CLOSE - LLV(LOW,100))) / (HHV(HIGH,100) - LLV(LOW,100))),13) / 4);
VAR1D:=(EMA(CLOSE,2) - EMA(CLOSE,89));
VAR1E:=EMA(VAR1D,30);
VAR1F:=((2 * (VAR1D - VAR1E)) * 10);
VAR20:=((POW(VAR1F,3) * 0.1) + POW(VAR1F,2));
VAR21:=SQRT(SQRT((((LOW * HIGH) * OPEN) * CLOSE)));
VAR22:=EMA((VAR21 * 0.97),3);
VAR23:=(((HIGH + LOW) + CLOSE) / 3);
VAR24:=((VAR23 - MA(VAR23,14)) / (0.015 * AVEDEV(VAR23,14)));
VAR25:=(IF(((YEAR < 2008) AND (VAR1F > 0.015)),VAR20,0) / 45);
庄拉线:VAR25,COLORYELLOW;
VAR26:=(EMA(CLOSE,2) - EMA(CLOSE,150)); VAR27:=EMA(VAR26,100);
VAR28:=(2 * (VAR26 - VAR27));
VAR29:=((POW(VAR28,3) * 0.1) + POW(VAR28,1));
VAR2A:=SQRT(SQRT((((LOW * HIGH) * OPEN) * CLOSE)));
VAR2B:=EMA((VAR2A * 0.97),3);
VAR2C:=(((HIGH + LOW) + CLOSE) / 3);
VAR2D:=((VAR2C - MA(VAR2C,14)) / (0.015 * AVEDEV(VAR2C,14)));
黑马线:=(IF((VAR28 > 0.1),VAR29,0) * 5),COLORRED;
量价线:(((CLOSE - MA(CLOSE,21)) / MA(CLOSE,21)) * 100),COLORFFFFFF;
VAR2E:=IF((FILTER(((量价线 > 0) AND (量价线 < 3)),5) = 1),12,0);
涨幅前兆:IF((FILTER(((((庄拉线 > 0) AND (庄拉线 < 0.5)) AND VAR2E) AND (VAR1C < 3)),10) = 1),10,0),COLORFFFFFF;
选股利器:IF((FILTER((((((((VAR2E > 0) AND (VAR1C < 2)) AND (庄拉线 > 0)) AND (庄拉线 < 1)) AND (黑马线 > 0)) AND (黑马线 < 1.5)) AND (VAR2E > 0)),5) = 1),10,0),COLORFF00FF; DRAWICON((买点 > 0),10,1); DRAWICON((卖点 > 0),10,2); DRAWICON((涨幅前兆 > 0),10,1);
DRAWICON((选股利器 > 0),5,1);
DRAWBAND(量价线,RGB(255,221,0),0,RGB(0,200,0));
IF(黑马线/2>=45,45,黑马线/2),COLORRED;
DRAWICON(ISLASTBAR=1 AND CROSS(量价线,0),0,11);
拉升开始:(5 * (((((((庄拉线 > 0.1) AND (COUNT((庄拉线 > 0.1),2) = 1)) AND (CLOSE >= OPEN)) AND (VOL > REF(VOL,1))) AND ((VOL / CAPITAL) > 0.003)) AND (量价线 > 1)) AND (量价线 > 黑马线))),LINETHICK2,COLOR00FFFF; DRAWICON((拉升开始 > 0),5,10);
量价主升浪:(8 * FILTER((CROSS(量价线,黑马线) AND (庄拉线 > 0.5)),7)),LINETHICK3,COLORFF00FF; DRAWICON((量价主升浪 > 0),8,8);
庄拉主升浪:(11 * ((CROSS(庄拉线,黑马线) AND (黑马线 > 0)) AND (量价线 > 0))),LINETHICK3,COLORFF00FF;
DRAWICON((庄拉主升浪 > 0),11,8);
{PJJ:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
JJ:=REF(EMA(PJJ,3),1);}
QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2))) + IF((CLOSE > OPEN),(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));
ZLL:=(VOL / CAPITAL);
HSL1:=IF((ZLL > 10),10,ZLL);
HSL:=((XVL / 20) / 1.15);
攻击流量:=(((HSL * 0.55) + (REF(HSL,1) * 0.33)) + (REF(HSL,2) * 0.22));
流量基线:=EMA(攻击流量,8);
LLJX:=EMA(攻击流量,3);
周流量:=SUM(LLJX,5);
BB1:=REF(周流量,1);
ZQZJJ:=(((周流量 - BB1) / BB1) * 100);
周增幅:=IF(((周流量 > 0) AND (BB1 < 0)),ABS(ZQZJJ),IF((((周流量 < 0) AND (BB1 < 0)) AND (周流量 < BB1)),(0 - ZQZJJ),ZQZJJ)),LINETHICK0;
{建仓减仓
A01:=IF(C>OPEN,VOL,0);
A02:=IF(C<OPEN,VOL ,0);
成交量:=MA(A01,10)/2000,COLORRED;
负成交量:=MA(A02,10)/2000,COLORGREEN;
DRAWTEXT(ISLASTBAR=1 AND CROSS(正成交量,负成交量),0,'♂进'),COLORFF00FF;
(正成交量-负成交量)*0.3,COLOR00C600;
0;}
X1:=EMA(C,7);
DRAWTEXT(ISLASTBAR=1 AND FILTER(MA(CLOSE,20) AND MA(CLOSE,10) AND COUNT(X1<REF(X1,1),5)>2 AND X1>REF(X1,1),3),5,'♂短进'),COLOR00C600;

通达信血枫主力指标公式

 

相关文章