在线检测未来函数

通达信新资金流向指标公式

来源:Internet,编辑:股旁网,2013-01-21

NOTEXT轴:0,COLOR4B4B4B;
PJJ:=DMA((H+L+C*2)/4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL/((H-L)*2-ABS(C-O));
XVL:=IF(C>O,QJJ*(H-L),IF(C<O,QJJ*(H-O+(C-L)),VOL/2))+IF(C>O,0-QJJ*(H-C+(O-L)),
IF(C<O,0-QJJ*(H-L),0-VOL/2));
ZLL:=VOL/CAPITAL;
HSL1:=IF(ZLL>10,10,ZLL);
HSL:=XVL/20/1.15;
攻击流量:=HSL*0.55+REF(HSL,1)*0.33+REF(HSL,2)*0.22;
GJJ:=EMA(攻击流量,8);
LLJX:=EMA(攻击流量,3);
流量:LLJX,COLORC875B7,NODRAW;
攻击力:HSL*0.4,NODRAW;
STICKLINE(流量>0,流量,0,2.3,0)COLOR0000FF;
STICKLINE(流量<0,流量,0,2.3,0),COLORFF4242;
流量基线:GJJ,COLOR00BBBB;
STICKLINE(HSL*0.4>=0,HSL*0.4*1.5,0,0,1)COLORYELLOW;
STICKLINE(HSL*0.4< 0,HSL*0.4*1.5,0,0,1)COLORGREEN;
ZJLL:=REF(LLJX,1);
QZJJ:=(((LLJX-ZJLL)/ZJLL)*100);
流量幅%:IF(((LLJX>0) AND (ZJLL<0)),ABS(QZJJ),IF((((LLJX<0) AND (ZJLL<0)) AND (LLJX<ZJLL)),(0-QZJJ),QZJJ))COLORWHITE,NODRAW;
力度:HSL/1000,COLOR9B37FF,NODRAW;
周流量:SUM(LLJX,5),COLORFFBFDF,NODRAW;
BB:=REF(周流量,1);
ZQZJJ:=(周流量-BB)/BB*100;
周幅%:IF(周流量>0 AND BB<0,ABS(ZQZJJ),IF(周流量<0 AND BB<0 AND 周流量<BB,-ZQZJJ,ZQZJJ))COLORWHITE,NODRAW;
{www.gupang.com 股旁网_通达信指标公式}
DRAWRECTREL(0,250,200,999.4,IF(120,RGB(10,0,0),0));
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),NODRAW;
大单:=(超B)-(超S),NODRAW;
大单:=(大B)-(大S),NODRAW;
中单:=(中B)-(中S),NODRAW;
小单:=(小B)-(小S),NODRAW;
DAZHI:=CONST(MAX(ABS(净流入),MAX(ABS(超大单),MAX(ABS(大单),MAX(ABS(中单),ABS(小单)))))),NODRAW;
DRAWRECTREL(0,CONST(830-(ABS(净流入)*500/DAZHI)),30,935,IF(CONST(净流入)>0,RGB(255,0,0{255,255,255}),RGB(23,125,255)));
DRAWRECTREL(40,CONST(830-(ABS(超大单)*500/DAZHI)),70,935,IF(CONST(超大单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(80,CONST(830-(ABS(大单)*500/DAZHI)),110,935,IF(CONST(大单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(120,CONST(830-(ABS(中单)*500/DAZHI)),150,935,IF(CONST(中单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(160,CONST(830-(ABS(小单)*500/DAZHI)),190,935,IF(CONST(小单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.002,0.98,0,'净流'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.040,0.98,0,'超大'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.080,0.98,0,'大单'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.120,0.98,0,'中单'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.160,0.98,0,'小单'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.05,0.25,0,'资金搏弈 (万元)'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.002,0.55,0,INTPART(净流入)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.040,0.55,0,INTPART(超大单)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.080,0.555,0,INTPART(大单)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.120,0.550,0,INTPART(中单)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.160,0.55,0,INTPART(小单)),COLORWHITE;

通达信新资金流向指标公式

 

相关文章