在线检测未来函数

通达信新资金进出指标公式

来源:Internet,编辑:股旁网,2013-01-21

N:=3;
K1:=IF(CLOSE>=REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW+CLOSE-REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW);
K2:=IF(CLOSE<=REF(CLOSE,1),OPEN-LOW+HIGH-CLOSE+REF(CLOSE,1)-CLOSE,OPEN-LOW+HIGH-CLOSE);
DT:=VOL*K1/(K1+K2);
KT:=(VOL-DT);
买量:SUM(DT,N),COLOR0000FF;
卖量:-SUM(KT,N),COLORFFFF00;
DRAWBAND(买量,RGB(0,120,0),0,DRAWNULL);
DRAWBAND(0,RGB(0,80,0),卖量,DRAWNULL);
进出量:买量+卖量,POINTDOT,COLOR00FFFF;
{www.gupang.com 股旁网_通达信指标公式}
净量换手:100*进出量/CAPITAL,POINTDOT,COLOR00FF33;
STICKLINE(进出量>=0,0,进出量,3,1),COLOR0000FF;
STICKLINE(进出量<0,0,进出量,3,1),COLORFFFF00;
D3:=100*SUM(DT,3)/CAPITAL;
K3:=100*SUM(KT,3)/CAPITAL;
J3:=D3-K3;
D6:=100*SUM(DT,6)/CAPITAL;
K6:=100*SUM(KT,6)/CAPITAL;
J6:=D6-K6;
D9:=100*SUM(DT,9)/CAPITAL;
K9:=100*SUM(KT,9)/CAPITAL;
J9:=D9-K9;
DAZHI:=CONST(MAX(ABS(D3),MAX(ABS(K3),MAX(ABS(J3),MAX(ABS(D6),MAX(ABS(K6),MAX(ABS(J6),MAX(ABS(D9),MAX(ABS(K9),ABS(J9)))))))))),NODRAW;
DRAWRECTREL(0,0,230,999.4,IF(120,RGB(100,100,100),0));
{3日画直方图}
DRAWRECTREL(38,CONST(830-(ABS(D3)*500/DAZHI)),51,935,IF(CONST(D3)>0,RGB(150,0,0),RGB(150,0,0)));
DRAWRECTREL(53,CONST(830-(ABS(K3)*500/DAZHI)),65,935,IF(CONST(K3)>0,RGB(0,150,150),RGB(0,150,150)));
DRAWRECTREL(68,CONST(830-(ABS(J3)*500/DAZHI)),80,935,IF(CONST(J3)>0,RGB(150,150,0),RGB(150,150,0)));
{6日画直方图}
DRAWRECTREL(100,CONST(830-(ABS(D6)*500/DAZHI)),112,935,IF(CONST(D6)>0,RGB(150,0,0),RGB(150,0,0)));
DRAWRECTREL(114,CONST(830-(ABS(K6)*500/DAZHI)),126,935,IF(CONST(K6)>0,RGB(0,150,150),RGB(0,150,150)));
DRAWRECTREL(128,CONST(830-(ABS(J6)*500/DAZHI)),140,935,IF(CONST(J6)>0,RGB(150,150,0),RGB(150,150,0)));
{9日画直方图}
DRAWRECTREL(160,CONST(830-(ABS(D9)*500/DAZHI)),172,935,IF(CONST(D9)>0,RGB(150,0,0),RGB(150,0,0)));
DRAWRECTREL(174,CONST(830-(ABS(K9)*500/DAZHI)),186,935,IF(CONST(K9)>0,RGB(0,150,150),RGB(0,150,150)));
DRAWRECTREL(188,CONST(830-(ABS(J9)*500/DAZHI)),200,935,IF(CONST(J9)>0,RGB(150,150,0),RGB(150,150,0)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.05,0.01,0,'资金进出统计'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.002,0.15,0,'名称'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.042,0.15,0,'买量'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.098,0.15,0,'卖量'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.160,0.15,0,'进出量'),COLORCYAN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.002,0.30,0,'今日'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.042,0.30,0,CONST(100*DT/CAPITAL)),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.098,0.30,0,CONST(100*KT/CAPITAL)),COLORGREEN;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.160,0.30,0,CONST(100*DT/CAPITAL-100*KT/CAPITAL)),COLORCYAN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.002,0.48,0,' 3日'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.042,0.48,0,CONST(D3)),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.098,0.48,0,CONST(K3)),COLORGREEN;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.160,0.48,0,CONST(J3)),COLORCYAN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.002,0.68,0,' 6日'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.042,0.68,0,CONST(D6)),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.098,0.68,0,CONST(K6)),COLORGREEN;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.160,0.68,0,CONST(J6)),COLORCYAN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.002,0.98,0,' 9日'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.042,0.98,0,CONST(D9)),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.098,0.98,0,CONST(K9)),COLORGREEN;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.160,0.98,0,CONST(J9)),COLORCYAN;

通达信新资金进出指标公式

 

相关文章