在线检测未来函数

大智慧均线面积主图指标公式

来源:Internet,编辑:股旁网,2013-01-22

MA5:MA(C,5);
MA10:MA(C,10);
均线差:=MA5-MA10;
JC:=MA10-MA5;
绿柱面积:=IF (均线差<0,SUM(均线差*0.1,BARSLAST(JC<0)),0);
红柱面积:=IF (均线差>0,SUM(均线差*0.1,BARSLAST(JC>0)),0);
均线面积:IF(均线差>0,红柱面积,绿柱面积),color0000ff,LINETHICK0;
A1:=IF(均线差>0,1,-1);
A2:=REF(A1,1);
A3:=A1*A2;
A4:=BARSLAST(A3<0);
A5:=A4+1;
趋势平均力度:(SUM(均线差,0)-REF(SUM(均线差,0),A5))/A5,colorFF00FF,LINETHICK0;
{www.gupang.com 股旁网_大智慧指标公式}
DRAWTEXT(ref(均线差,1)>0 and 均线差<=0 ,HHV(H,8),''+ref(红柱面积,1)),ALIGN2,colorred;
DRAWTEXT(ref(均线差,1)>0 and 均线差<=0 ,HHV(H,8),''+ref(趋势平均力度,1)),ALIGN1,VALIGN1,colorff00ff;
DRAWTEXT(ref(均线差,1)<0 and 均线差>=0 ,LLV(L,8),''+ref(abs(绿柱面积),1)),ALIGN2,Color00ff00;
DRAWTEXT(ref(均线差,1)<0 and 均线差>=0 ,LLV(L,8),''+ref(abs(趋势平均力度),1)),ALIGN1,VALIGN2,colorff00ff;
DRAWTEXT(BARSTATUS=2 AND 均线差<0,LLV(L,5),''+abs(绿柱面积)),align2,Color004A00;
DRAWTEXT(BARSTATUS=2 AND 均线差<0,LLV(L,5),''+abs(趋势平均力度)),align2,Colorff00ff;
DRAWTEXT(BARSTATUS=2 AND 均线差>0,HHV(H,5),''+abs(红柱面积)),align2,colorred;
DRAWTEXT(BARSTATUS=2 AND 均线差>0,HHV(H,5),''+abs(趋势平均力度)),align2,colorff00ff;

大智慧均线面积主图指标公式

 

相关文章