在线检测未来函数

通达信整合高级成交量指标公式

来源:Internet,编辑:股旁网,2013-01-22

1、主动买卖区分:当天收市价高过昨日收市价,成交量画红色实体加绿色实体(红色为当天主动买入量,绿色为当天主动卖出量);如果当天收市价低于昨天收市价则画绿色实体加红色实体 如果当天收市价低于昨天收市价则画蓝色实体加红色实体(红色为当天主动买入量,蓝色为当天主动卖出量) 3、均换手%表示近阶段周期内平均换手率。包括3天、5天、10天、20天、30天换手分析。 2、在成交量柱体中心如果看到暗红色竖线为成交资金异动。 4、两市涨跌家数,可适时分析大盘强弱。 5、倍量成交拐点。关注成交量变化。 6、虚拟成交量。 7、引入培量柱概念。

虚拟量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*210/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,虚拟量,0,2,-1),COLOR00C0C0;
总量:VOL,NODRAW;
TJ1:=H=L AND C>REF(C,1) OR C>REF(C,5) OR C>REF(C,9) OR C>REF(C,17);
TJ2:=H=L AND C<REF(C,1) OR C<REF(C,5) OR C<REF(C,9) OR C<REF(C,17);
EE:=IF(TJ1,0.0001,IF(TJ2,-0.0001,0)){对付一字涨停,并求极限};
JGL_DTC:=(C-OPEN+EE)/(2*(H-L)+ABS(C-O)+3*0.0001);
主买:VOL*(1+JGL_DTC)/2,COLORRED,NODRAW{主动买};
主卖:VOL*(1-JGL_DTC)/2,COLORFFFF80,NODRAW{主动卖};
总涨数:"SH000001$ADVANCE"+"SZ399001$ADVANCE",POINTDOT,COLORWHITE;
总跌数:"SH000001$DECLINE"+"SZ399001$DECLINE",POINTDOT,COLOR00FF00;
换手率:100*V/CAPITAL,COLORRED;
均换手率:=MA(VOL/CAPITAL*100,5),COLORYELLOW,NODRAW;
З换:SUM(100*V/CAPITAL,3),LINETHICK0;
5换:SUM(100*V/CAPITAL,5),LINETHICK0;
10换:SUM(100*V/CAPITAL,10),LINETHICK0;
20换:SUM(100*V/CAPITAL,20),LINETHICK0;
З0换:=SUM(100*V/CAPITAL,30),LINETHICK0;
BLZ:=VOL>REF(V,1)*1.9;
BLZ1:=VOL<REF(LLV(VOL,13),1);
BLZ2:=VOL<REF(LLV(VOL,55),1);
倍量柱:BLZ;
DRAWTEXT(倍量柱,VOL*1.05,'倍'),COLORYELLOW;
{www.gupang.com 股旁网_通达信指标公式}
{HJZ:=(3*C+H+L+O)/6;
HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36;
HJZ3:=VOL==HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O;
黄金柱:FILTER(HJZ3,5),STICK;
DRAWTEXT(黄金柱,VOL*1.3,'黄'),COLORRED;}
MA5:=MA(V,5)COLORWHITE;
MA55:=MA(V,55)COLORYELLOW;
MA135:=MA(V,135)COLORGREEN;
STICKLINE(C>=REF(C,1) AND MA5<MA135 AND V<MA5,VOL,0,7,0),COLOR333333;
STICKLINE(C<REF(C,1) AND MA5<MA135 AND V<MA5,VOL,0,7,0),COLOR333333;
STICKLINE(IF(BARSCOUNT(C)=1,C<O,C<REF(C,1)),0,VOL,2,0),COLOR880000;
STICKLINE(IF(BARSCOUNT(C)=1,C<O,C<REF(C,1)),0,VOL,1,0),COLORBB0000;
STICKLINE(IF(BARSCOUNT(C)=1,C<O,C<REF(C,1)),0,VOL,0.5,0),COLORDD0000;
STICKLINE(IF(BARSCOUNT(C)=1,C<O,C<REF(C,1)),0,VOL,0.25,0)COLORFF0000;
STICKLINE(IF(BARSCOUNT(C)=1,C>=O,C>=REF(C,1)),0,VOL,2,0),COLOR008800;
STICKLINE(IF(BARSCOUNT(C)=1,C>=O,C>=REF(C,1)),0,VOL,1,0),COLOR00AA00;
STICKLINE(IF(BARSCOUNT(C)=1,C>=O,C>=REF(C,1)),0,VOL,0.5,0),COLOR00DD00;
STICKLINE(IF(BARSCOUNT(C)=1,C>=O,C>=REF(C,1)),0,VOL,0.25,0),COLOR00FF00;
STICKLINE(主买>0,0,主买,2,0),COLOR000088;
STICKLINE(主买>0,0,主买,1,0),COLOR0000AA;
STICKLINE(主买>0,0,主买,0.5,0),COLOR0000DD;
STICKLINE(主买>0,0,主买,0.25,0),COLOR0000FF;
IF(VOL/MA(VOL,60)*100>100,VOL,VOL/0),STICK,COLORWHITE;
量增价平转阳:=VOL>REF(V,1) AND ABS(C-REF(C,1))/REF(C,1)<=0.005;
量增价升买入:=VOL>REF(V,1) AND C>REF(C,1);
量平价升续买:=ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.05 AND C>REF(C,1);
量减价升持有:=VOL<REF(V,1) AND C>REF(C,1);
量减价平警戒:=VOL<REF(V,1) AND ABS(C-REF(C,1))/REF(C,1)<=0.005;
量减价跌卖出:=VOL<REF(V,1) AND C<REF(C,1);
量平价跌续卖:=ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.05 AND C<REF(C,1);
量增价跌弃卖:=VOL>REF(V,1) AND C<REF(C,1);
量梯级递增上:=VOL>REF(V,1) AND REF(V,1)>REF(VOL,2);
量梯级递减下:=VOL<REF(V,1) AND REF(V,1)<REF(VOL,2);
ZGD:=HHV(V,80)*1;
ZGD2:=CONST(ZGD);
情况1:=CONST(IF(量增价平转阳,1,0));
情况2:=CONST(IF(量增价升买入,1,0));
情况3:=CONST(IF(量平价升续买,1,0));
情况4:=CONST(IF(量减价升持有,1,0));
情况5:=CONST(IF(量减价平警戒,1,0));
情况6:=CONST(IF(量减价跌卖出,1,0));
情况7:=CONST(IF(量平价跌续卖,1,0));
情况8:=CONST(IF(量增价跌弃卖,1,0));
情况9:=CONST(IF(量梯级递增上,1,0));
情况10:=CONST(IF(量梯级递减下,1,0));
DRAWTEXT(情况1=1 AND CURRBARSCOUNT=60,ZGD2-(ZGD2*0.1),'量增价平'),COLORMAGENTA;
DRAWTEXT(情况2=1 AND CURRBARSCOUNT=60,ZGD2-(ZGD2*0.4),'量增价升'),COLORMAGENTA;
DRAWTEXT(情况3=1 AND CURRBARSCOUNT=60,ZGD2-(ZGD2*0.2),'量平价升'),COLORMAGENTA;
DRAWTEXT(情况4=1 AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.3),'量减价升'),COLORMAGENTA;
DRAWTEXT(情况5=1 AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.1),'量减价平'),COLORMAGENTA;
DRAWTEXT(情况6=1 AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.3),'量减价跌'),COLORMAGENTA;
DRAWTEXT(情况7=1 AND CURRBARSCOUNT=60,ZGD2-(ZGD2*0.2),'量平价跌'),COLORMAGENTA;
DRAWTEXT(情况8=1 AND CURRBARSCOUNT=60,ZGD2-(ZGD2*0.4),'量增价跌'),COLORMAGENTA;
DRAWTEXT(情况9=1 AND CURRBARSCOUNT=60,ZGD2-(ZGD2*0.5),'量梯递增'),COLORMAGENTA;
DRAWTEXT(情况10=1 AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.5),'量梯递减'),COLORMAGENTA;
STICKLINE(V>=3*REF(V,1),V/3,V/3,5.9,0),COLORWHITE;
STICKLINE(V>=2*REF(V,1),V/2,V/2,5.9,0),COLORYELLOW;

通达信整合高级成交量指标公式

 

相关文章