在线检测未来函数

通达信十有八九准确指标公式

来源:Internet,编辑:股旁网,2013-01-22

短期:100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),COLORWHITE;
中期:100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10)),COLORYELLOW;
中长期:100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20)),COLORMAGENTA;
长期:100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),COLORRED,LINETHICK2;
VARD:=SMA(((CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11)))*(100),4,1);
VARE:=SMA(((CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12)))*(100),4,1);
VARF:=SMA(((CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13)))*(100),4,1);
VAR10:=SMA(((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14)))*(100),4,1);
VAR11:=SMA(((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15)))*(100),4,1);
VAR12:=SMA(((CLOSE-LLV(LOW,16))/(HHV(HIGH,16)-LLV(LOW,16)))*(100),4,1);
VAR13:=SMA(((CLOSE-LLV(LOW,17))/(HHV(HIGH,17)-LLV(LOW,17)))*(100),4,1);
VAR14:=SMA(((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18)))*(100),4,1);
VAR17:=SMA(((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20)))*(100),4,1);
VAR18:=(HIGH+LOW+CLOSE)/(3);
VAR19:=(VAR18-MA(VAR18,14))/((0.015)*(AVEDEV(VAR18,14)));
VAR1A:=(VAR18-MA(VAR18,70))/((0.015)*(AVEDEV(VAR18,70)));
VAR1B:=IF((VAR19>=150) AND (VAR19<200) AND (VAR1A>=150) AND (VAR1A<200),(-10),0);
VAR1C:=IF((VAR19<=(-150)) AND (VAR19>(-200)) AND (VAR1A<=(-150)) AND (VAR1A>(-200)),10,0);
VAR1D:=((CLOSE-MA(CLOSE,13))/(MA(CLOSE,13)))*(100);
VAR1E:=100-ABS(VAR1D);
警1:IF((BARSCOUNT(CLOSE)<70),120,IF((VAR1A>=200) AND (VAR19>=150),(-15),VAR1B)+120),LINETHICK2,COLORCCFF66;
警2:IF((BARSCOUNT(CLOSE)<13),100,IF((VAR1E<88) AND (VAR1D>0),85,100)),LINETHICK2,COLORBLUE;
警3:IF((BARSCOUNT(CLOSE)<13),(-100),0-IF((VAR1E<92) AND (VAR1D<0),85,100)),LINETHICK2,COLORGREEN;
警4:IF((BARSCOUNT(CLOSE)<70),(-120),IF((VAR1A<=(-200)) AND (VAR19<=(-150)),15,VAR1C)-120),LINETHICK2,COLORCCFFCC;
{警戒区:}
VAR50:=(HIGH+LOW+CLOSE)/3;
VAR60:=(VAR50-MA(VAR50,10))/(0.015*AVEDEV(VAR50,10));
VAR70:=(VAR50-MA(VAR50,30))/(0.015*AVEDEV(VAR50,30));
VAR80:=IF(VAR60>=150 AND VAR60<200 AND VAR70>=150 AND VAR70<200,100,0);
VAR90:=IF(VAR60<=-150 AND VAR60>-200 AND VAR70<=-150 AND VAR70>-200,-100,VAR80);
VARK1:=3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1),3,1);
VARK2:=EMA(VARK1,3), COLORBLACK,COLORYELLOW;
{www.gupang.com 股旁网_通达信指标公式}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
J1:=REVERSE(J);
AA:=REF(MA(C,1),10)>REF(MA(C,60),10);
买点:CROSS(J,J1) AND AA;
STICKLINE(买点,0,-30,-12,0),COLOR0000FF;
STICKLINE(买点,-30,-60,-10,0),COLORWHITE;
STICKLINE(买点,-60,-80,-6,0),COLORYELLOW;
DRAWTEXT(买点,-40,'财神'),COLORFF00FF;
N:=5;
VAR1:4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2:8,COLORGREEN,LINETHICK0;
上升在即: IF(CROSS(VAR1,VAR2),-100,0),STICK,COLOR0000CC,LINETHICK2;
DRAWTEXT(CROSS(VAR1,VAR2),-100,'买'),COLOR00FFFF;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓区: IF((VARO7<10),80,100) ,COLOR00CCFF,LINETHICK1;
0,LINETHICK2 ,COLORFFCC00;

通达信十有八九准确指标公式

 

相关文章