在线检测未来函数

飞狐K线+量主图指标公式

来源:Internet,编辑:股旁网,2013-01-23

VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*10,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*10,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*10,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*10,5,1),3,1);
趋势:=EMA(VAR3,3);
VAR11:=(SMA(ABS(LOW-REF(LOW,1)),3,1))/(SMA(MAX(LOW-REF(LOW,1),0),3,1))*200;
VAR12:=HHV(VAR11,30)*8;
VAR13:=(MA(CLOSE,1)+MA(CLOSE,3)+MA(CLOSE,5)+MA(CLOSE,7)+MA(CLOSE,9))/5;
VAR14:=(MA(CLOSE,2)+MA(CLOSE,4)+MA(CLOSE,6)+MA(CLOSE,8)+MA(CLOSE,10))/5;
趋势线:趋势,color10000;
VAR16:=(MAX(EMA(VAR13,2)-EMA(VAR14,5),0))*8;
VAR17:=EMA(VAR16,5);
波浪峰:VAR17,STICK,colorFF00FF;
STICKLINE(VAR17<REF(VAR17,1),0,VAR17,1,0),colorFF00;
VAR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)/28.57;
VAR4:=EMA(VAR3,5);
VAR5:=3*VAR3-2*VAR4;
AA:=CROSS(VAR5,VAR3) AND VAR3<2.1 AND CLOSE>OPEN;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
STICKLINE(AA,1.2,0.5,5,1),colorFFFF;
DRAWTEXT(AA,1.8,'底'),ALIGN0,colorFF;
{www.gupang.com 股旁网_飞狐指标公式}
VAR1:=LLV(LOW,3)=LLV(LOW,120) AND CLOSE/REF(CLOSE,1)>=1.06;
VAR2:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR3:=CROSS(VAR2,-20);
VAR4:=COUNT(CLOSE/MA(CLOSE,48)<0.67,3) AND HIGH>LOW*1.06 AND CLOSE/COST(8)<0.8;
出击:VAR1 OR VAR3 OR VAR4,STICK,LINETHICK3,colorFFFFFF;
DRAWICON(出击,2,10);
BB:=(CLOSE-REF(OPEN,12.9))/28>0.0089*CLOSE;
AA:0.8*BB,STICK,LINETHICK2,colorFFFF;
BBB:=(CLOSE-REF(OPEN,25))/28>0.012*CLOSE;
AAA:-0.8*BBB,STICK,LINETHICK2,colorFFFFFF;
BBB:HHV(MA(HIGH,6),30),LINETHICK0,colorAAFF;
BB顶:HHV(MA(HIGH,6),60),LINETHICK0,colorFF;
G:EMA(CLOSE,5),LINETHICK0,colorFFFFFF;
DRAWTEXT(CROSS(G,BBB),G,'■'),ALIGN0,PXDN70,colorFFFFFF;
HHH:HHV(MA(HIGH,6),30),LINETHICK0,colorAAFF;
HH顶:HHV(MA(HIGH,6),60),LINETHICK0,colorFF;
GG:EMA(CLOSE,6.89),LINETHICK0,colorFFFFFF;
DRAWTEXT(CROSS(GG,HHH),GG,'■'),ALIGN0,PXDN30,colorFFFF;
VAR1:=(HIGH+LOW+CLOSE)/3;
VAR2:=(VAR1-MA(VAR1,14))/(0.015*AVEDEV(VAR1,14));
VAR3:=(VAR1-MA(VAR1,70))/(0.015*AVEDEV(VAR1,70));
VAR5:=IF(VAR2>=150 AND VAR2<200 AND VAR3>=150 AND VAR3<1,100,0);
测顶:-IF(VAR3>=200,0.4,VAR5),STICK,LINETHICK3,colorFF;
VAR10:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR11:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR12:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VAR13:=(VAR10+VAR11+VAR12)/3;
VAR14:=IF(VAR13<=-20,10,0);
VAR15:=HHV(VAR14,10);
VAR24:=LLV(LOW,36);
VAR25:=HHV(HIGH,30);
VAR26:=EMA((CLOSE-VAR24)/(VAR25-VAR24)*4,4)*25;
红底:STICKLINE(CROSS(MA(CLOSE,3),MA(CLOSE,5)) AND VAR15,1,0,8,0),colorFF;
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8);
上注01:STICKLINE(走势-AA6>85,0.3,0.1,15,1),ALIGN2,colorFFFF00;
下注01:STICKLINE(走势-AA6<-75,0.1,0.3,15,1),colorFF00;
下注02:STICKLINE(走势-AA6<-65,-0.4,-0.2,15,1),colorFFFF;
V11:=LLV(LOW,10);
V12:=HHV(HIGH,25);
价位线:=EMA((CLOSE-V11)/(V12-V11)*4,4);
卖出:STICKLINE(CROSS(3.5,价位线),1.5,1,2,0),LINETHICK0,colorFF00;
STICKLINE(CROSS(3.5,价位线),2,1.4,2,0),LINETHICK2,colorFFFFFF;
VAR1:=HHV(HIGH,3);
VAR2:=(IF(WINNER(1.1*CLOSE)<0,0,WINNER(1.1*CLOSE))-(IF(WINNER(0.9*CLOSE)<0,0,WINNER(0.9*CLOSE))))*100;
VAR3:=IF(VAR1<0,0,VAR1);
VAR4:=IF(VAR2<0,0,VAR2);
V1:=LLV(LOW,10);
V2:=HHV(HIGH,25);
价位线:=EMA((CLOSE-V1)/(V2-V1)*4,4);
买入:STICKLINE(CROSS(价位线,0.3),1.5,0,0,0),LINETHICK0,colorCCFF;
STICKLINE(CROSS(价位线,0.3),1.5,0,0,0),LINETHICK0,color80;
STICKLINE(CROSS(价位线,0.3),1.5,0,0,0),LINETHICK0,color99FF;
DRAWTEXT(CROSS(价位线,0.3),2.5,'买'),color99FF;
VARE:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VARF:=SMA(VARE,9,1)+100;
VAR10:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR11:=SMA(VAR10,3,1);
VAR12:=SMA(VAR11,3,1)+100;
VAR13:=VAR12-VARF;
VAR14:=ZIG(3,13);
顶11:STICKLINE(REF(VAR14,2)<REF(VAR14,1) AND VAR14<REF(VAR14,1),2,1.4,5,0),colorFFFF00;
M5:EMA(CLOSE,8),LINETHICK0,colorFFAA66;
M6:EMA(CLOSE,13),LINETHICK0,colorFFFFFF;
M7:MA(CLOSE,78),LINETHICK0,colorFFFF;
M8:EMA(M7,3),LINETHICK0,colorFFFF;
M9:EMA(M8,3),LINETHICK0,colorFFFF;
M11:EMA(M9,3),LINETHICK0,colorFFFF;
MA47:EMA(CLOSE,46),LINETHICK0,colorFFAA66;
MA60:EMA(CLOSE,60),LINETHICK0,colorFF0000;
Y:=(HIGH+LOW)/2;
AO:=MA(Y,5)-MA(Y,34);
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:=IF(TDU3<TUD3,REF(HHV(HIGH,2),TDU3),REF(LLV(LOW,2),TUD3));
JDU0:=REF(CLOSE,1)<=REF(UDGLINE,1) AND CLOSE>UDGLINE AND TDU0<TUD0;
JUD0:=REF(CLOSE,1)>=REF(UDGLINE,1) AND CLOSE<UDGLINE AND TUD0<TDU0;
JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
DRAWTEXT(JDU2,M9*0,'◆'),ALIGN0,PXDN20,colorFFFF;
DRAWTEXT(CROSS(M6,M11),M11*0,'◆'),ALIGN0,PXDN20,colorFF;
DRAWICON(CROSS(M6,M11),M11*0.98,12),ALIGN0,PXDN30;
DRAWTEXT(CROSS(M6,M11),M9,'←2'),PXDN35,colorFFFF;
DRAWICON(JDU2,M9*0.9,12);
DRAWTEXT(CROSS(M6,MA47),MA47,'←1'),PXDN40,colorFF00;
A1:EMA(CLOSE,10),LINETHICK0,colorFF;
B1:SMA(HIGH,21,2)*1.028,LINETHICK0,colorFFFFFF;
DRAWICON(CROSS(A1,B1),B1,12);
股线:=SMA(LOW,21,2)*1.05;
DRAWTEXT(CROSS(A1,B1),B1,'火山 '),ALIGN2,PXDN5,colorFFFF;
NN:CROSS(A1,B1),LINETHICK0;
DRAWICON(NN,HIGH,12),ALIGN2;
DRAWICON(CROSS(A1,B1),B1,12),ALIGN5,PXDN2;
A2:EMA(CLOSE,11),LINETHICK0,color10000;
B2:SMA(HIGH,21,2)*1.03,LINETHICK0,color10000;
DRAWICON(CROSS(A2,B2),B2,10),ALIGN0,PXDN2;
DRAWTEXT(CROSS(A2,B2),B2,' 爆发'),ALIGN1,colorFF;
NNN:CROSS(A2,B2),LINETHICK0;
DRAWICON(NNN,HIGH,10),ALIGN0;
DRAWICON(CROSS(A2,B2),B2,10),ALIGN5,PXDN2;
H1:EMA(CLOSE,8),LINETHICK1,colorFFFFFF;
H2:EMA(H1,20),LINETHICK1,colorFFFF;
STICKLINE(H1<H2,H1,H2,1,0.8),colorFF00;
ZDF:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
STICKLINE(ZDF>9.8,OPEN,CLOSE,6,0),colorFF;
STICKLINE(ZDF<-9.8,OPEN,CLOSE,6,0),colorFFFFFF;
VAR6:=EMA(CLOSE,5);
VAR7:=EMA(CLOSE,10);
VAR8:=EMA(CLOSE,20);
VAR9:=EMA(CLOSE,30);
VARA:=EMA(CLOSE,60);
VARB:=EMA(CLOSE,90);
VARC:=EMA(CLOSE,125);
VARD:=EMA(CLOSE,250);
VAR10:=1.809*LLV(LOW,250);
VAR11:=MA(CLOSE,10)-EMA(CLOSE,10)*100;
VAR12:=MA(VAR11,5);
VAR13:=3*(VAR12-VAR11);
VAR14:=((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*200-100)/2-REF(CLOSE,5);
VAR15:=SMA(SMA(VAR14,5,1),5,1);
VAR16:=MA(MA(VAR15,5),5);
VAR17:=3*VAR16-5*VAR15;
VAR18:=EMA(VAR17,10);
VAR19:=MA(CLOSE,20)/MA(CLOSE,20)-REF(CLOSE,20)/CLOSE*100;
VAR1A:=DMA(SMA(EMA(VAR19,5),5,1),VOL/REF(VOL,5));
VAR1B:=SMA(EMA(VAR19,10),5,1);
VAR1C:=(-100)*(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13));
VAR1D:=(-100)*(HHV(HIGH,8)-CLOSE)/(HHV(HIGH,8)-LLV(LOW,8));
VAR1E:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14,1);
VAR1F:=HIGH-REF(HIGH,1);
疯牛:DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,90),VOL),LINETHICK0,colorFF;
年线:DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,250),VOL),POINTDOT,LINETHICK0,color30CC00;
VAR20:=REF(LOW,1)-LOW;
VAR21:=SMA(IF(VAR1F>0 AND VAR1F>VAR20,VAR1F,0),14,1);
VAR22:=SMA(IF(VAR20>0 AND VAR20>VAR1F,VAR20,0),14,1);
VAR23:=VAR21*100/VAR1E;
VAR24:=VAR22*100/VAR1E;
VAR25:=SMA((ABS(VAR24-VAR23))/(VAR24+VAR23)*100,14,1);
VAR26:=(VAR25+REF(VAR25,6))/2;
DRAWTEXT(CROSS(VAR13,50) AND VAR6>VAR7 AND VAR7>VAR8 AND VAR8>VAR9 AND VAR9>VARA AND VARA>VARB AND VARB>VARC AND VARC>VARD AND 疯牛>VARD AND VAR19>VAR1A AND VAR1A>VAR1B AND VAR1B>-100 AND VAR1C>-20 AND VAR1D>-20 AND -30>VAR18 AND VAR18>VAR17 AND VAR23>VAR25 AND VAR25>VAR26 AND VAR26>VAR24,年线,'藏龙卧虎'),ALIGN4,colorFFFF;
DRAWTEXT(CROSS(VAR13,200) AND VAR6>VAR7 AND VAR7>VAR8 AND VAR8>VAR9 AND VAR9>VARA AND VARA>VARB AND VARB>VARC AND VARC>VARD AND VARD>年线 AND 年线>VAR10 AND VAR19>VAR1A AND VAR1A>VAR1B AND VAR1B>-100 AND VAR1C>-20 AND VAR1D>-20 AND VAR23>VAR25 AND VAR25>VAR26 AND VAR26>VAR24,年线,'牛'),ALIGN3,colorFFFF;
T:(46.18*EMA(CLOSE,10)-31.82*EMA(CLOSE,4))/14.36,LINETHICK0;
J:=SUM(VOL*CLOSE,5)/SUM(VOL,5);
Z:EMA(J,5),LINETHICK0,colorFFFFFF;
DRAWTEXT(CROSS(Z,T),T,'←'),ALIGN5,PXDN10,colorFF00;
VAR15:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR16:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR48:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR49:=(VAR15+2*VAR16+3*VAR48)/6;
VAR50:=MA(VAR49,3);
介入:IF(VAR50>9,1,0.85),LINETHICK0,colorFFFF00;
DRAWTEXT(VAR50>9,-0.8,'-'),ALIGN0,colorFFFF00;

飞狐K线+量主图指标公式

 

相关文章