在线检测未来函数

通达信好用的画线主图指标公式

来源:Internet,编辑:股旁网,2013-01-29

用法:1、当天选出红箭头,下午2.30当天买入,但要遵守以下规则。 2、选出的股请参照主图,红箭头在黄虚线下方大胆买入。 3、选出红箭 头上方有绿线压力免进。 4、选出红箭 头粉红线方向上,上方没有绿线压力可进。 5、主图黄虚线方向上证明给股是上升通道。 6、注释:主图有部份源码有未来。但红箭头是没有未来的。如同行觉得有参考价值给几个共享币,提示:股市有风险,操作请谨慎!

N:=20;P:=8;
GJ:=(C+H+L+O)/4;阻:=L+(GJ-L)+(C-L);支:=L+(C-GJ);
压力:REF(阻 , 1),NODRAW,COLOR00FF00;
支撑:REF(支 , 1),NODRAW,COLORYELLOW;
STICKLINE(ISLASTBAR,压力,压力,30,1),LINETHICK2,COLOR00FF00;
STICKLINE(ISLASTBAR,支撑,支撑,30,1),LINETHICK2,COLORYELLOW;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RRRSV:=SMA(下档线,3,1);KKK:=SMA(RRRSV,3,1);DDD:=((3 * RRRSV) - (2 * KKK));
JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);K24:=SMA(RSV24,3,1);D24:=((3 * RSV24) - (2 * K24));
顶部:=IF(CROSS(D24,DDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDD)))),COLORFFFFFF;
决策:IF(ISLASTBAR,顶部,DRAWNULL),COLORMAGENTA;
STICKLINE(ISLASTBAR ,决策,决策,60,1),LINETHICK3,COLORMAGENTA;
底部:=LLV(HIGH,30),COLOR00FF00;
超跌:IF(ISLASTBAR,底部,DRAWNULL),COLORRED;
STICKLINE(ISLASTBAR ,超跌,超跌,60,1),LINETHICK3,COLORRED;
风险参数:MA((MA(C,13)-MA(C,55))/MA(C,13)*100,1),NODRAW,COLORFFFF00;
波:=ZIG(3,P),COLORWHITE;
涨天:BARSLASTCOUNT(波>REF(波,1)),NODRAW,COLORRED;
VAR1:=(C-REF(C,涨天))/REF(C,涨天)*100;
涨幅%:IF(涨天>0,VAR1, DRAWNULL),NODRAW;
跌天:BARSLASTCOUNT(波<REF(波,1)),NODRAW,COLOR00FF00;
VAR2:=(C-REF(C,跌天))/REF(C,跌天)*100;
跌幅%:IF(跌天>0,VAR2, DRAWNULL),NODRAW;
{红}
STICKLINE(C>O,C,O,3,0),COLOR000077;
STICKLINE(C>O,C,O,2,0),COLOR000099;
STICKLINE(C>O,C,O,1,0),COLOR0000BB;
STICKLINE(C>O,H,L,0,0),COLOR0000FF;
{绿}
STICKLINE(C<O,C,O,3,0),COLOR007700;
STICKLINE(C<O,C,O,2,0),COLOR009900;
STICKLINE(C<O,C,O,1,0),COLOR00BB00;
STICKLINE(C<O,H,L,0,0),COLOR00FF00;
{浪}
{浪线6:DRAWLINE(H=HHV(H,6),H,L=LLV(L,6),L,0),LINETHICK2,COLORRED;
浪线6X:DRAWLINE(L=LLV(L,6),L,H=HHV(H,6),H,0),LINETHICK2,COLORRED;}
浪线7:DRAWLINE(H=HHV(H,7),H,L=LLV(L,7),L,0),LINETHICK2,COLORYELLOW;
浪线7X:DRAWLINE(L=LLV(L,7),L,H=HHV(H,7),H,0),LINETHICK2,COLORYELLOW;
{浪线21:DRAWLINE(H=HHV(H,21),H,L=LLV(L,21),L,0),LINETHICK2,COLORFF7F00;
浪线21X:DRAWLINE(L=LLV(L,21),L,H=HHV(H,21),H,0),LINETHICK2,COLORFF7F00;}
浪线35:DRAWLINE(H=HHV(H,35),H,L=LLV(L,35),L,0),LINETHICK2,COLORMAGENTA;
浪线35X:DRAWLINE(L=LLV(L,35),L,H=HHV(H,35),H,0),LINETHICK2,COLORMAGENTA;
{浪线49:DRAWLINE(H=HHV(H,49),H,L=LLV(L,49),L,0),LINETHICK2,COLORGREEN;
浪线49X:DRAWLINE(L=LLV(L,49),L,H=HHV(H,49),H,0),LINETHICK2,COLORGREEN; };
{趋势}
A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
DRAWLINE(D1,H,S11,H,1),COLORGREEN,CROSSDOT;
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
DRAWLINE(D2,L,U11,L,1),COLORRED,CIRCLEDOT;
M:=INTPART(3*N/5);
A12:=REF(H,M)=HHV(H,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1);
S112:=R112>REF(R112,1);
DRAWLINE(D12,H,S112,H,1),COLORGREEN,POINTDOT;
A22:=REF(L,M)=LLV(L,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1);
U112:=T112>REF(T112,1);
DRAWLINE(D22,L,U112,L,1),COLORRED,POINTDOT;
{www.gupang.com 股旁网_通达信指标公式}
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BB1:=0;
B1万元:=DVOL*DCLOSE/100;
B1差:=B1万元-REF(B1万元,1);
B2万元:=DVOL*DCLOSE/100;
B2比:=B2万元/REF(B2万元,1);
净流入万元:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(净流入万元,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
密码:(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
二日比:=密码/REF(密码,1);
选股:PMB AND 密码>REF(密码,1) AND 二日比>1,COLORRED,NODRAW;
{MA5:MA(C,5);MA10:MA(C,10);MA30:MA(C,30);}
DRAWNUMBER(选股=1 ,L,密码),COLORYELLOW;
DRAWICON(选股,L*0.975,1);

通达信好用的画线主图指标公式

 

相关文章