在线检测未来函数

通达信RSI之W底指标公式

来源:Internet,编辑:股旁网,2013-01-28

LC := REF(CLOSE,1);
快速:SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100,COLORFFFFFF;
RSI2:=SMA(MAX(CLOSE-LC,0),10,1)/SMA(ABS(CLOSE-LC),10,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),20,1)/SMA(ABS(CLOSE-LC),20,1)*100;
慢速:RSI3,COLOR00FF00,LINETHICK1;
IF(快速>=慢速,慢速,DRAWNULL), COLORFF00FF,LINETHICK2;
DRAWLINE(慢速>=HHV(慢速,21),慢速,慢速<=LLV(慢速,21),慢速,1),COLORCYAN;
RSIX:SMA(快速,3,1),COLORRED;
RSIY:=SMA(RSI2,3,1);
启动1:=CROSS(快速,25) AND RSIX<=50 AND COUNT(REF(RSIX,1)<REF(RSIX,2),3)>=2 AND RSIX>REF(RSIX,1);
启动2:=CROSS(快速,REF(RSIY,1)) AND RSIX<=58 AND COUNT(REF(RSIX,1)<REF(RSIX,2),3)>=2 AND RSIX>REF(RSIX,1);
抄底:IF(启动1 OR 启动2,20,0),COLORRED;
STICKLINE(启动1,0,35,2,1),COLORYELLOW;
STICKLINE(启动2,0,25,3,1),COLORMAGENTA;
加仓:=RSIX>45 AND 启动2 AND 快速/REF(快速,1)>1.25;
DRAWTEXT(加仓,30,'△加'),COLORMAGENTA;
{www.gupang.com 股旁网_通达信指标公式}
减仓0:=COUNT( REF(RSIX,1)>REF(RSIX,2),4 )>=3 AND RSIX<REF(RSIX,1) AND 快速/REF(快速,1)<0.8;
减仓1:=COUNT( CROSS(RSIX,快速),8)=3 AND RSIX<75 AND RSIX>50;
减仓:=FILTER(减仓0,2) OR FILTER(减仓1,4);
DRAWTEXT(减仓,70,'减'),COLORGREEN;
结束1:=CROSS(RSIX,快速) AND RSIX>72;
结束2:=CROSS(80,RSIX);
结束_ALL:=(结束1 AND NOT(结束2) ) OR 结束2;
DRAWICON(结束_ALL,85,4);
A2:=BARSLAST(REF(CROSS(快速,78),1));
B2:= A2<=10 AND REF(C,A2+1)<C AND REF(快速,A2+1)>快速 AND CROSS(快速,78);
背离:=FILTER(B2>0,5);
DRAWTEXT(顶背离,90,'顶背离'),COLORBLUE;
DRAWTEXT(减仓0 AND 顶背离 ,90,'清'),COLORGREEN;
{//以下设置W底}
A3:=BARSLAST(REF(CROSS(快速,25),1));
B3:=REF(C,A3+1)>C AND REF(快速,A3+1)<快速 AND CROSS(快速,25);
W底背离:=FILTER(B3>0,5) AND 抄底=20;
W底1:=COUNT( CROSS(快速,25),15)>=2 AND 抄底=20;
W底2:=A3>=2 AND A3<10 AND CROSS(快速,RSIX) AND RSIX<50 AND RSIX>=25;
W底:=( FILTER(W底1,2) OR FILTER(W底2,2) )AND NOT (W底背离);
DRAWTEXT(W底背离,30,'W底背离'),COLORRED;
DRAWTEXT(W底,40,'●W底'),COLORYELLOW;
高:80,POINTDOT,COLORFFBB00 ;
中轴:50,POINTDOT,COLORFFBB00 ;
底:25,POINTDOT,COLORWHITE;

通达信RSI之W底指标公式

 

相关文章