在线检测未来函数

通达信考虑买卖主图指标公式

来源:Internet,编辑:股旁网,2013-01-28

DRAWGBK(O>C,RGB(360,0,10),RGB(10,0,1),0,'01',0);
VAR6:=(2*C+H+L)/4;
VAR8:=LLV(L,34);
VARA:=HHV(H,34);
BM:=EMA((VAR6-VAR8)/(VARA-VAR8)*100,3);
BM1:=EMA(BM,3);
AA:=BM-BM1>=0;
BB:=BM-BM1<0;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
支撑:REFDATE(V2,DATE),DOTLINE,LINETHICK1,COLORFF0080;
阻力:REFDATE(V3,DATE),DOTLINE,LINETHICK1,COLOR676767;
M20:=MA(C,18);
乖离20:=ABS((2*C+H+L)/4-M20)/M20;
乖离线:=DMA(CLOSE,乖离20);
止盈:乖离线*1.06,COLOR00FFFF,LINETHICK1;{20天均线乖离+6%}
止损:乖离线*0.94,COLOR00FF00,LINETHICK1;{20天均线乖离-6%}
DRAWBAND(止盈,RGB(0,0,255),乖离线,RGB(0,0,255));
DRAWBAND(乖离线,RGB(0,0,155),止损,RGB(0,0,155));
DRAWBAND(止盈,RGB(100,0,100),止盈*1.05,RGB(100,0,100));
DRAWBAND(止损,RGB(0,80,0),止损*0.95,RGB(0,180,0));
DMA(CLOSE,乖离20);
{www.gupang.com 股旁网_通达信指标公式}
乖离线*1.06,COLOR00FFFF,LINETHICK1;
乖离线*0.94,COLOR00FF00,LINETHICK1;
乖离线*1.06*1.05,COLOR0077FF,LINETHICK1;
乖离线*0.94*0.95,COLORFF9900,LINETHICK1;
{MA5}
重心:WMA((2*C+H+L)/4,2),COLOR00FFFF,LINETHICK0;
MA5:WMA(重心,5),COLOR00FF00,DOTLINE;
IF(MA5>REF(MA5,1),MA5,DRAWNULL),COLORRED,LINETHICK3;
DRAWICON(CROSS(AA,BB),(LOW * 0.93),34);
DRAWICON(CROSS(BB,AA),(H*1.06),35);
{K线}
STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND CLOSE>REF(CLOSE,1),LOW,HIGH,0.0,0),COLORRED;
STICKLINE(CLOSE<OPEN OR CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),LOW,HIGH,0.0,0),COLORCYAN;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR000088;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000AA;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLOR0000FF;
STICKLINE(C>=O,C,O,3.4,0),COLOR0000AA;
STICKLINE(C>=O,C,O,3.0,0),COLOR0000BB ;
STICKLINE(C>=O,C,O,2.4,0),COLOR0000CC;
STICKLINE(C>=O,C,O,2.0,0),COLOR0000DD ;
STICKLINE(C>=O,C,O,1.6,0),COLOR0000EE;
STICKLINE(C>=O,C,O,1.2,0),COLOR0000FF;
STICKLINE(C>=O,C,O,0.6,0),COLOR0000FF;
STICKLINE(C>=O,H,L,0,0),COLORRED;
STICKLINE(C<=O,C,O,3.4,0),COLORAAAA00;
STICKLINE(C<=O,C,O,3.0,0),COLORBBBB00;
STICKLINE(C<=O,C,O,2.4,0),COLORCCCC00;
STICKLINE(C<=O,C,O,2.0,0),COLORDDDD00;
STICKLINE(C<=O,C,O,1.6,0),COLOREEEE00;
STICKLINE(C<=O,C,O,1.2,0),COLORFFFF00;
STICKLINE(C<=O,C,O,0.6,0),COLORFFFF00;
STICKLINE(C<=O,H,L,0,0),COLORFFFF00;

通达信考虑买卖主图指标公式

 

相关文章