在线检测未来函数

通达信捕食者指标公式

来源:Internet,编辑:股旁网,2013-01-28

XVAR5:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
ZQX:=XVAR5+100,COLORRED,LINETHICK2;
XVAR6:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
CQX:=XVAR6+100,COLOR00FFFF,LINETHICK2;
买1:=MA(CLOSE,1);
卖1:=(LOW+HIGH+CLOSE)/3;
XVAR1:=MA(卖1,5);
XVAR2:=HHV(XVAR1,10);
DM:=IF(HHV((买1<XVAR2),5),100,85),COLORFFFF00,LINETHICK2;
MAI:=IF(HHV((买1<XVAR2),10),100,80),COLORGREEN,LINETHICK2;
DRAWBAND(100,RGB(0,250,250),DM,RGB(0,0,0));
DRAWBAND(100,RGB(240,240,0),MAI,RGB(0,0,0));
短卖:DM,COLORFF00FF,LINETHICK2;
卖:MAI,COLORYELLOW,LINETHICK2;
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) );
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);
XVAR3:=(((DMP ) * 100) / TR);
XVAR4:=((DMM * 100) / TR);
XXX:=(MA(((ABS((XVAR4 - XVAR3)) / (XVAR4 + XVAR3)) * 100),3));
买卖:=LLV(XVAR1,10);
DB:=IF(((XXX > 88) AND (XVAR3 < 5.8)),30,0),LINETHICK2,COLORFFFF00;
{www.gupang.com 股旁网_通达信指标公式}
DMAI:=IF(LLV((买1<买卖),5),15,0),COLORRED,LINETHICK3;
MAI2:=IF(LLV((买1<买卖),10),20,0),COLORFF00FF,LINETHICK3;
DRAWBAND(DB,RGB(240,240,240),0,RGB(0,0,0));
DRAWBAND(DMAI,RGB(240,0,0),0,RGB(0,0,0));
DRAWBAND(MAI2,RGB(240,0,240),0,RGB(0,0,0));
底部:DB,COLORFF00CC,LINETHICK3;
捕食1:DMAI,COLOR9933FF,LINETHICK2;
捕食2:MAI2,COLOR00DDFF,LINETHICK2;
A1:=REF(C,3);
A2:=SMA(MAX(C-A1,0),5,1)/SMA(ABS(C-A1),5,1)*1000;
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
A4:=A2-LLV(A2,10);
A5:=(MA(A4,2)*3+A4*13)/16;
A6:=IF(A5>13,MA(A5,2),A5)/6;
RSI1:=SMA(MAX(C-A1,0),6,1)/SMA(ABS(C-A1),6,1)*100;
RSI2:=SMA(MAX(C-A1,0),12,1)/SMA(ABS(C-A1),12,1)*100;
RSI3:=SMA(MAX(C-A1,0),24,1)/SMA(ABS(C-A1),24,1)*100;
压力:=HHV(MA(RSI2,3),12);
支撑:=LLV(MA(RSI2,3),12);
中间:(HHV(MA(RSI2,3),12)+LLV(MA(RSI2,3),12))/2,COLORRED,LINETHICK2;
短线:IF(CROSS(A6,1) AND (A6<30)AND RSI2<30 AND RSI2>=支撑 AND RSI2<中间,30,25),COLORMAGENTA,DOTLINE;
STICKLINE(RSI2<支撑,中间,RSI2,2,0)COLORGREEN;
STICKLINE(RSI2>=支撑 AND RSI2<中间,中间,RSI2,2,0)COLORLIBLUE;
STICKLINE(RSI2>=中间 AND RSI2<压力,中间,RSI2,2,0)COLORLIRED;
STICKLINE(RSI2>=压力,中间,RSI2,2,0)COLORRED;
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS ("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
DRAWTEXT(B3,RSI2,'底背');
B1:=RSI1>=RSI2 AND RSI2>=RSI3;
S1:=RSI1<RSI2 AND RSI2<RSI3;
BS1:=NOT(RSI1>=RSI2 AND RSI2>=RSI3)AND NOT(RSI1<RSI2 AND RSI2<RSI3);
STICKLINE(B1,100,105,2,1)COLORRED;
STICKLINE(S1,100,105,2,1)COLORGREEN;
STICKLINE(BS1,100,105,2,1)COLORYELLOW;
VAR1:=1/WINNER(CLOSE);
VAR2:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR3:=100-ABS(VAR2);
VAR4:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR5:=3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR6:=100-VAR5;
VAR7:=100-VAR4;
VAR8:=MA(WINNER(CLOSE*0.95)*100,3);
VAR9:=IF(VAR1>5,IF(VAR1<100,VAR1,VAR3-10),0);
VARA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VARB:=SMA(VARA,3,1);
VARC:=SMA(VARB,3,1);
VARE:=(-1)*(EMA(VAR7,12)-50)+50;
探索者1:EMA(3*VARB-2*VARC,3),COLORCYAN;
探索者2:MA(探索者1,3),COLORRED;
探索者3:MA(MA(探索者1,3),3),COLORBROWN;

通达信捕食者指标公式

 

相关文章