在线检测未来函数

飞狐量质变指标公式

来源:Internet,编辑:股旁网,2013-01-30

{量质变}
流通:CAPITAL/1000000,LINETHICK0,PRECISION2;
内外比:DYNAINFO(23)/DYNAINFO(22),COLORYELLOW,PRECISION1;
量比:V/(REF(MA(V,5),1)),COLORYELLOW,PRECISION1;
换手:VOL/CAPITAL*100,POINTDOT COLORMAGENTA,PRECISION0;
{FWH58地量买点}
地量rsv:=(close-llv(low,9))/(hhv(high,9)-llv(low,9))*100;
地量k:=sma(地量rsv,3,1);
地量d:=sma(地量k,3,1);
地量j:=3*地量k-2*地量d;
地量买点:IF(CROSS(0.9,1/VOL*1000>0.01 AND 地量j<0),1,0),COLORWHITE,LINETHICK0;
量:VOL,VOLSTICK;
V5:MA(VOL,5),COLORWHITE;
V35:MA(VOL,35)COLORYELLOW;
V135:MA(VOL,135);
AA:=VOL>REF(V,1)*1.9;
AA1:=VOL<REF(LLV(VOL,13),1);
AA2:=VOL<REF(LLV(VOL,55),1);
STICKLINE(AA,0,V,5,0),COLORYELLOW;
STICKLINE(AA1,0,V,5,0),COLORGREEN;
STICKLINE(AA2,0,V,5,0),COLORMAGENTA;
TJ1:=COUNT(V>REF(V,1)*1.9,4)=1;
TJ2:=COUNT(V<REF(V,1) AND L>MIN(L,4) AND L>REF(L,1),3)=3 ;
TJ3:=TJ1 AND TJ2;
STICKLINE(TJ3,0,V,5,0),COLORBLUE;
STICKLINE(地量买点=1,0,V*1.2,2,0),COLORWHITE;
DRAWTEXT(地量买点=1,V*1.3,'★'),COLORWHITE;
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN))*10;
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2)));
HSL:=(XVL/20)/1.15;
攻击:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
LLJX:=EMA(攻击,3);0,POINTDOT,COLORWHITE;
A1:SUM(LLJX,1),COLORCYAN;
A2:SUM(LLJX,2),COLORCYAN;
A3:SUM(LLJX,3),COLORCYAN;
A4:SUM(LLJX,4),COLORCYAN;
A5:SUM(LLJX,5),COLORCYAN;
A6:SUM(LLJX,6),COLORCYAN;
A7:SUM(LLJX,7),COLORCYAN;
A8:SUM(LLJX,8),COLORCYAN;
A9:SUM(LLJX,9),COLORCYAN;
A10:SUM(LLJX,10),COLORCYAN;
partline(a1>REF(a1,1),a1),COLORMAGENTA;
partline(a2>REF(a2,1),a2),COLORRED;
partline(a3>REF(a3,1),a3),COLORRED;
partline(a4>REF(a4,1),a4),COLORRED;
partline(a5>REF(a5,1),a5),COLORRED;
partline(a6>REF(a6,1),a6),COLORRED;
partline(a7>REF(a7,1),a7),COLORRED;
partline(a8>REF(a8,1),a8),COLORRED;
partline(a9>REF(a9,1),a9),COLORRED;
PARTLINE(a10>REF(a10,1),a10),COLORRED,LINETHICK3;
CC1:=IF(A1>REF(A1,1),1,0);
CC2:=IF(A2>REF(A2,1),1,0);
CC3:=IF(A3>REF(A3,1),1,0);
CC4:=IF(A4>REF(A4,1),1,0);
CC5:=IF(A5>REF(A5,1),1,0);
CC6:=IF(A6>REF(A6,1),1,0);
CC7:=IF(A7>REF(A7,1),1,0);
CC8:=IF(A8>REF(A8,1),1,0);
CC9:=IF(A9>REF(A9,1),1,0);
CC10:=IF(A10>REF(A10,1),1,0);
LS1:=MAX(MAX(A1,A2),MAX(A2,MAX(A3,MAX(A4,MAX(A5,MAX(A6,MAX(A7,MAX(A8,MAX(A9,A10)))))))));
LS2:=MIN(MIN(A1,A2),MIN(A2,MIN(A3,MIN(A4,MIN(A5,MIN(A6,MIN(A7,MIN(A8,MIN(A9,A10)))))))));
{www.gupang.com 股旁网_飞狐指标公式}
量线粘合度:ABS((LS1-LS2)/LS2)*100,LINETHICK0;
VAX2:=EMA(C,7);
VAR3:=EMA(C,14);
VAR4:=EMA(C,25);
VAR5:=2*(VAX2-VAR4);
VAR6:=2*(VAX2-VAR3);
VAR7:2*(VAR6+VAR5);
DRAWTEXT(CROSS(VAR7,0),V*1.1,'★'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HX:=(HIGH - REF(HIGH,1));
LX:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HX > 0) AND (HX > LX)),HX,0),10);
DMM:=SUM(IF(((LX > 0) AND (LX > HX)),LX,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
ZZ:=(AV + NEWVOL);
DRAWICON(CROSS(ZZ,0),v,1),COLORFF00FF;

飞狐量质变指标公式

 

相关文章