在线检测未来函数

通达信强势起爆主图指标公式

来源:Internet,编辑:股旁网,2013-01-30

{说明1:多用途_几何递增数列_强弱变色_均线;TDX版}; {说明2:均线显红为强势线;显原色为弱势线}; {说明3:弱势线在K线之上为强压力线、在下为弱支撑线}; {说明4:K线向下接近或击穿某均线仍显红色此为强支撑线};

开关色:=1;沉举中:=3;
QZ:=ABS(CLOSE);
DL:=IF(沉举中=1,1/QZ,IF(沉举中=2,QZ,1));
GL:=CLOSE*DL;
M5:SUM(GL,5)/SUM(DL,5);
M9:SUM(GL,9)/SUM(DL,9);
M14:SUM(GL,14)/SUM(DL,14);
M23:SUM(GL,23)/SUM(DL,23);
M37:SUM(GL,37)/SUM(DL,37);
M60:SUM(GL,60)/SUM(DL,60),LINETHICK2;
M97:SUM(GL,97)/SUM(DL,97);
M123:SUM(GL,123)/SUM(DL,123);{加密};
M157:SUM(GL,157)/SUM(DL,157);
M200:SUM(GL,200)/SUM(DL,200);{加密};
M254:SUM(GL,254)/SUM(DL,254);
M323:=SUM(GL,323)/SUM(DL,323);{加密};
{www.gupang.com 股旁网_通达信指标公式}
KK:=DRAWNULL{MA(C,256000)};KG:=开关色;{以下代码属均线变色部分};
K9:IF(KG=1 AND M9<=EMA(GL,9)/EMA(DL,9),M9,KK),COLOR113399,LINETHICK2;{近似月牛熊线};
K37:IF(KG=1 AND M37<=EMA(GL,37)/EMA(DL,37),M37,KK),COLOR113399,LINETHICK2;{近似周牛熊线};
K157:IF(KG=1 AND M157<=EMA(GL,157)/EMA(DL,157),M157,KK),COLOR113399,LINETHICK2;{近似日牛熊线};
K5:IF(KG=1 AND M5<=EMA(GL,5)/EMA(DL,5),M5,KK),COLOR113399;
K14:IF(KG=1 AND M14<=EMA(GL,14)/EMA(DL,14),M14,KK),COLOR113399;
K23:IF(KG=1 AND M23<=EMA(GL,23)/EMA(DL,23),M23,KK),COLOR113399;
K60:IF(KG=1 AND M60<=EMA(GL,60)/EMA(DL,60),M60,KK),COLOR113399,LINETHICK2;
K97:IF(KG=1 AND M97<=EMA(GL,97)/EMA(DL,97),M97,KK),COLOR113399;
K123:IF(KG=1 AND M123<=EMA(GL,123)/EMA(DL,123),M123,KK),COLOR113399;{加密};
K200:IF(KG=1 AND M200<=EMA(GL,200)/EMA(DL,200),M200,KK),COLOR113399;{加密};
K254:IF(KG=1 AND M254<=EMA(GL,254)/EMA(DL,254),M254,KK),COLOR113399;
K323:IF(KG=1 AND M323<=EMA(GL,323)/EMA(DL,323),M323,KK),COLOR113399;{加密};

通达信强势起爆主图指标公式

 

相关文章