在线检测未来函数

通达信绝底进场指标公式

来源:Internet,编辑:股旁网,2013-01-31

VAR1:=SMA(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),14,1);
VAR2:=(HIGH - REF(HIGH,1));
VAR3:=(REF(LOW,1) - LOW);
VAR4:=SMA(IF(((VAR2 > 0) AND (VAR2 > VAR3)),VAR2,0),12,1);
VAR5:=SMA(IF(((VAR3 > 0) AND (VAR3 > VAR2)),VAR3,0),12,1);
VAR6:=((VAR4 * 100) / VAR1);
VAR7:=((VAR5 * 100) / VAR1);
VAR8:=SMA(((ABS((VAR7 - VAR6)) / (VAR7 + VAR6)) * 100),12,1);
VAR9:=((VAR8 + REF(VAR8,5)) / 2);
VARA:=((SUM((HIGH - OPEN),12) / SUM((OPEN - LOW),12)) * 100);
VARB:=((SUM(MAX(0,(HIGH - REF(CLOSE,1))),12) / SUM(MAX(0,(REF(CLOSE,1) - LOW)),12)) * 100);
VARC:=((AMOUNT / VOL) / 100);
VARD:=(((((3 * HIGH) + LOW) + OPEN) + (2 * CLOSE)) / 7);
VARE:=((SUM(AMOUNT,5) / VARC) / 100);
VARF:=((SUM(AMOUNT,13) / VARC) / 100);
VAR10:=((SUM(AMOUNT,34) / VARC) / 100);
VAR11:=((SUM(AMOUNT,209) / VARC) / 100);
VAR12:=(((REF(VOL,1) + REF(VOL,2)) + REF(VOL,3)) + REF(VOL,4));
VAR13:=(VAR12 / CAPITAL);
VAR14:=(((VOL / CAPITAL) * VARD) + (VAR13 * REF(VARC,1)));
VAR15:=DMA(VARD,(VOL / VARE));
VAR16:=DMA(VARD,(VOL / VARF));
VAR17:=DMA(VARD,(VOL / VAR10));
VAR18:=DMA(VARD,(VOL / CAPITAL));
VAR19:=MA(HHV(HIGH,488),18);
VAR1A:=MA(HHV(HIGH,220),18);
VAR1B:=MA(HHV(HIGH,98),18);
VAR1C:=MA(LLV(LOW,488),18);
VAR1D:=MA(LLV(LOW,220),18);
VAR1E:=MA(LLV(LOW,98),18);
VAR1F:=MA((((((((VAR1C * 0.96) + (VAR1D * 0.96)) + (VAR1E * 0.96)) + (VAR19 * 0.558)) + (VAR1A * 0.558)) + (VAR1B * 0.558)) / 6),18);
VAR20:=MA((((((((VAR1C * 1.25) + (VAR1D * 1.23)) + (VAR1E * 1.2)) + (VAR19 * 0.55)) + (VAR1A * 0.55)) + (VAR1B * 0.65)) / 6),18);
VAR21:=MA((((((((VAR1C * 1.3) + (VAR1D * 1.3)) + (VAR1E * 1.3)) + (VAR19 * 0.68)) + (VAR1A * 0.68)) + (VAR1B * 0.68)) / 6),18);
VAR22:=MA((((((VAR1F * 3) + (VAR20 * 2)) + VAR21) / 6) * 1.738),18);
VAR23:=IF((DATE <= 1031231),VAR22,(VAR22 * DAY));
VAR24:=LOW;
VAR25:=REF(LOW,1);
VAR26:=((SMA(ABS((VAR24 - VAR25)),3,1) / SMA(MAX((VAR24 - VAR25),0),3,1)) * 100);
VAR27:=MA(IF(((CLOSE * 1.35) <= VAR23),(VAR26 * 10),(VAR26 / 10)),3);
VAR28:=LLV(LOW,30);
VAR29:=HHV(VAR27,30);
VAR2A:=IF((LOW <= VAR28),((VAR27 + (VAR29 * 2)) / 2),0);
VAR31:=MA(HHV(HIGH,488),18);
VAR32:=MA(HHV(HIGH,220),18);
VAR33:=MA(HHV(HIGH,98),18);
VAR34:=MA(LLV(LOW,488),18);
VAR35:=MA(LLV(LOW,220),18);
VAR36:=MA(LLV(LOW,98),18);
VAR37:=MA((((((((VAR34 * 0.96) + (VAR35 * 0.96)) + (VAR36 * 0.96)) + (VAR31 * 0.558)) + (VAR32 * 0.558)) + (VAR33 * 0.558)) / 6),18);
VAR38:=MA((((((((VAR34 * 1.25) + (VAR35 * 1.23)) + (VAR36 * 1.2)) + (VAR31 * 0.55)) + (VAR32 * 0.55)) + (VAR33 * 0.65)) / 6),18);
VAR39:=MA((((((((VAR34 * 1.3) + (VAR35 * 1.3)) + (VAR36 * 1.3)) + (VAR31 * 0.68)) + (VAR32 * 0.68)) + (VAR33 * 0.68)) / 6),18);
VAR40:=MA((((((VAR37 * 3) + (VAR38 * 2)) + VAR39) / 6) * 1.738),18);
VAR41:=VAR40;
VAR42:=LOW;
VAR43:=REF(LOW,1);
VAR44:=((SMA(ABS((VAR42 - VAR43)),3,1) / SMA(MAX((VAR42 - VAR43),0),3,1)) * 100);
VAR45:=MA(IF(((CLOSE * 1.35) <= VAR41),(VAR44 * 10),(VAR44 / 10)),3);
VAR46:=LLV(LOW,30);
VAR47:=HHV(VAR45,30);
VAR49:=IF((LOW <= VAR46),((VAR45 + (VAR47 * 2)) / 2),0);
提示:MA((VAR49 AND (CLOSE < COST(1))),3),,COLORFFFFFF;
买入:MA(VAR2A AND (CLOSE < COST(1)),3)
AND ((CLOSE - VAR16) / VAR16) * 100 < (2 - 13),COLORFFFA00;
趋势:=(EMA(((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1))),5) / 100);
欢喜:IF((((((((REF(CLOSE,13) - CLOSE) / REF(CLOSE,13)) * 100) > 15) AND ((SUM((VOL / CAPITAL),13) * 100) < 18)) AND (((VOL / CAPITAL) * 100) < 2.5)) AND ((((REF(CLOSE,1) - CLOSE) / REF(CLOSE,1)) * 100) < 8)),0.7,0),,COLORFFCC66;
V2:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
V3:=(MA(VOL,2) / MA(VOL,10));
V4:=(VOL / CAPITAL);
A1:=((((0.0068 * V2) - (0.0072 * V3)) - (0.5676 * V4)) - 0.0105);
A2:=((((0.0015 * V2) - (0.0124 * V3)) + (1.7461 * V4)) - 0.0074);
A3:=((((0 - (0.0003 * V2)) + (0.047 * V3)) - (0.5734 * V4)) - 0.0549);
B1:=(((CLOSE - MA(CLOSE,27)) / MA(CLOSE,27)) < (0 - 0.16));
翻番:STICKLINE(B1,0,0.5,2,0),,COLORFFAAFF;
RG1:=MA(CLOSE,27);
RG2:=((CLOSE - RG1)/(RG1))*(100);
RG3:=MA(RG2,2);
RG4:=BARSLAST((CROSS((-10),RG3) = 1));
RG5:=(RG3 < (-10)) AND (RG4 > 3);
V1:=C/REF(MA(C,36),6)*10;
RF1:=EMA(CLOSE,3);
RF2:=((SMA(MAX((CLOSE - RF1),0),9,1) / SMA(ABS((CLOSE - RF1)),9,1)) * 100);
RF3:=((100 - (3 * SMA((((CLOSE - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1))) + (2 * SMA(SMA((((CLOSE - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1),21,1)));
RF4:=((100 - (3 * SMA((((OPEN - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1))) + (2 * SMA(SMA((((OPEN - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1),21,1)));
RF5:=((((HHV(HIGH,21) - CLOSE) / (HHV(HIGH,21) - LLV(LOW,21))) * 100) - 10);
RF6:=(((CLOSE - LLV(LOW,21)) / (HHV(HIGH,21) - LLV(LOW,21))) * 100);
RF7:=SMA(SMA(RF6,16,8),25,8)-SMA(RF5,30,8);
K0:=IF((RF2< 14) AND L<REF(L,1) AND V1<8.8 AND RF7<-65,50,0);
K1:=IF(K0>1 AND C>O,50,0),STICK,COLOR10FFFF,LINETHICK3;
K2:=IF(K0>1 AND C/L>1.045,50,0);
K3:=IF(REF(K0,1)>0 AND K0=0,10,0);
准备1:IF(K0>3 AND RG5=0,1.25,0),STICK,COLOR10FFFF,LINETHICK3;
K4:=IF(MAX(MAX(K1,K2),K3) AND REF(准备1,1)>0,30,0);
进场1:IF(K4>0 AND REF(K4,1)=0,1.75,0),STICK,COLOR00FF00,LINETHICK3;
{www.gupang.com 股旁网_通达信指标公式}
DRAWTEXT(进场1,1.75,进场1),COLOR10FF10;
DRAWTEXT(准备1,1.25,准备1),COLOR10FFFF;
准备2:IF(K0>3 AND RG5>0,1.5,0),STICK,COLORFF00FF,LINETHICK3;
K5:=IF(MAX(MAX(K1,K2),K3) AND REF(准备2,1)>0,30,0);
进场2:IF(K5>1 AND REF(K5,1)=0,2,0),STICK,COLORFFFF00,LINETHICK3;
DRAWTEXT(进场2,2,进场2),COLORFFFF00;
DRAWTEXT(准备2,1.5,准备2),COLORFF00FF;

通达信绝底进场指标公式

 

相关文章